Bug 209267 - Firstboot crash on firewall configuration, when setting it to disabled
Firstboot crash on firewall configuration, when setting it to disabled
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Chris Lumens
:
: 209268 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-04 02:53 EDT by Vedran Miletić
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 09:16:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vedran Miletić 2006-10-04 02:53:41 EDT
This happens in FC6 Prerelease, I'm pretty sure it didn't happen in test3.

Description of problem:
Firstboot crashes (and I get GDM login shortly after that) if I change setting 
to disabled on Firewall configuration page.

Version-Release number of selected component (if applicable):
Whichever is in FC6Pre, I haven't updated anything.

Additional info:
This happens on i386, haven't tried anywhere else.
Comment 1 Vedran Miletić 2006-10-04 02:56:18 EDT
*** Bug 209268 has been marked as a duplicate of this bug. ***
Comment 2 Chris Lumens 2006-10-04 11:31:39 EDT
Are you getting a /tmp/firstboot-crash.log file that you can attach to this bug?
Comment 3 Vedran Miletić 2006-10-05 07:06:43 EDT
Sorry, I can't reproduce it after booting second time (logically, it didn't set
firstboot to done if it crashed). I will try to reinstall and see.
Comment 4 Vedran Miletić 2006-10-11 08:32:57 EDT
OK, this still happens.
firstboot-1.4.23-1
firstboot-tui-1.4.23-1

What I did was the following:
1. Reinstall FC6.
2. Before first starting it, set /etc/sysconfig/firstboot to *not* run 
firstboot.
3. Get in, log in as root. Do a "yum update firstboot firstboot-tui"
4. rm /etc/sysconfig/firstboot
5. Reboot. Firstboot appears, it's centered nicely and everything.

However:
1. Keyboard does not work. This was bug 208620, and it's supposed to be fixed 
if firstboot is centered, however it's not in my case.
2. It crashes on clicking the firewall (enabled/disabled) dropdown and I'm not 
getting any /tmp/firstboot-crash.log

Can I help anyhow else?
This is an x86 laptop Toshiba Satellite 1410 (non-mobile Celeron 2.2GHz, NV GF4 
420 Go, standard keyboard, Alps touchpad).
Comment 5 Chris Lumens 2006-10-11 13:46:44 EDT
I'm still unable to reproduce this.  What sort of choices do you make during
installation?  I'm thinking that one of the installation parameters is causing
this, but I'm not seeing it because I have been choosing defaults.
Comment 6 Vedran Miletić 2006-10-11 16:24:35 EDT
I'm using default parameters. I didn't change anything other than:
1. Keyboard -> Croatian
2. Location -> Croatia/Zagreb
3. Disabled starting ethernet card on boot and used a custom hostname.
Everything else is default.

If I additionally set language to Croatian during installation, crash doesn't occur.

Also, note that crash doesn't occur next time firstboot runs. Only first time.

Any ideas?
Any ideas about keyboard not working while it is supposed to?
Comment 7 Chris Lumens 2006-10-12 13:42:08 EDT
firstboot-1.4.22-1 is the version you've got right now, correct?  You can use
rpm -q firstboot to determine that.  Please upgrade to firstboot-1.4.23-1 from
development and see if this fixes some of your problems.  I believe at the least
the keyboard problem will be solved and I'm unreasonably hopeful that this
mysterious s-c-sl crash will disappear too, even though I know that won't happen.
Comment 8 Vedran Miletić 2006-10-13 12:34:07 EDT
> OK, this still happens.
> firstboot-1.4.23-1
> firstboot-tui-1.4.23-1

I was using 1.4.23 when I reproduced it for second time. Both keyboard didn't
work and it crashed. However, note that I *did*not* upgrade anything other than
firstboot, so I'm using everything else from FC6 Prerelease.
Comment 9 Vedran Miletić 2006-10-18 04:11:20 EDT
Sorry for bugspam, but do you have any ideas? I would like this to be fixed
before Fedora Core 6.
Comment 10 Chris Lumens 2006-10-18 09:42:26 EDT
Nope, no ideas.  I am completely unable to reproduce this bug despite a lot of
trying.
Comment 11 Chris Lumens 2006-10-19 14:52:32 EDT
I believe there were some problems with rhgb, selinux, and X keyboards that were
discovered right before FC6 and hopefully fixed before the release.  Please try
again with FC6 final and let me know if this is still happening.  I know that's
a pretty lame answer, but I'm not having any luck reproducing this over here and
therefore I don't know what to do about it.  Thanks.
Comment 12 Vedran Miletić 2006-11-01 09:16:04 EST
Can't reproduce it with FC6. Fantastic work! Thanks a lot.

Note You need to log in before you can comment on or make changes to this bug.