Bug 209630 - Cannot browse specific website with newer kernels
Cannot browse specific website with newer kernels
Status: CLOSED DUPLICATE of bug 207373
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Miller
Brian Brock
http://www.beertools.dk
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-06 10:39 EDT by Rasmus Ory Nielsen
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 17:21:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test case. Expect script using telnet. (166 bytes, application/x-sh)
2006-10-08 11:27 EDT, Rasmus Ory Nielsen
no flags Details
Screenshot fc5 and fc4 inside VMware (246.45 KB, image/png)
2006-10-10 09:08 EDT, Rasmus Ory Nielsen
no flags Details

  None (edit)
Description Rasmus Ory Nielsen 2006-10-06 10:39:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; da-DK; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text

Description of problem:
When I visit http://www.beertools.dk the browser just hangs and finally reports "connection reset". The same website worked a few weeks ago. I have tested several different kernels on several machines, and to me it looks like the problem is the kernel. It doesn't matter which browser you are using. See output from telnet sessions below.

Version-Release number of selected component (if applicable):
kernel-smp-2.6.17-1.2187_FC5

How reproducible:
Always


Steps to Reproduce:
1. Visit http://www.beertools.dk running e.g. 2.6.17-1.2187_FC5
2.
3.

Actual Results:
It connects, but nothing is returned, just hangs, and finally returns "connection reset". 

Expected Results:
It should display the website.

Additional info:
Here is output from two telnet sessions from the same machine, but running different kernel versions.


[roni@fc5 ~]$ uname -r
2.6.17-1.2187_FC5smp
[roni@fc5 ~]$ telnet www.beertools.dk 80
Trying 62.61.157.174...
Connected to www.beertools.dk (62.61.157.174).
Escape character is '^]'.
GET / HTTP/1.1
host: www.beertools.dk

[and it hangs and outputs nothing until ...]

Connection closed by foreign host.
[roni@gbi-pc-128036 ~]$



And after rebooting into an older kernel



[roni@gbi-pc-128036 ~]$ uname -r
2.6.15-1.2054_FC5smp
[roni@gbi-pc-128036 ~]$ telnet www.beertools.dk 80
Trying 62.61.157.174...
Connected to www.beertools.dk (62.61.157.174).
Escape character is '^]'.
GET / HTTP/1.1
host: www.beertools.dk

HTTP/1.1 200 OK
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Content-Type: text/html
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Server: Microsoft-IIS/6.0
X-Powered-By: PHP/4.4.4
Set-Cookie: osCsid=3f78e4d3f699989f44fafcff416b7451; path=/; domain=www.beertools.dk
Date: Fri, 06 Oct 2006 14:21:42 GMT
Connection: close


<!doctype html public "-//W3C//DTD HTML 4.01 Transitional//EN">
[CUT CUT CUT]
</html>
Connection closed by foreign host.
[roni@gbi-pc-128036 ~]$


Everything works.


I have made some tests on different machines. Here is a summary:

Works:
kernel-2.6.12-2.3.legacy_FC3
kernel-2.6.15-1.2054_FC5
kernel-smp-2.6.15-1.2054_FC5
kernel-2.6.16-1.2096_FC5
FreeBSD 5.4-release-p20
FreeBSD 6.0-release-p13
FreeBSD 6.1-release-p8
Windows XP (I am told)

Does not work:
kernel-smp-2.6.17-1.2174_FC5
kernel-smp-2.6.17-1.2187_FC5
Todays fc6t3 kernel, (was it kernel-2.6.18-1.2741.fc6?)
Comment 1 Andre Robatino 2006-10-06 18:16:52 EDT
  I am able to get a response from www.beertools.dk with the 2187 kernel. 
However, I have a similar problem with another website, www.bu.edu.  I normally
can't get a response by telnetting to port 80 (though some other ports respond).
 However, if I configure my machine to do its own PPPoE login, then it works
(normally the PPPoE login is done by the router the machine is connected to). 
This problem has existed for me since at least March 2005, when I replaced my
DSL modem (which couldn't do the PPPoE login, so my computer had to do it) with
a DSL modem/router which did the login.
  Unfortunately, I need the router to do its own PPPoE login, to use a VoIP
phone adaptor.  Doing an additional login by the computer means I have 2 IPs
simultaneously which violates the terms of service of my ISP.
Comment 2 Rasmus Ory Nielsen 2006-10-08 11:03:13 EDT
#1
I do not think your problem is related to this bug. Perhaps lowering MTU in your
router will solve your problem.
Comment 3 Rasmus Ory Nielsen 2006-10-08 11:27:37 EDT
Created attachment 138007 [details]
Test case. Expect script using telnet.

Added test case. An expect script that uses telnet to check if you have
problems retrieving webpages from www.beertools.dk.
When running the script one of two things should happen.
1. You see HTML codes from the front page. You are not affected by this bug.
2. It hangs, and outputs nothing. :-(
Comment 4 Andre Robatino 2006-10-08 13:42:24 EDT
  I know the problem is OS-related (though maybe not exclusively the OS) since I
can access the same site in Windows XP using the same hardware with no problem,
and since I never told XP what my PPPoE username and password are, it can't be
doing its own login.
Comment 5 Rasmus Ory Nielsen 2006-10-10 09:08:47 EDT
Created attachment 138132 [details]
Screenshot fc5 and fc4 inside VMware

Screenshot showing the problem seen in fc5 (left side) and on the right, inside
the VMware window, fc4 showing http://www.beertools.dk without problems.
Comment 6 Dave Jones 2006-10-16 15:39:59 EDT
A new kernel update has been released (Version: 2.6.18-1.2200.fc5)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

In the last few updates, some users upgrading from FC4->FC5
have reported that installing a kernel update has left their
systems unbootable. If you have been affected by this problem
please check you only have one version of device-mapper & lvm2
installed.  See bug 207474 for further details.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

If this bug has been fixed, but you are now experiencing a different
problem, please file a separate bug for the new problem.

Thank you.
Comment 7 Rasmus Ory Nielsen 2006-10-16 16:55:08 EDT
I still see the problem with kernel 2.6.18-1.2200.fc5smp:

[roni@gbi-pc-128036 ~]$ uname -r
2.6.18-1.2200.fc5smp
[roni@gbi-pc-128036 ~]$ telnet www.beertools.dk 80
Trying 62.61.157.174...
Connected to www.beertools.dk (62.61.157.174).
Escape character is '^]'.
GET / HTTP/1.1
host: www.beertools.dk


Connection closed by foreign host.
[roni@gbi-pc-128036 ~]$

Please tell me how I can help debug this.
Comment 8 Dave Jones 2006-10-16 17:02:42 EDT
does it start working again if you

echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

?

Comment 9 Andre Robatino 2006-10-16 17:07:35 EDT
  It fixes mine!  I can access www.bu.edu at port 80 after this command.  If I
then set it back to the original value of 1, it fails again.  Why does this work?
Comment 10 Dave Jones 2006-10-16 17:21:05 EDT
broken router somewhere between your computer the target host that doesn't
handle window scaling correctly.

I'll bet that Rasmus has the same issue.

Theres no bug here, just more broken networking hardware..
Comment 11 Dave Jones 2006-10-16 17:22:20 EDT

*** This bug has been marked as a duplicate of 207373 ***
Comment 12 Andre Robatino 2006-10-16 17:36:36 EDT
  Two questions:

1) Any way to tell if the broken router is the one sitting on my desk (a Westell
327W)?

2) Any idea when window scaling will be the default in Windows, since presumably
that will be when the hardware gets fixed?
Comment 13 Rasmus Ory Nielsen 2006-10-16 17:41:10 EDT
(In reply to comment #8)
> does it start working again if you
> 
> echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

It works now! Thanks.
Comment 14 Dave Jones 2006-10-16 18:03:24 EDT
Andre: Unlikely, as that would mean every site would be inaccessable.

Note You need to log in before you can comment on or make changes to this bug.