Bug 212605 - Enabling desktop effects causes screen corruption
Enabling desktop effects causes screen corruption
Status: CLOSED DUPLICATE of bug 203282
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Airlie
:
: 215178 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-27 14:05 EDT by Greg Wasson
Modified: 2008-08-02 19:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 18:25:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Wasson 2006-10-27 14:05:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
When enabling "desktop-effects" using the ATI "radeon" driver, with display resolutions greater than 1024x768, the right ~1/5 of the desktop is missing (black bar). Also, all the panel text and icons are missing. I suspect anything over the 1024 pixels is not being displayed.

System is a Dell 600M with ATI Mobility 9000, 32M video card. Default resolution on install is 1400x1050 at 24 bit color depth.

If the resolution is set to 1024x768, system looks normal. Even at higher resolutions, desktop effects work properly (wobbly windows, spinning cube). Just screen is missing and panel is corrupt.

Version-Release number of selected component (if applicable):
metacity-2.16.0-5.fc6

How reproducible:
Always


Steps to Reproduce:
1. Install Fedora Core 6
2. Log into system
3. Enable desktop-effects

Actual Results:
Screen missing right hand side of background. Panels are missing text and icons.

Expected Results:
desktop should be properly displayed.

Additional info:
Comment 1 Jan Wildeboer 2006-10-30 07:38:37 EST
Workaround in my case (IBM X31 Laptop with radeon driver):

touch /etc/drirc

and add the following content to the file /etc/drirc:

<driconf>
  <device screen="0" driver="radeon">
    <application name="all">
      <option name="allow_large_textures" value="2" />
    </application>
  </device>
</driconf>

this does solve my problem.
Comment 2 Radu Radutiu 2006-10-31 10:21:00 EST
I see the same problem (or similar) on a laptop Compaq nx7010 with ATI Radeon
Mobility 9000 (although the sticker on the laptop says 9200) with 32 MB video
RAM. When the desktop is at the default resolution (1680x1050 24 bpp) desktop
effects work but the background remains dirty except for a small area in the top
left corner (you can see a screenshot at
http://picasaweb.google.com/rradutiu/FC6CompizProblem/photo#4992072458980687890 )
If I decrease the bpp to 16 the area where the background looks fine is actually
the left half of the screen at 1680x1050.  
Also when maximizing windows the maximum window size is the size of the area
where everything is ok and not the maximum screen size.
The above workaround does not work in my case.
Comment 3 Greg Wasson 2006-10-31 12:57:39 EST
The above workaround does not work for me either. If I add:

Option      "UseInternalAGPGART" "no"

to my /etc/X11/xorg.conf, I at least get the text back on the panels at the top
and bottom of the desktop, but still missing the right side of the display. My
desktop looks like the screenshot above, just less is missing due to a lower
resolution than above.
Comment 4 James Burke 2006-11-10 22:14:57 EST
This solved my problem as well. I have a Sony Vaio PCG-K33Q (i686) laptop and my
video card is an ATI Technologies Inc Radeon IGP 330M/340M/350M. I'm using the
open source built "radeon" in my xorg.conf file. The resolution on my laptop is
set to 1280x800 and a right-margin of the screen was "bad". Very similarly as
Jan describes, I also would add that 'maximizimzig' a window would fulfill my
left side of the screen up to this right-margin(in case this adds any more sense
for the debuggers) and that my mouse cursor displays well in this area. I too
got panel corruption. I wonder how anyone could figure this one out of the box.
Jan, where did you find out about this?

(In reply to comment #1)
> Workaround in my case (IBM X31 Laptop with radeon driver):
> 
> touch /etc/drirc
> 
> and add the following content to the file /etc/drirc:
> 
> <driconf>
>   <device screen="0" driver="radeon">
>     <application name="all">
>       <option name="allow_large_textures" value="2" />
>     </application>
>   </device>
> </driconf>
> 
> this does solve my problem.

Comment 5 Tim Mayberry 2006-11-12 20:36:51 EST
*** Bug 215178 has been marked as a duplicate of this bug. ***
Comment 6 Greg Wasson 2006-11-13 14:22:44 EST
After some google searches, I changed the "radeon" below to "r200" and now the
desktop effects are working properly at 1400x1050 resolution. I also dropped the
 color depth in X to 16 bit to get much improved performance with Desktop
effects enabled.

> Workaround in my case (IBM X31 Laptop with radeon driver):
> 
> touch /etc/drirc
> 
> and add the following content to the file /etc/drirc:
> 
> <driconf>
>   <device screen="0" driver="radeon">
>     <application name="all">
>       <option name="allow_large_textures" value="2" />
>     </application>
>   </device>
> </driconf>
> 
> this does solve my problem.
Comment 7 scott anderson 2006-11-14 22:41:17 EST
This fix doesn't work in my case. Anything else that they're workin on?
Comment 8 Matěj Cepl 2007-10-02 17:36:29 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 9 Matěj Cepl 2007-10-05 18:25:43 EDT

*** This bug has been marked as a duplicate of 203282 ***

Note You need to log in before you can comment on or make changes to this bug.