Bug 212787 - wrong permissions on /usr/share/compiz, /usr/lib/compiz
wrong permissions on /usr/share/compiz, /usr/lib/compiz
Status: CLOSED DUPLICATE of bug 233825
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-28 22:44 EDT by Ben Liblit
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 13:29:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Liblit 2006-10-28 22:44:39 EDT
+++ This bug was initially created as a clone of Bug #212093 +++

Description of problem:


Version-Release number of selected component (if applicable):

compiz-0.0.13-0.32.20060817git.fc6


How reproducible:

Consistently reproducible.


Steps to Reproduce:
1. remove the compiz rpm
2. manually remove /usr/share/compiz
3. reinstall the compiz rpm
4. as non-root, run the "desktop-effects" command

Actual results:

Desktop Effects preferences dialog fails to appear.  Instead, the following
diagnostic output is seen:

    (desktop-effects:5750): libglade-WARNING **: could not find glade file
    '/usr/share/compiz/desktop-effects.glade'

    ** (desktop-effects:5750): WARNING **: Could not open
    /usr/share/compiz/desktop-effects.glade

Expected results:

Desktop Effects preferences dialog should have appeared.

Additional info:

The compiz package does not claim to own the "/usr/share/compiz" directory. 
This directory is created at package install time, but with permissions that do
not allow access by non-root users.  Incidentally, this will also cause the
directory to be left behind, empty, should compiz be uninstalled later.
Comment 1 Ben Liblit 2006-10-28 22:49:24 EDT
Directory "/usr/lib/compiz" has exactly the same problem.
Comment 2 Kristian Høgsberg 2007-04-16 13:29:50 EDT

*** This bug has been marked as a duplicate of 233825 ***

Note You need to log in before you can comment on or make changes to this bug.