Bug 212805 - Always in english (intl.locale.matchOS is false)
Always in english (intl.locale.matchOS is false)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
: 213400 221232 228064 (view as bug list)
Depends On:
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2006-10-29 03:34 EST by Remi Collet
Modified: 2007-11-30 17:11 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-19 17:34:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use proper language pack by default if available (1.14 KB, patch)
2007-03-11 09:08 EDT, Thorsten Leemhuis
no flags Details | Diff

  None (edit)
Description Remi Collet 2006-10-29 03:34:43 EST
Description of problem:
Creating a new profil result in a english interface.

Version-Release number of selected component (if applicable):
2.0-2.fc7 (run under FC6)

How reproducible:
always

Steps to Reproduce:
1. firefox -profilemanager
2. create a new profil
3. launch firefox
  
Actual results:
Interface in english

Expected results:
Interface in current locale

Additional info:
anout:config reports "intl.locale.matchOS = false"

It seems greprefs/all-redhat.js not used anymore
Changing the value in greprefs/all.js is a working workaround.
Changing the general.useragent.locale for the user is another (but poor) workaround.

Regards
Comment 1 Matthias Clasen 2006-10-30 18:54:43 EST
Chris, does this also affect 1.5.0.x in FC6 / RHEL5 ?
Comment 2 Christopher Aillon 2006-10-30 21:19:56 EST
No, those are fine...
Comment 3 Christopher Aillon 2006-11-01 10:29:02 EST
*** Bug 213400 has been marked as a duplicate of this bug. ***
Comment 4 Nicolas Mailhot 2007-01-06 05:22:35 EST
Even an old profile that used to be localized is in english now in firefox
Comment 5 Christoph Wickert 2007-01-06 07:23:54 EST
I wonder if this is related to
https://bugzilla.mozilla.org/show_bug.cgi?id=364599 ?

All I had to do was to change "general.useragent.locale" to my locale (which is
"de-DE").
Comment 6 Amanpreet Singh Brar Alamwalia 2007-01-06 14:12:26 EST
*** Bug 221232 has been marked as a duplicate of this bug. ***
Comment 7 Sertaç Ö. Yıldız 2007-02-09 12:15:18 EST
might this be due to the changes in /usr/bin/firefox?

adding SHORTMOZLOCALE (as in fc6) and modifying (correcting) the langpack path
when setting MOZLOCALE brings up localized firefox ui here.
Comment 8 Christopher Aillon 2007-02-09 12:17:16 EST
Hm, I thought I transfered those changes over but apparently not.  Thanks for
the investigation.  I'll add that to the next package.
Comment 9 Christopher Aillon 2007-02-09 16:05:33 EST
*** Bug 228064 has been marked as a duplicate of this bug. ***
Comment 10 Arkady L. Shane 2007-02-16 03:19:12 EST
Hm, for firefox 2.0.0.1-5.fc? i see that these changes don't take effect as
variable $MOZ_EXTENSIONS_DIR does not determine.

---
# check system locale
MOZARGS=
# Try without a local variant first, then with a local variant
# So that pt-BR doesn't try to use pt for example
SHORTMOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*||g"`
[ -f
$MOZ_EXTENSIONS_DIR/langpack-${SHORTMOZLOCALE}@firefox.mozilla.org/chrome/$SHORTMOZLOCALE.jar
] && MOZARGS="-UILocale $SHORTMOZLOCALE"

MOZLOCALE=`echo $LANG | sed "s|_\([^.]*\).*|-\1|g"`
[ -f
$MOZ_EXTENSIONS_DIR/langpack-${MOZLOCALE}@firefox.mozilla.org/chrome/$MOZLOCALE.jar
] && MOZARGS="-UILocale $MOZLOCALE"
---
Comment 11 Thorsten Leemhuis 2007-02-24 10:14:27 EST
(In reply to comment #10)
> Hm, for firefox 2.0.0.1-5.fc? i see that these changes don't take effect as
> variable $MOZ_EXTENSIONS_DIR does not determine.

Confirmed, still in english. The patch from Bug 228064 would have worked ;-)
Comment 12 Thorsten Leemhuis 2007-03-11 09:08:27 EDT
Created attachment 149790 [details]
use proper language pack by default if available 

(In reply to comment #11)
> Confirmed, still in english. The patch from Bug 228064 would have worked ;-)
Updated patch against cvs. Please apply.
Comment 13 Christopher Aillon 2007-04-19 17:34:56 EDT
This should have been fixed a few RPMs ago.

Note You need to log in before you can comment on or make changes to this bug.