Bug 214446 - Remote Desktop (VNC) does not update VNC Client when 'Desktop Effects' enabled
Remote Desktop (VNC) does not update VNC Client when 'Desktop Effects' enabled
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: vino (Show other bugs)
13
All Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
bzcl34nup
:
: 214448 505558 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-07 12:53 EST by Travis Brodeen
Modified: 2013-03-05 22:47 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-13 15:40:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Travis Brodeen 2006-11-07 12:53:46 EST
Description of problem:  
The screen does not refresh when connecting to a VNC Server (remote desktop) 
that has 'Desktop Effects' enabled.

When connecting to a Server with Desktop Effects enabled, a screen shot of the 
desktop is displayed in the client but never again updates.  You can monitor 
the Server's display and see that the mouse and keyboard function, however no 
output can be seen through the VNC client.

Version-Release number of selected component (if applicable):  Zod


How reproducible:
This is consistent with my configuration.  Disabling Desktop Effects 
immediately resolved the problem.

Steps to Reproduce:
1.  Enable desktop effects
2.  Establish a VNC connection to FC6 from remote machine
3.  Note the screen displays, but you do not recieve and screen updates
  
Actual results:


Expected results:


Additional info:  The configuration is on a Dell D610 with Intel video drivers.
Comment 1 Travis Brodeen 2006-11-07 12:56:06 EST
*** Bug 214448 has been marked as a duplicate of this bug. ***
Comment 2 Adam Tkac 2006-11-08 05:22:26 EST
please, could you specify more when is the desktop effect options?? I can't find
it + which window manager're you using. thanks
Comment 3 Travis Brodeen 2006-11-08 07:35:17 EST
In gnome, under System/Preferences/Desktop Effects.  You can 'Enable Desktop 
Effects' which change the behavior of the Windows to wobble when dragged.
Comment 4 Victor Bogado 2006-11-20 11:31:08 EST
I have the same problem, my window manager is the default one, compiz, it shows
up in the ps command as following : 

compiz --sm-client-id default1 gconf

If you exits the vncviewer and restart the session the image is updated. 
Comment 5 Adam Tkac 2006-12-05 08:43:21 EST
Could you please write me if you join to native vncserver (from vnc-server
package) or to gnome's vino server?
Comment 6 Travis Brodeen 2006-12-05 11:31:54 EST
It is the vino server, activated by the Remote Desktop features within Gnome.  
This is from a very generic installation of FC6.
Comment 8 Adam Tkac 2007-01-18 11:37:18 EST
This bug isn't in vnc. Reassigning to proper component.
Comment 9 Didier 2007-08-17 11:29:49 EDT
Confirmed on a fully updated F7, with components :

vino-2.18.0-1.fc7
vnc-4.1.2-18.fc7 (for vncviewer)
compiz-0.4.0-1.fc7 (for desktop effects)


Disclaimer : tested with the proprietary nvidia driver
(kmod-nvidia-100.14.11-1.2.6.22.1_41.fc7 and xorg-x11-drv-nvidia-100.14.11-1.lvn7)
Comment 10 Tomasz Torcz 2007-09-03 06:10:53 EDT
This bug is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=208983
Comment 11 Aaron Gaudio 2007-11-03 21:19:33 EDT
x11vnc apparently works where vino fails:
http://ubuntuforums.org/showthread.php?t=470306

Perhaps the '-noxdamage' option for x11vnc can be reproduced for vino to fix this?
Comment 12 Bug Zapper 2008-04-04 00:30:04 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 13 Bug Zapper 2008-05-06 12:44:11 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 14 Emmanuel Pacaud 2009-09-30 05:06:05 EDT
This issue is still there on an up to date fedora 11 machine.

I'm using vino for the desktop sharing service, have desktop effects enabled, and an nvidia graphic card.

I've tried vinagre and vncviewer in order to connect to vino, and I obtain the exact same behaviour than what the original reporter described.

Will this bug be reopened, or do I need to open a new one ?
Comment 15 baking666@gmail.com 2009-11-19 23:58:10 EST
(In reply to comment #14)
> This issue is still there on an up to date fedora 11 machine.
> 
> I'm using vino for the desktop sharing service, have desktop effects enabled,
> and an nvidia graphic card.
> 
> I've tried vinagre and vncviewer in order to connect to vino, and I obtain the
> exact same behaviour than what the original reporter described.
> 
> Will this bug be reopened, or do I need to open a new one ?  

I can confirm same bug with ubuntu...I have networked computer with my sister and she was running ubuntu 8.10 ...vino worked fine...But when I upgraded her to 9.04 (yes 9.10 is out) her vino started doing what has been described.
Comment 16 Chris Elmquist 2009-12-21 18:41:26 EST
I was using vncviewer on FC8 through FC10 to remotely control and view
the desktop of a Mac OSX machine using the native OSX remote desktop capability (which is essentially VNC).  After an upgrade to FC12, the vncviewer
on the FC12 machine now exhibits the symptoms described here--  namely, you
get one screen image which then does not update after you do anything on the Mac desktop.  The keyboard and mouse traffic do move from FC12 to the Mac but screen updates in the return direction do not occur.

Also, coincident with the upgrade to FC12 from FC10, the application 'x2vnc'
now fails to work.  The cursor will move down to the lower left corner of the
screen but fails to move onto the Mac desktop.  I have lost the ability to control the Mac desktop from the FC12 Linux desktop as a result.

There have been no changes to the Mac OSX installation.  Only the Linux machine was changed from FC10 to FC12.  Additionally, it was a fresh install of FC12 rather than an in-place upgrade from FC10.
Comment 17 Walter Neumann 2010-02-21 19:06:27 EST
I confirm this bug in FC12.
Comment 18 txvs 2010-04-25 13:42:20 EDT
The same on Fedora 11.

vino + fglrx + desktop effects --> no screen refresh on vnc client.
vino + fglrx - desktop effects --> normal screen refresh on vnc client.

Regards.
Comment 19 A Oepping 2010-04-27 18:37:10 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=214446 seems to be a duplicate of this bug.  Ubuntu launchpad says the bug is in xorg or possibly the ATI/nvidia drivers: https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/353126

For a workaround in your shell type:
gconftool-2 -s -t bool /desktop/gnome/remote_access/disable_xdamage true
Comment 20 John Ruemker 2010-05-07 21:34:29 EDT
Issue seen here on updated F12:

-nVidia Corporation GeForce Go 7900 GS 
-kernel-2.6.32.11-99.fc12.i686 
-vino-2.28.1-1.fc12.i686
-xorg-x11-server-Xorg-1.7.6-3.fc12.i686
-kmod-nvidia-2.6.32.11-99.fc12.i686-195.36.15-1.fc12.i686

When connecting to vino with any vnc client, I can see the initial rendering of the desktop, but no changes/updates are seen through the client.  The updates can still be seen on the primary screen.

Let me know if I can provide any more info.

-John
Comment 21 John Ruemker 2010-05-07 21:37:15 EDT
Oh and the workaround in https://bugzilla.redhat.com/show_bug.cgi?id=214446#c18 seems to work after restarting vino-server. 

-John
Comment 22 Sandro Mani 2010-05-22 09:50:25 EDT
This issue only remains with the proprietary ati driver and virtualbox additions driver. The issue with the proprietary nvidia driver has been fixed in the latest 256 beta release (http://www.nvnews.net/vbulletin/showthread.php?p=2255561), the issue does not appear to affect any open intel / ati / nvidia drivers.
Comment 23 Michael Cronenworth 2010-06-30 11:59:01 EDT
*** Bug 505558 has been marked as a duplicate of this bug. ***
Comment 24 Michael Cronenworth 2010-06-30 12:00:33 EDT
Should this be closed now? CANTFIX? (binary drivers)
Comment 25 Bug Zapper 2010-11-04 08:14:34 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 26 John Ruemker 2010-11-05 09:36:38 EDT
Last I checked this was still an issue with 13.  Haven't tried 14 yet.
Comment 27 Michael Cronenworth 2010-11-05 09:48:41 EDT
(In reply to comment #26)
> Last I checked this was still an issue with 13.  Haven't tried 14 yet.

John, you're using the proprietary driver. Make sure you are using the latest version. At least the 256.xx or 260.xx series driver. The issue was resolved. This should be closed.
Comment 28 John Ruemker 2010-11-05 09:53:22 EDT
Oh, I missed that.  Will do.  Sorry for the noise.  Feel free to close if others have tested and confirmed thats it.

-John
Comment 29 Michael Cronenworth 2011-05-13 15:40:53 EDT
Just make sure you update all packages (Fedora and proprietary).

Note You need to log in before you can comment on or make changes to this bug.