Bug 214620 - yum won't run quietly even with -e 0 -d 0
yum won't run quietly even with -e 0 -d 0
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 214782 219018 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-08 12:44 EST by Gilles Detillieux
Modified: 2014-01-21 17:55 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-07 17:26:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilles Detillieux 2006-11-08 12:44:42 EST
Description of problem:
The version of yum in Fedora Core 6, currently yum-3.0-6, will not run quietly
even with the -e0 and -d0 options, which is a bit of an annoyance when running
it from a cron job, e.g. with the yum-cron package included in the bug report
for bug 212507.  Running from cron is rather necessary until yum-updatesd is
fixed to work properly, so it would be nice if we could get yum to run quietly
when run from cron.

Version-Release number of selected component (if applicable):
yum-3.0-6

How reproducible:
Depends if there are updates to load, or the cache needs updating.

Steps to Reproduce:
1. Run something like "yum -e 0 -d 0 -y update | cat".
2. Look at the results.
3. If it didn't give any output, try again later when there are updates to install.
  
Actual results:
# yum -e 0 -d 0 -y update | cat
** Message: sqlite cache needs updating, reading in metadata
  Updating  : firefox                      ####################### [ 1/18]
  Updating  : cups-libs                    ####################### [ 2/18]
  Updating  : kdebase                      ####################### [ 3/18]
  Updating  : doxygen                      ####################### [ 4/18]
  Updating  : thunderbird                  ####################### [ 5/18]
  Updating  : autofs                       ####################### [ 6/18]
  Updating  : cups                         ####################### [ 7/18]
  Updating  : yelp                         ####################### [ 8/18]
  Updating  : swig                         ####################### [ 9/18]
# 

Expected results:
(no output except important error messages)

Additional info:
Comment 1 Gilles Detillieux 2006-11-08 13:20:59 EST
Just to be sure that the stderr destination wasn't a factor, I reran it with
2>&1 before the pipe, to simulate more closely what the run-parts script does
when running cron jobs from /etc/cron.daily, and it still behaves similarly...

# yum -e 0 -d 0 -y update 2>&1 | cat
** Message: sqlite cache needs updating, reading in metadata
  Updating  : audacious                    ######################### [1/6]
  Updating  : xmms-libs                    ######################### [2/6]
  Updating  : soundconverter               ######################### [3/6]
# 


The yum run just before this one above gave error messages like these:

Error: Cannot find a valid baseurl for repo: core
Could not retrieve mirrorlist
http://mirrors.fedoraproject.org/mirrorlist?repo=core-6&arch=i386 error was
[Errno 4] IOError: <urlopen error (111, 'Connection refused')>

That's the sort of error message that I'd want to have output even with -e0, but
not the progress bars and informatory messages about updating the cache.
Comment 2 Jeremy Katz 2006-11-10 11:46:53 EST
*** Bug 214782 has been marked as a duplicate of this bug. ***
Comment 3 Seth Vidal 2006-12-07 17:26:07 EST
okay most of this bug is fixed in cvs for 3.0.X. it will be in 3.0.2.

There is a small portion of thise in the c-based metadata parser where we need
to silence some of its output.

closing as upstream.
Comment 4 Seth Vidal 2006-12-09 10:02:16 EST
*** Bug 219018 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.