Bug 214992 - file-devel should own %_includedir/* %_libdir/lib*.so
file-devel should own %_includedir/* %_libdir/lib*.so
Status: CLOSED DUPLICATE of bug 203548
Product: Fedora
Classification: Fedora
Component: file (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
: FutureFeature
Depends On:
Blocks: 221041
  Show dependency treegraph
 
Reported: 2006-11-10 10:03 EST by Rex Dieter
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 08:54:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2006-11-10 10:03:02 EST
file-devel should include stuff like %{_includedir}/* and %{_libdir}/lib*.so
(just general Packaging Guidelines mumbo jumbo).

This came up mostly because of a package of mine currently in Extras that ends
up with x86_64/multilib dependency issues because libmagic.so.1.i386 doesn't
live in the x86_64 (Core) repo.  If file-devel existed, then it would get pulled
into the multilib mix (automatically) too.
Comment 1 Rex Dieter 2006-11-30 14:44:02 EST
Martin, ping, I've got a package with broken deps for 30+ days in fc7 Extras
repo due to this.
Comment 2 Rex Dieter 2006-12-30 21:02:53 EST
ping ping, now with 60+ days of silence.  We may need to send someone looking
for you. (:
Comment 3 Rex Dieter 2006-12-30 21:04:13 EST
FYI, it's Extras/gift bug #221041 that has the multilib problem due to this.
Comment 4 Patrice Dumas 2007-01-03 08:54:35 EST
There is no file-devel package. I requested one some time ago. I close
that bug as a duplicate of mine. Feel free to reopen if you find 
it is wrong.

*** This bug has been marked as a duplicate of 203548 ***
Comment 5 Martin Bacovsky 2007-01-09 14:45:48 EST
First of all sorry for not responding for so long :(. 

According to my information libmagic was not intended to be standalone library
and had not stable api in the past, so I didn't want to split the package. 
As libmagic is quite powerful library and number of requests for spliting is
growing I decided to meet this wishes.

Finally I upgraded to file-4.19-1.fc7 and splited file into file, file-devel and
file-libs packages. 

Hope this will be helpfull.

Note You need to log in before you can comment on or make changes to this bug.