Bug 221041 - gift has broken dependencies in fc7/devel
gift has broken dependencies in fc7/devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gift (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On: 203548 214992
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-12-30 19:32 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 15:29:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-12-30 19:32:56 EST
Description of problem:

        gift - 0.11.8.1-6.fc7.i386    (62 days)

Broken packages in fedora-extras-development-x86_64:

    gift-0.11.8.1-6.fc7.i386  requires  libmagic.so.1

This is due to the fact that gift uses the libmagic.so.1 library, which is in
the 'file' package. However, the .i386 gift package in the x86_64 repo can't
find the file.i386 package and won't work. 

Possible solutions: 

- Add the file.i386 package to the x86_64 repo. It is installable with the
file.x86_64 package already installed. 

- Remove the 'gift.i386' package from the x86_64 tree.
Comment 1 Rex Dieter 2006-12-30 20:52:41 EST
Yup, it's blocking on bug #214992
Comment 2 Martin Bacovsky 2007-01-09 14:33:51 EST
I pushed new version of file (file-4.19-1.fc7) to rawhide. It is now splited
into file, file-devel and file-libs packages. Please check if this can resolve
your issue.
Comment 3 Rex Dieter 2007-01-09 14:45:26 EST
Thanks Martin!  That should do the trick, indeed.  
Comment 4 Rex Dieter 2007-01-11 15:29:36 EST
file-devel now exists in rawhide, problem should just go away now.

Note You need to log in before you can comment on or make changes to this bug.