Bug 217256 - Review Request: alsa-tools - Specialist tools for ALSA
Review Request: alsa-tools - Specialist tools for ALSA
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks: FE-ACCEPT
  Show dependency treegraph
 
Reported: 2006-11-25 20:14 EST by Tim Jackson
Modified: 2008-05-18 14:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-09 05:27:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Jackson 2006-11-25 20:14:33 EST
Spec URL: http://www.timj.co.uk/linux/specs/alsa-tools.spec
SRPM URL: http://www.timj.co.uk/linux/srpms/alsa-tools-1.0.12-1.src.rpm
Description: 
This package contains several specialist tools for use with ALSA, including
a number of programs that provide access to special hardware facilities on
certain sound cards.

alsa-tools was previously built in FE and maintained by Thorsten Leemhuis. Then, Andreas Bierfert took ownership but never actually committed any changes. I tried to contact Andreas on 5 Nov 06 but have had no reply; he appears to be AWOL.

I am therefore submitting an updated package for new review; if OK then I will unorphan alsa-tools.  This package is almost entirely unchanged from the previous FE one other than a version update and some text changes.
Comment 1 Tim Jackson 2006-11-25 20:20:44 EST
Note that the subpackage alsa-tools-firmware is disabled by default; this is
pending the alsa-firmware package which I am going to submit separately.
Comment 2 Tim Jackson 2006-11-25 20:48:56 EST
Firmware is over in bug #217259
Comment 3 Parag AN(पराग) 2006-11-25 23:03:16 EST
I had a look at this package.
Though rpmlint is silent i found 
/usr/share/doc/alsa-tools-1.0.12
directory is orphaned
Comment 4 Tim Jackson 2006-11-26 09:18:14 EST
Thanks, that was subtle: I hadn't spotted that. Fixed in an updated spec file (I
haven't bothered to re-upload the whole SRPM for that one-liner).
Comment 5 Parag AN(पराग) 2006-11-26 09:25:13 EST
Mock build for i386 devel failed =>

checking for ENVY24CONTROL... configure: error: Package requirements (gtk+-2.0
alsa >= 0.9.0) were not met:

No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables ENVY24CONTROL_CFLAGS
and ENVY24CONTROL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

error: Bad exit status from /var/tmp/rpm-tmp.87484 (%build)


I think you should bother now to again update release and submit new download
links for this modified package.
You need to add gtk2-devel as Build Requires
Comment 6 Tim Jackson 2006-11-26 16:43:23 EST
Thanks, fixed, sorry, I forgot to run it through mock. Builds now fine in mock.

Spec URL: http://www.timj.co.uk/linux/specs/alsa-tools.spec
SRPM URL: http://www.timj.co.uk/linux/srpms/alsa-tools-1.0.12-3.src.rpm
Comment 7 Linus Walleij 2006-11-26 17:35:52 EST
I have this special thing in my /etc/rc.local that loads instruments to the 
OPL3 if one is found during startup:

#!/bin/sh
# Load MIDI instruments to the OPL3, if there is one.
# Use "aplaymidi -l", "aplaymidi -p nn:nn foo.mid" to test it.
midiport=`/usr/bin/aplaymidi -l | grep OPL3 | awk '{print $1}'`
if [ "x$midiport" != "x" ]; then
    /usr/bin/sbiload -p${midiport} --opl3 /usr/share/sounds/opl3/std.o3
/usr/share/sounds/opl3/drums.o3
    echo "Loaded OPL3 Instruments"
fi

I wonder if one should actually put something like that into init.d and
link it in from the rc.d:s. It would add a Requires:alsa-utils though.
Comment 8 Parag AN(पराग) 2006-11-26 23:44:56 EST
I think alsa-tools-1.0.13 is already released. How about updating package to
that tarball?
Comment 9 Parag AN(पराग) 2006-11-26 23:51:31 EST
Anyway you can also do that while importing/updating this package in CVS.
Review:
+ package builds in mock (development i386).
+ rpmlint is silent for SRPM and RPMS.
+ source file's md5sum is
7342056614623273abccb1cd38a674d8  alsa-tools-1.0.12-pruned.tar.bz2
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.  License text included in package.
+ %doc is small; no -doc subpackage required.
+ %doc does not affect runtime.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ no -devel subpackage exists
+ firmware subpackage though written in spec file its disabled.
+ no .la files.
+ no translations are available
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Desktop files installed without desktop-files-install as its really not needed.
APPROVED.
Comment 10 Tim Jackson 2006-11-27 17:31:45 EST
Many thanks for the review Parag. I left the version at 1.0.12 to match the
version of alsa-libs currently included with FC6.

Linus, I'm not 100% sure whether including your script is appropriate or not. In
one way, I think it should be in a separate package (e.g. alsa-opl3 or
something) but that seems complete overkill for a 4 line script. On the other
hand it is kind of appropriate to put it here given that alsa-tools includes the
sbiload binary.

If we did include it I'm not sure what I would call the init script.
"alsa-tools" seems wrong. "alsa-tools-opl3" is OK, but a bit of chkconfig clutter.

Parag, do you have any comments?
Comment 11 Linus Walleij 2006-11-27 17:54:13 EST
Tim, don't care about that script right now. Import and build instead,
I'll make a patch in some separate bug instead if I find the time.

Good work!
Comment 12 Parag AN(पराग) 2006-11-27 21:00:09 EST
Linus,
 I think its better to have another package that contains your script.  you can
start packaging that script and create alsa-tools-opl3 review request. I will be
happy to review that also :)
Comment 13 Tim Jackson 2006-11-29 17:32:12 EST
I imported and tried to build on devel but it failed with an odd error on ppc:

http://buildsys.fedoraproject.org/logs/fedora-development-extras/22627-alsa-tools-1.0.12-3.fc7/ppc/build.log

(for some reason it didn't appear to even try to build on other archs, which is
weird).

Will have to look at this in more detail.
Comment 14 Tim Jackson 2006-11-30 04:22:50 EST
Hmm, it's not building on FC6 either, on PPC. See job 22645
Anyone have a PPC machine that they can play around on?
Comment 15 Parag AN(पराग) 2006-11-30 09:55:22 EST
You can ask on FE-list about your build problem.
Also you will get good information at #fedora-extras 
Comment 16 Tim Jackson 2006-12-09 05:27:32 EST
OK, since nobody seems interested in ppc, I've ExcludeArch'd it for now.  The
corresponding bug is over in bug #219010. alsa-tools is now built successfully
in devel for x86 and i386 (job #23253). FC-6 is running now.

Thanks for the input everyone.
Comment 17 Tim Jackson 2008-05-18 12:35:23 EDT
Package Change Request
======================
Package Name: alsa-tools

Please remove the tag "alsa-tools-1_0_16-2_fc9" on the *devel* branch
This was a bad tag created due to the F9/F10-devel rollover (this is waaay too
easy to do)
Comment 18 Kevin Fenzi 2008-05-18 14:00:27 EDT
we don't remove cvs tags... please just bump your release and retag... 

Note You need to log in before you can comment on or make changes to this bug.