Bug 217567 - 'Send/Receive' - SMTP or IMAP stuck
'Send/Receive' - SMTP or IMAP stuck
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 217620 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 12:53 EST by Warren Sturm
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: evolution-data-server-1.8.2-2.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-15 13:06:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Sturm 2006-11-28 12:53:27 EST
Description of problem:

Clicking on Send/Receive button the SMTP or IMAP session can get stuck in
'waiting' and never seems to clear.  From that point on the connection to the
server cannot be established and outgoing mail will not get sent until there is
a --force-shutdoen and restart.

Version-Release number of selected component (if applicable):

evolution-2.8.1.1-3.fc6
evolution-sharp-0.11.1-10.fc6
evolution-webcal-2.7.1-6
evolution-data-server-1.8.1-2.fc6
evolution-data-server-devel-1.8.1-2.fc6


How reproducible:

It happens daily

Steps to Reproduce:
1.  Have not been able to reproduce at will
2.
3.
  
Actual results:


Expected results:


Additional info:
2.6.18-1.2849.fc6xen #1 SMP 

I have two IMAP mailboxes accessed through the same username but different
namespace.  We are running cyrus imap for the server.
Comment 1 Ricardo Nuno 2006-11-28 22:32:00 EST
I have the same exact problem here.

evolution-webcal-2.7.1-6
evolution-sharp-0.11.1-10.fc6
evolution-data-server-1.8.1-2.fc6
evolution-2.8.1.1-3.fc6
Comment 2 Matthew Barnes 2006-11-29 06:45:30 EST
*** Bug 217620 has been marked as a duplicate of this bug. ***
Comment 3 David Nielsen 2006-11-29 09:18:53 EST
Some what the same problem on my machine, however I have it 100% reproducable
and even forcefully shutting down and restart Evolution will not allow for mail
to be sent. Tested the same account using Thunderbird on the same machine and
there is no problem sending mail in that client.
Comment 4 Peter Gordon 2006-11-29 23:28:53 EST
I've been using IMAPS as mail account for a ver long time, and have yet to
encounter such a bug in Evolution (using the same versions as posted in comment
#1). 

The one thing immediately I notice that is different about this though is that
Warren is using the Xen setup, whereas I've elected to disable it at install
time. David or Ricardo: Does this make a difference for you?

Also, does electing to use or not to use SSL/TLS support for your account change
the result (if your mail server supports it)? 
Comment 5 Peter Gordon 2006-12-02 01:12:56 EST
Ok, I just hit this bug earlier this evening and it's a complete pain in the
butt. `evolution --force-shutdown` works around it (as running Evolution again
then works okay). This is really really odd.

My mail server is configured to use IMAP and SMTP over a TLS connection.
Comment 6 David Nielsen 2006-12-02 14:27:26 EST
And it's not like Development escapes unharmed from this:

evolution-2.9.2-3.fc7
evolution-data-server-1.9.2-3.fc7

Are also affected.

I still timeout regardless of TLS/SSL setting, this is on x86_64, no Xen.

Comment 7 Thomas M Steenholdt 2006-12-20 04:32:21 EST
Same problem here. This is on x86_64, but I'm sending mail using SMTP over an
SSH tunnel. I run IMAP over the same tunnel, but have only seen this hang on the
SMTP part (if I can trust the "complete" IMAP status).

I can reproduce in less than 15 seconds every time by continuously hitting the
"Send / Receive" button.

Tried to reproduce usinng --debug, but nothing is put in the debug log at hang time.

evolution-2.8.2.1-2.fc6
evolution-data-server-1.8.2-1.fc6
Comment 8 Paul Howarth 2007-01-09 06:14:52 EST
Same hebaviour seen here: I'm using SMTP with TLS and also IMAPS. The server is
on the same LAN and I don't believe it's a network timeout issue. Both the IMAP
and SMTP parts are prone to hanging - IMAP says 'Updating', SMTP says 'Waiting',
though SMTP hangs are more frequesnt. I also use LDAP over SSL if that makes any
difference. The IMAP server is dovecot and the SMTP server is sendmail.

evolution.x86_64 2.8.2.1-2.fc6
evolution-data-server.x86_64 1.8.2-1.fc6
Comment 9 Thomas M Steenholdt 2007-01-10 17:59:41 EST
evolution-data-server-1.8.2-2.fc6 appears to fix this for me. I've been hitting
the send/receive button so many times, it would have crashed for me many times
earlier. Now it just keeps sending and recieving - Yay!

-- from the changelog --
* Wed Jan 10 2007 Matthew Barnes <mbarnes@redhat.com> - 1.8.2-2.fc6
- Add patch for RH bug #208724 (hang on send/receive).
-- --
Comment 10 Matthew Barnes 2007-01-10 21:45:39 EST
Awesome!  Glad it's working for you.

I'll wait until the package hits Fedora Updates to close this bug.
Comment 11 Warren Sturm 2007-01-12 21:57:01 EST
After getting hit twice in a short span of minutes I bit the bullet and tried
the updates-testing version of the data-server and did not have any problems for
the rest of the day.
Comment 12 Paul Howarth 2007-01-14 04:52:53 EST
The e-d-s package in updates-testing has also resolved this issue for me. Thanks!

Note You need to log in before you can comment on or make changes to this bug.