Bug 21939 - 'gdm murdered' causes reboots, system not able to stabilise
'gdm murdered' causes reboots, system not able to stabilise
Status: CLOSED DUPLICATE of bug 23259
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-08 04:06 EST by shivaji apte
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-13 04:47:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shivaji apte 2000-12-08 04:06:29 EST
I have Red Hat 7.0 on an Intel Acer machine (128MB RAM, 10 GB HDD).

The box was up and ok. Then, I used Linuxconf to change the boot mode 
to 'text and network' instead of 'graphics and network' and saved.
I rebooted. Text mode came up fine.
But just when I try to log-in, screen starts blinking and I error messages 
saying something like ' gdm was running but has been somehow murdered...
' then something about 'gdm.pid ...' and the system reboots.
I don't even get time to do 'ps -ef | grep gdm' and kill it or like that.

I don't know why gdm is starting in the first place. It should not in text 
mode, right ?
And I am not able to debug or do anything as the system reboots within 20 
seconds of booting up.
Comment 1 Havoc Pennington 2000-12-08 10:44:16 EST
Hmm. Not sure what linuxconf does if you choose that, I'll ask. In the meantime
to get running again, type "linux 1" at the boot: prompt to start in single-user
mode, edit the file /etc/inittab, change the line "id:5:initdefault:" to
have a 3 instead of a 5.
Comment 2 giulioo 2000-12-10 07:59:56 EST
My initdefault is 5. Card is i810.
I frequently get the "murdered" message when I switch to a tty and then try to 
return to X. Sometime X is there, sometime it's not and I get a new X login and 
all my open apps are vanished. Sometime X is F9 instead of F7.

I don't know if my problem is due to gdm (as the error message seems to 
indicate) or to XFree4.0.1 having problems after a tty switch (like other bug 
reports suggests, ie bug 18651)

Comment 3 shivaji apte 2000-12-13 04:47:28 EST
I have found why using Linuxconf causes problems for me.
Basically, the default X-server that came could give only 640x480 resolution as 
it couldn't detect the video ram on my i82815 based agp card.
So, I had download the X-server from Intel's site (its XFCom_i810) and 
linked /usr/X11R6/bin/XF86_SVGA to it and also linked /etc/X11/X 
to /usr/X11R6/bin/XF86_SVGA. 
Then, everything was fine. However, when I used Linuxconf again, it resetted my 
custom settings and hence I was getting the problem.

Comment 4 Havoc Pennington 2001-01-05 13:25:24 EST
Merging with other 'gdm murdered' bugs

*** This bug has been marked as a duplicate of 23259 ***

Note You need to log in before you can comment on or make changes to this bug.