Bug 221831 - After upgrade, image thumbnails now shown on USB mass-storage camera
After upgrade, image thumbnails now shown on USB mass-storage camera
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gphoto2 (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
:
: 222271 222528 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-08 07:58 EST by Pavel Rosenboim
Modified: 2013-07-02 19:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-28 02:36:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log file (274.43 KB, text/plain)
2007-01-19 02:20 EST, Pavel Rosenboim
no flags Details

  None (edit)
Description Pavel Rosenboim 2007-01-08 07:58:46 EST
Description of problem:
After upgrade to gphoto2-2.3.1-1.fc5 no image thumbnails shown when importing
photos from USB mass-storage camera (Samsung DigiMax 410) with F-Spot or gThumb

Version-Release number of selected component (if applicable):
gphoto2-2.3.1-1.fc5

How reproducible:
Always

Steps to Reproduce:
1. Import images with f-spot or gthumb.
2.
3.
  
Actual results:
Image thumbnails not shown in import dialogs.

Expected results:
Display image thumbnails.


Additional info:
Comment 1 Jindrich Novy 2007-01-18 10:49:51 EST
Could you please send the description and debug log file:

gphoto2 --debug --debug-logfile=my-logfile.txt -T

to gphoto-devel@lists.sourceforge.net ? The upstream should be aware of it as well
to fix it in the next release as this seems to be an apparent regression.
Comment 2 Pavel Rosenboim 2007-01-19 02:20:48 EST
Created attachment 145969 [details]
Log file
Comment 3 Jindrich Novy 2007-01-19 02:23:00 EST
Which platform do you use? Is it x86_64?
Comment 4 Pavel Rosenboim 2007-01-19 02:36:32 EST
No, it is i386.
Comment 5 Jindrich Novy 2007-01-19 07:12:49 EST
*** Bug 222528 has been marked as a duplicate of this bug. ***
Comment 6 Jindrich Novy 2007-01-19 07:33:57 EST
Marcus, the problem is that gphoto2-2.3.1 requires at least libexif-0.6.13, but
we have libexif-0.6.12 in FC5 so that the configure script refuses to use it.
Should I also request update of libexif to FC5 or will gphoto2 work also with
libexif-0.6.12 so that I can force it to the configure script?
Comment 7 Marcus Meissner 2007-01-19 07:39:11 EST
in my eyes you can just patch the libgphoto2 configure.ac to only
require the 0.6.12 version.

While there are bugfixes in libexif 0.6.13, none of them are actually 
necessary for libgphoto2 if I remember correctly. (I am not sure why
the requirement got bumped.)
Comment 8 Jindrich Novy 2007-01-19 08:16:11 EST
Could you please test the following packages whether it fixes the problem for you?

http://people.redhat.com/jnovy/files/gphoto2-2.3.1-2.i386.rpm
http://people.redhat.com/jnovy/files/gphoto2-devel-2.3.1-2.i386.rpm

I'll release updates then.
Comment 9 Gert Vervoort 2007-01-27 06:02:18 EST
On x86_64 the problem has been resolved with the latest update:

gphoto2.x86_64                           2.3.1-3.fc5
Comment 10 Jindrich Novy 2007-01-28 02:36:19 EST
Ok, closing ERRATA. Thanks.
Comment 11 Andy Shevchenko 2007-01-31 04:56:34 EST
To comment #6:
I filled bug #222271 for this issue. May be that bug will be closed accordingly.
Comment 12 Jindrich Novy 2007-01-31 10:36:09 EST
*** Bug 222271 has been marked as a duplicate of this bug. ***
Comment 13 Fedora Update System 2007-01-31 11:48:31 EST
gphoto2-2.3.1-3.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.