Bug 222506 - cyrus-imapd conflicts with uw-imap
cyrus-imapd conflicts with uw-imap
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Target 379491
  Show dependency treegraph
 
Reported: 2007-01-12 19:18 EST by Robert Scheck
Modified: 2008-03-19 15:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 15:14:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-01-12 19:18:37 EST
Description of problem:
cyrus-imapd - 2.3.7-6.fc7.i386
  File conflict with: /etc/pam.d/imap
  File conflict with: /etc/pam.d/imap
  File conflict with: /etc/pam.d/pop
  File conflict with: /etc/pam.d/pop
  File conflict with: /etc/pam.d/pop
  File conflict with: /etc/pam.d/pop
  File conflict with: /usr/share/man/man8/imapd.8.gz
  File conflict with: /etc/pam.d/imap
  File conflict with: /etc/pam.d/imap
  => Package conflicts with: uw-imap - 2006d-1.fc7.i386

Version-Release number of selected component (if applicable):
cyrus-imapd-2.3.7-6

How reproducible:
Everytime, see above.

Actual results:
Package conflicts with: uw-imap - 2006d-1.fc7.i386

Expected results:
Can we rename /etc/pam.d/{imap,pop} etc. somehow?

Additional info:
Vice versa bug report is filed in bug #222486:
uw-imap - 2006d-1.fc7.i386
  File conflict with: /etc/pam.d/imap
  File conflict with: /etc/pam.d/pop
  File conflict with: /usr/share/man/man8/imapd.8.gz
  => Package conflicts with: cyrus-imapd - 2.3.7-6.fc7.i386
Comment 1 Tomas Janousek 2007-01-17 09:57:34 EST
The manpage conflict could be easily solved by adding a prefix like:
/usr/share/man/man8/imapd.8cyrus.gz

And I think we might possibly solve the pam.d one by unifying the contents of
the files -- that would mean cyrus having the additional entries uw-imapd has.
Or would you rather rename them, Rex?
Comment 2 Rex Dieter 2007-01-17 10:13:25 EST
I like both of your suggestions.  

Patching for renamed pam file sounds a little scary, though I'm not sure how to
manage having shared/common pam files rpm-wise though, that may be even more pain.
Comment 3 Rex Dieter 2007-01-17 10:21:37 EST
Further, someone/somewhere may be crazy enough to want separate/different pam
configs for cyrus-imapd vs. uw-imap\

Hmm... I'll go scrounging around other distros packaging (debian, mandriva, pld,
suse) to see if they've hit this, and how they dealt with it.
Comment 4 Tomas Janousek 2007-01-31 07:49:29 EST
I think that having those files binary identical will make rpm not complaint.
And since your pam config just adds something that shouldn't break cyrus, it can
probably be solved just by using your pam config in cyrus.

Anyway, I'll be happy to hear what you found out.
Comment 5 Robert Scheck 2007-02-15 06:02:08 EST
At PLD cyrus-imap simply conflicts uw-imap but not the other way round as far 
as I could see. At Debian it looks like they're just sharing the common files, 
because I can't detect any conflicts there, but maybe I'm wrong. At SuSE, the 
cyrus-imap conflicts with imap but not vice versa. And at Mandriva the imap 
package conflicts with cyrus-imapd, but not the other way round. So none of the 
other distributions solved this "problem", yet.
Comment 6 Tomas Janousek 2007-02-28 09:05:56 EST
So what do you suggest? Doing it the (probably) debian way -- making the files
look the same, or spend the time renaming the pam services? The first way is
probably very quick, but Fedora rules like the other one :)
Comment 7 Tomas Janousek 2007-08-14 07:10:06 EDT
Ping.
Comment 8 Rex Dieter 2008-03-19 14:52:26 EDT
Let's try the "making the files look the same" approach.  I'll get to work on this.
Comment 9 Rex Dieter 2008-03-19 15:14:21 EDT
tested a local build, looks like we have a winner.

%changelog
* Wed Mar 19 2008 Rex Dieter <rdieter@fedoraproject.org> - 2.3.9-12
- cyrus-imapd conflicts with uw-imap (#222506)
Comment 10 Tomas Janousek 2008-03-19 15:47:19 EDT
Okay, thanks :)

Note You need to log in before you can comment on or make changes to this bug.