Bug 223169 - [ml_IN] three combination are render improperly (pango)
[ml_IN] three combination are render improperly (pango)
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: pango (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
: i18n
: 288911 (view as bug list)
Depends On: 220874
Blocks: 431401
  Show dependency treegraph
 
Reported: 2007-01-17 23:51 EST by Liang Zhang
Modified: 2015-04-06 23:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-04 15:30:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my patch (648 bytes, patch)
2007-01-17 23:55 EST, Liang Zhang
no flags Details | Diff

  None (edit)
Description Liang Zhang 2007-01-17 23:51:17 EST
+++ This bug was initially created as a clone of Bug #220874 +++

Description of problem:
3 more combinations has problem with pango/icu  (different for icu)
3)
[അപ്ഗ്റേഡ്]
0D05 + 0D2A + 0D4D + 0D17 + 0D4D + 0D31 + 0d47 + 0D21 + 0D4D

4) [വ്യക്തം]
0D35 + 0D4D + 0D2F + 0D15 + 0D4D + 0D24 + 0d02


5) [ഇന്‍സ്റ്റോള്‍]
0D07 + 0D28 + 0D4D + 200D + 0D38 + 0D4D + 0D31 + 0D4D + 0D31 + 0D4B + 0D33 +
0D4D + 200D

Version-Release number of selected component (if applicable):
pango-1.15.0

How reproducible:
Everytime

Steps to Reproduce:
1. open gedit/oowriter
2. type give combination (use att text file)
3. open those in kedit
  
Actual results:
as in gedit/oowriter

Expected results:
as in kedit

Additional info:
>attachment
1) Screenshot attached for kedit, gedit, oowriter
2) simple text file for  those 3 combination

>Ref
this bug is part of bug #220866

-- Additional comment from aalam@redhat.com on 2006-12-28 02:19 EST --
Created an attachment (id=144443)
Test Case (text file)


-- Additional comment from aalam@redhat.com on 2006-12-28 02:23 EST --
Created an attachment (id=144444)
Image at RHEL5Client machine
Comment 1 Liang Zhang 2007-01-17 23:55:41 EST
Created attachment 145879 [details]
my patch
Comment 2 Liang Zhang 2007-02-07 20:56:36 EST
This bug and bug223170 have 4 problems, this patch only can fix one problem, so
it need be modified.
Comment 3 Liang Zhang 2007-06-13 02:40:37 EDT
I wrote a patch for fixing bug238896, bug223169 and bug223170.
And I modified indic_shape_engine( ) in this patch, let it handle one by one
syllable, not handle all syllables together.
It can fix the three bugs only by this way.

The patch is below:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=156846
Comment 4 Liang Zhang 2007-09-27 23:10:56 EDT
*** Bug 288911 has been marked as a duplicate of this bug. ***
Comment 5 Ani Peter 2008-01-25 06:46:54 EST
The problem with all three combinations still exists.

Please have a look in the bug. 

Pango version: pango-1.19.3-1.fc9

Thanks
Ani
Comment 6 Ani Peter 2008-02-04 01:31:07 EST
Problem still exists and necessary action is highly appreciated.

Slight change in the first combination mentioned in the problem

Correct combination is:
[അപ്ഗ്രേഡ്]
0D05 + 0D2A + 0D4D + 0D17 + 0D4D + 0D30 + 0d47 + 0D21 + 0D4D.

Thanks
Ani
Comment 7 Behdad Esfahbod 2008-02-04 15:30:05 EST
Discussing here never gets it fixed.  Please file/follow upstream.

Note You need to log in before you can comment on or make changes to this bug.