Bug 431401 - [ml_IN] three combination are render improperly
[ml_IN] three combination are render improperly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: icu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
: i18n
Depends On: 223169
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-04 01:33 EST by Ani Peter
Modified: 2016-07-31 21:31 EDT (History)
7 users (show)

See Also:
Fixed In Version: F-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 07:01:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Scrreshot for the problematic combination (43.41 KB, image/png)
2008-02-04 01:49 EST, Ani Peter
no flags Details

  None (edit)
Description Ani Peter 2008-02-04 01:33:58 EST
+++ This bug was initially created as a clone of Bug #223169 +++

+++ This bug was initially created as a clone of Bug #220874 +++

Description of problem:
3 more combinations has problem with pango/icu  (different for icu)
3)
[അപ്ഗ്റേഡ്]
0D05 + 0D2A + 0D4D + 0D17 + 0D4D + 0D31 + 0d47 + 0D21 + 0D4D

4) [വ്യക്തം]
0D35 + 0D4D + 0D2F + 0D15 + 0D4D + 0D24 + 0d02


5) [ഇന്‍സ്റ്റോള്‍]
0D07 + 0D28 + 0D4D + 200D + 0D38 + 0D4D + 0D31 + 0D4D + 0D31 + 0D4B + 0D33 +
0D4D + 200D

Version-Release number of selected component (if applicable):
pango-1.15.0

How reproducible:
Everytime

Steps to Reproduce:
1. open gedit/oowriter
2. type give combination (use att text file)
3. open those in kedit
  
Actual results:
as in gedit/oowriter

Expected results:
as in kedit

Additional info:
>attachment
1) Screenshot attached for kedit, gedit, oowriter
2) simple text file for  those 3 combination

>Ref
this bug is part of bug #220866

-- Additional comment from aalam@redhat.com on 2006-12-28 02:19 EST --
Created an attachment (id=144443)
Test Case (text file)


-- Additional comment from aalam@redhat.com on 2006-12-28 02:23 EST --
Created an attachment (id=144444)
Image at RHEL5Client machine

-- Additional comment from lizhang@redhat.com on 2007-01-17 23:55 EST --
Created an attachment (id=145879)
my patch


-- Additional comment from lizhang@redhat.com on 2007-02-07 20:56 EST --
This bug and bug223170 have 4 problems, this patch only can fix one problem, so
it need be modified.

-- Additional comment from lizhang@redhat.com on 2007-06-13 02:40 EST --
I wrote a patch for fixing bug238896, bug223169 and bug223170.
And I modified indic_shape_engine( ) in this patch, let it handle one by one
syllable, not handle all syllables together.
It can fix the three bugs only by this way.

The patch is below:
https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=156846

-- Additional comment from lizhang@redhat.com on 2007-09-27 23:10 EST --
*** Bug 288911 has been marked as a duplicate of this bug. ***

-- Additional comment from apeter@redhat.com on 2008-01-25 06:46 EST --
The problem with all three combinations still exists.

Please have a look in the bug. 

Pango version: pango-1.19.3-1.fc9

Thanks
Ani

-- Additional comment from apeter@redhat.com on 2008-02-04 01:31 EST --
Problem still exists and necessary action is highly appreciated.

Slight change in the first combination mentioned in the problem

Correct combination is:
[അപ്ഗ്രേഡ്]
0D05 + 0D2A + 0D4D + 0D17 + 0D4D + 0D30 + 0d47 + 0D21 + 0D4D.

Thanks
Ani
Comment 1 Ani Peter 2008-02-04 01:48:39 EST
Hello again Caolan,

All is fixed in icu-3.8.1-4.fc9 except for combinations like

[അപ്ഗ്രേഡ്]
0D05 + 0D2A + 0D4D + 0D17 + 0D4D + 0D30 + 0d47 + 0D21 + 0D4D

ie, If a consonant with 0D4D is followed by the combination of (a consonant +
0D4D + 0D30), the glyph of combination of (a consonant + 0D4D + 0D30) appears wrong.

please find the screenshot attached.

Thanks
Ani
Comment 2 Ani Peter 2008-02-04 01:49:56 EST
Created attachment 293869 [details]
Scrreshot for the problematic combination
Comment 3 Caolan McNamara 2008-02-04 10:16:54 EST
So this is test-case number 252 of 

http://batman.brisbane.redhat.com/~indic/IndicTC/lang/ml_IN/font/IndicFontTestCaseGSUB-Malayalam.html

?

If so can we change the text of that test to be ...

A PA VIRAMA GA VIRAMA RA VOWEL SIGN EE DDA VIRAMA
and not
A PA VIRAMA GA VIRAMA RRA VOWEL SIGN EE DDA VIRAMA

to match the unicode code points used.

I think I can hack in a special case for this sort of thing in >= icu-3.8.1-5,
but I really should make some time to figure out all this from scratch and
re-examine all the malayalam specific stuff and see why it has become so much
more complex than all the other indics, perhaps in conjunction with testing icu
with the microsoft malayalam font instead of/as well as the lohit one.

Note You need to log in before you can comment on or make changes to this bug.