Bug 22320 - Hangs on Kernel boot
Hangs on Kernel boot
Status: CLOSED DUPLICATE of bug 22069
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2000-12-14 18:22 EST by Need Real Name
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-12-18 12:25:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-12-14 18:22:00 EST
After post intallation completes the bug window opens.  After saving and 
clicking ok the system reboots.  When the kernel reboots the kernal begins 
to load and the dots get to about 6 or so you know  ........  Then hangs.
Here's the bug stuff.

The system is a Hewlett Packard E60 Server with 128M.  Adaptec 74xxx 
series SCSI controller.  No indications of any problems at all until the 
bug window appears after post intallation.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/tmp/updates/todo.py", line 1674, in doInstall
    self.x.write (self.instPath + "/etc/X11")
  File "/tmp/updates/xf86config.py", line 894, in write
    config4 = self.Version4Config ()
  File "/tmp/updates/xf86config.py", line 1172, in Version4Config
    info["enableVariant"] = ""
NameError: info

Local variables in innermost frame:
data: {'screenModes': '\012\011Subsection "Display"\012        
\011Depth       8\012                Modes       "640x480" \012
\011EndSubsection\012', 'videoRam': '', 'pex5Mod': '\012
\011Load "pex5"', 'XkbModel': 'pc104', 'monitorVert': '47.0-
160.0', 'mouseDevice': 'psaux', 'cardVendor': 'ATI 
Mach64', 'cardsOptions': '\011# no known 
options', 'XkbRules': 'xfree86', 'cardBoardName': 'ATI 
Mach64', 'ia64Mods': '', 'XkbLayout': 'en_US', 'nonSparcMods': '\012
\011Load "fbdevhw"', 'defaultDepth': '', 'XkbOptions': '', 'cardID': 'ATI 
Mach64', 'emulate3': 'yes', 'enableOptions': '#', 'monitorHoriz': '30.0-
72.0', 'enableVariant': '#', 'XkbVariant': 'nodeadkeys', 'mouseProto': 'PS/
2', 'files': '\012# The location of the RGB database.  Note, this is the 
name of the\012# file minus the extension (like ".txt" or ".db").  There 
is normally\012# no need to change the default.\012\012    
RgbPath\011"/usr/X11R6/lib/X11/rgb"\012\012# Multiple FontPath entries are 
allowed (they are concatenated together)\012# By default, Red Hat 6.0 and 
later now use a font server independent of\012# the X server to render 
fonts.\012\012    FontPath   "unix/:7100"\012'}
self: <xf86config.XF86Config instance at 8266760>
maxdepth: 8
res: 640x480
test: 0
mouseProto: PS/2
emulate3: yes
modes: ['640x480']
depth: 8
	Subsection "Display"
        	Depth       8
                Modes       "640x480" 

ToDo object:

Comment 1 Need Real Name 2000-12-14 18:24:02 EST
Attempting installing the anaconda fix without result.
Comment 2 Brent Fox 2000-12-15 11:42:05 EST
I suspect that this bug is a duplicate of bug #21904.  What kind of video card
does the system have and what did anaconda probe the card to be?  Also, did you
change the video card selection from what anaconda probed?
Comment 3 Brent Fox 2000-12-15 11:44:36 EST
A potential workaround is to skip configuring X in the install and use
Xconfigurator once the system reboots.  I'm looking into a better solution.
Comment 4 Michael Fulbright 2000-12-18 12:25:44 EST

*** This bug has been marked as a duplicate of 22069 ***

Note You need to log in before you can comment on or make changes to this bug.