Bug 223205 - Evolution - Lost connection to Evolution Exchange backend process
Evolution - Lost connection to Evolution Exchange backend process
Product: Fedora
Classification: Fedora
Component: evolution-connector (Show other bugs)
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
: 223206 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-01-18 08:35 EST by Valent Turkovic
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-03 09:55:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 364463 None None None Never

  None (edit)
Description Valent Turkovic 2007-01-18 08:35:01 EST
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:
Every time

Steps to Reproduce:
1. Open Evolution
2. Nothing else AFAIK
Actual results:
I get a message "Lost connection to Evolution Exchange backend process" and I 
can't get new mail, read, delete them... nothing. Client doesn't crash but just 
sits there useless.

Expected results:
Get new mail, be able to read, reply and delete them.

Additional info:
Please check also this bug:

This happened after I used pup to get all new upgrades, including Evolution and 
evolution-connector Before the upgrade everything worked perfectly!

Come on guys, please test the releases more carefully! Each second update
release introduces show-stopping bug!

Thank you for your hard work but please pay more attention to testing releases
before releasing them.

Every time I see Evolution upgrade I dread and a thought comes to my mind: 
"What have they broken now?" :(
Comment 1 Matthew Barnes 2007-01-18 10:17:20 EST
*** Bug 223206 has been marked as a duplicate of this bug. ***
Comment 2 Valent Turkovic 2007-01-23 05:27:44 EST
I tried downgrading to but I still get the same error!
Can you please look into this. Maby is some dependency that is causing this

# rpm -e evolution-connector
# rpm -e evolution --nodeps
# rpm -ivh evolution-
# rpm -ivh evolution-connector-2.8.1-1.fc6.i386.rpm

and still the same error message pops-up, even after a reboot.
Comment 3 Valent Turkovic 2007-01-26 09:43:42 EST
Ok, now I have another situation;
I installed a new clean Fedora Core 6 on new laptop, and did an "yum update" so
evolution also got updated to latest version.

I don't have this bug on a new Fedora installation, but I still have it on my
work laptop that has been gradually updated and also has evolution version.

Do you have any idea what could be causing these problems on my old fedora
machine? Can you give me some pointers into what libraries I should pay
attention... any help is appreciated.

Thank you in advance.
Comment 4 Herbert Carl Meyer 2007-01-31 06:45:24 EST
I developed this error last night (2007.01.30), after updating fetchmail.
Evolution and evolution-connector were not updated (I think). I will collect
version numbers later today.
Comment 5 Valent Turkovic 2007-02-05 17:37:03 EST
Can you please tell us what versions are you using. Did downgrading fetchmail help?
Comment 6 Mark Polo 2007-02-19 03:30:33 EST
This problem has started occurring for me upon installing
evolution-connector-2.8.3-1.fc6 and evolution-2.8.3. (I installed about a week's
worth of updates on Saturday, the 17th.) I'm using FC6.x86_64, fully updated.
The system hangs on trying to fetch my email, eventually giving the message
"Lost connection to Evolution Exchange backend process". If I try to close
Evolution, it hangs for long enough that I kill the processes from the command

There may be something weird with an appointment of the calendar getting
involved in this, as once it crashed and opened Bug Buddy for the calendar
component. I'm afraid I didn't send the details on that in, and I am now having
it die without reaching that point...
Comment 7 Mark Polo 2007-02-19 03:35:10 EST
Hmmm. As soon as I posted this, I tried opening Evolution again. The "Outlook"
folders were marked unexpanded, as it was unable to expand them the last time.
Hitting Send/Receive managed to get my mail sent out and to receive my mail into
the local files. (I have a rule that moves everything to local mbox files, as
our server administrators do not allow us to keep large amounts of mail on the
Exchange server.) It is certainly less convenient this way, as I can't see if
something's coming by looking at the Inbox on the Exchange server, but it does
seem to work, more or less. Keeping my fingers crossed...
Comment 8 Mark Polo 2007-02-19 16:04:03 EST
Just to update... The behavior is inconsistent now. I can occasionally get
things down by using Send & Receive, but then this stops working, or I get a
crash linked to the Calendar application (which I can't send in, since evolution
doesn't use the Gnome error system). Right now I got "Lost connection" from the
Comment 9 Mark Polo 2007-02-20 09:07:26 EST
I seem to have resolved the problem by downgrading (rpm --oldpackage -Uvh) to
2.8.0. I'll have to block yum from updating this until this issue can be resolved...
Comment 10 Mark Polo 2007-04-29 15:43:35 EDT
Sorry to be "pushy", but is it safe to update evolution-connector yet?
Comment 11 Valent Turkovic 2007-05-02 09:52:54 EDT
I update with no problem now. Knock, knock on wood :)
Comment 12 Matthew Barnes 2007-10-02 14:17:34 EDT
Is the problem still present in Fedora 8 Test 2 or later?
Comment 13 Valent Turkovic 2007-10-03 08:55:57 EDT
I don't know - I only know that I haven't experienced it with Fedora 7 nor with
Fedora 8 test 2.

But I get an new and also nasty bug which prevents me from using Fedora 8 test 2
with exchange: https://bugzilla.redhat.com/show_bug.cgi?id=296671
Comment 14 Matthew Barnes 2007-10-03 09:55:24 EDT
Thanks for responding.  I'm closing this bug but feel free to reopen it if the
problem crops up again.

Note You need to log in before you can comment on or make changes to this bug.