Bug 223606 - PS2 mouse inoperative
PS2 mouse inoperative
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
: Reopened
: 223603 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-01-20 12:56 EST by GeoffLeach
Modified: 2008-03-12 16:04 EDT (History)
13 users (show)

See Also:
Fixed In Version: 2.6.20-1.2962.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 13:39:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description GeoffLeach 2007-01-20 12:56:11 EST
Description of problem: PS2 mouse inoperative


Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2895.fc6

How reproducible:
every time

Steps to Reproduce:
1.boot
2.run level 3 or 5
3.no mouse
  
Actual results:
No mouse pointer movement

Expected results:
Well ...

Additional info:
Rebooting to kernel-2.6.18-1.2869.fc6 resolves problem
Comment 1 Peter Gordon 2007-01-20 15:02:07 EST
Is there anything obvious in terms of error or warning output in your kernel log
(`dmesg`) that is not in 2.6.18-1.2869 that is in the new 2.6.19-1.2895? 

What type of motherboard/mouse do you have? I have an Abit VT7 with a Logitech
Trackball and my mouse works just fine with the new kernel. :|
Comment 2 GeoffLeach 2007-01-20 18:46:53 EST
MB is AccelerTech Tyhpoon64 / Model: ATO2082-A (HDAMB) #46 (dual Opteron 240)
Mouse is an ancient Keytronic three-button

There are some differences in the kernel messages.  This is where they are out
of sync.

2.6.18 messages:
Jan 19 08:59:39 mtranch kernel: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:PS2M]
at 0x60,0x64 irq 1,12
Jan 19 08:59:39 mtranch kernel: serio: i8042 AUX port at 0x60,0x64 irq 12
Jan 19 08:59:39 mtranch kernel: serio: i8042 KBD port at 0x60,0x64 irq 1
Jan 19 08:59:39 mtranch kernel: mice: PS/2 mouse device common for all mice
Jan 19 08:59:39 mtranch kernel: md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
Jan 19 08:59:39 mtranch kernel: md: bitmap version 4.39

2.6.19 messages
Jan 20 09:22:30 mtranch kernel: PNP: PS/2 Controller [PNP0303:KBC,PNP0f13:PS2M]
at 0x60,0x64 irq 1,12
Jan 20 09:22:30 mtranch kernel: serio: i8042 KBD port at 0x60,0x64 irq 1
Jan 20 09:22:30 mtranch kernel: mice: PS/2 mouse device common for all mice
Comment 3 Richard Hirs 2007-01-23 09:48:42 EST
I have the same problem with a Asus TUSI-M motherboard (SiS 630 chipset) I did
try   several PS/2 mouses including nonames, Microsoft (old and new types).

Going back to previous kernel brings the mouse back to live
Comment 4 Richard Hirs 2007-01-23 21:33:25 EST
I found that some of the mouse's using chipset from Elan Microelectronics
http://www.emc.com.tw

In one mouse I can clearly see that it is using the EM84510EP PS/2 scrolling
mouse controller chipset (Link to the datasheet
http://www.emc.com.tw/database/Data_Sheet/PC/EM84510.pdf)

With kernel 2.6.19-1.2895 I get no data from "cat /dev/mouse01" or "cat
/dev/mice" , "cat /dev/mouse01" give a error message "no file or directory"

With the old kernel 2.6.18-1.2869 "cat /dev/mouse01" works fine and I can see
data from mouse movement.
Comment 5 Craig Phillips 2007-02-04 11:36:33 EST
Hmm, I also have this problem and I too also have the SiS 630 chipset, is this a
common denominator?
Comment 6 Ronald de Boer 2007-02-05 02:01:44 EST
We have the same problem with several systems which have SiS 630 (Intel socket)
and SiS 730 (AMD socket. In total 20 machines we use this low spec machines for
data entry.
Comment 7 J Carter 2007-02-09 15:24:42 EST
I also saw the lost mouse under Virtual PC 2004 after the kernel upgrade.  
Virtual PC emulates a PS2 mouse.
Comment 8 Guido R. Rolon A. 2007-02-14 10:08:22 EST
i have the same problem. MB ASUS CUSI-FX Bios 1018.005 (sis630) Pentium III
933Mhz 512MB RAM 10GB HDD CD-RW/DVD. Installed FC6 from DVD just fine. I did a
full update yesterday, moved from 2.6.18-1.2798.fc6xen to 2.6.19-1.2911.fc6xen
and no mouse.
[root@fc6 log]# dmesg | grep PS/2
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
mice: PS/2 mouse device common for all mice
[root@fc6 log]# ll /dev/psaux
ls: /dev/psaux: No existe el fichero o el directorio
[root@fc6 log]# ll /dev/input/
total 0
crw------- 1 root root 13, 64 feb 14 11:51 event0
crw------- 1 root root 13, 65 feb 14 11:51 event1
crw------- 1 root root 13, 63 feb 14 11:51 mice
Any ideas ?
TIA
Comment 9 Guido R. Rolon A. 2007-02-14 10:09:00 EST
i have the same problem. MB ASUS CUSI-FX Bios 1018.005 (sis630) Pentium III
933Mhz 512MB RAM 10GB HDD CD-RW/DVD. Installed FC6 from DVD just fine. I did a
full update yesterday, moved from 2.6.18-1.2798.fc6xen to 2.6.19-1.2911.fc6xen
and no mouse.
[root@fc6 log]# dmesg | grep PS/2
PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
mice: PS/2 mouse device common for all mice
[root@fc6 log]# ll /dev/psaux
ls: /dev/psaux: No existe el fichero o el directorio
[root@fc6 log]# ll /dev/input/
total 0
crw------- 1 root root 13, 64 feb 14 11:51 event0
crw------- 1 root root 13, 65 feb 14 11:51 event1
crw------- 1 root root 13, 63 feb 14 11:51 mice
Any ideas ?
TIA
Comment 10 Richard Hirs 2007-02-14 21:29:18 EST
The new kernel 2.6.19-1.2911.fc6 doesn't fix a thing, all the mice are still
death on the table.
Comment 11 J Carter 2007-02-19 17:18:18 EST
>The new kernel 2.6.19-1.2911.fc6 doesn't fix a thing, all the mice are still
death on the table.

  I also see that the mouse is still dead with this kernel update also. 
Comment 12 Chuck Ebbert 2007-02-19 17:27:03 EST
Is everyone seeing the same differences in their boot messages,
i.e. is this line missing in the broken kernels:

kernel: serio: i8042 AUX port at 0x60,0x64 irq 12

Comment #2 is the only one that confirms this so far.
Comment 13 J Carter 2007-02-19 22:54:42 EST
I also confirm that on mine

> This line missing in the broken kernels:
kernel: serio: i8042 AUX port at 0x60,0x64 irq 12
Comment 14 lahtis 2007-02-20 16:08:45 EST
same as my usb mouse and normal keyboard. If i startx usb mouse and normal
keyboard crash. Im using 2.6.18-1.2798.fc6 kernel.
Comment 15 Christian Mongeon 2007-02-25 19:41:53 EST
Same problem on three different systems:

1. Pentium III, 1000 MHz. Motherboard Matsonic MS7308E Bios AMI 09/25/01 

2. Celeron II, 800 MHz. Motherboard Matsonic MS7308E Bios AMI 09/25/01

3. Celeron II, 800 MHz. Motherboard PCChips M758LMRE Bios AMI 05/10/01


All of them use the SiS 630 chipset. They all work fine with kernel
2.6.18-1.2869.fc6

The problem appears with all other kernels afterward. Mouse cursor is stuck on
the center of the screen and, yes, this line is missing from the broken kernels:

kernel: serio: i8042 AUX port at 0x60,0x64 irq 12

I also have a fourth system that uses the SiS 735 chipset (Athlon 1150 MHz,
motherboard ECS K7S5A) that works fine.

These four systems are sharing the same mouse, keyboard and monitor with a KVM.
If the mouse is connected directly, no effect, same problem.

While doing some tests, something strange happened. I was able to produce the
same problem with system 1 when using kernel 2.6.18-1.2869.fc6 and, yes, the
above line was missing from dmesg as well. What I did is that right after system
1 started booting, I switched to system 2 with the KVM. Rebooting system 1 with
kernel 2.6.18-1.2869.fc6 and waiting for it to finish booting fixed the problem.

Hope this helps.
Comment 16 Kam Leo 2007-03-03 03:38:01 EST
For what it's worth, problem still persists with kernel-2.6.19-1.2911.6.4.fc6.
Comment 17 Kam Leo 2007-03-07 14:29:48 EST
No change with kernel-2.6.19-1.2911.6.5.fc6.
Comment 18 Chuck Ebbert 2007-03-07 15:04:13 EST
Reported upstream.
Comment 19 Bob Rubendunst 2007-03-08 10:27:38 EST
If I add the boot option noapic, the mouse works again.
Comment 20 Kam Leo 2007-03-08 14:29:03 EST
(In reply to comment #19)
> If I add the boot option noapic, the mouse works again.

Unfortunately that option does not work on my rig: ASUS SP97-V MB with AMD K6-2 
CPU.
 
Comment 21 Bob Rubendunst 2007-03-09 17:54:34 EST
Disabling "Legacy USB" instead of using the noapic kernel option also restored
the mouse to working on my Ausus M2PNV-VM motherboard.
Comment 22 Kam Leo 2007-03-10 22:40:08 EST
(In reply to comment #21)
> Disabling "Legacy USB" instead of using the noapic kernel option also restored
> the mouse to working on my Ausus M2PNV-VM motherboard.

Doesn't that disable use of USB interfaced printers and peripherals?
Comment 23 Pete Zaitcev 2007-03-11 15:04:28 EDT
Kam, "Legacy USB" setting in BIOS usually means emulation of i8042. There's no
telling until you try, because a large number of poorly made BIOSes float
about, but normally you want this disabled. It is not the same as disabling
USB controller.
Comment 24 Kam Leo 2007-03-11 20:24:02 EDT
(In reply to comment #23)
> Kam, "Legacy USB" setting in BIOS usually means emulation of i8042. There's no
> telling until you try, because a large number of poorly made BIOSes float
> about, but normally you want this disabled. It is not the same as disabling
> USB controller.
> 

No such setting on my old rig. Only have USB Enable/Disable and USB IRQ
selection.  Disabling USB port is not an option. Changing IRQ from "Auto" to
"15" had no effect on problem, i.e. mouse still frozen.
Comment 25 Chuck Ebbert 2007-03-11 20:28:47 EDT
Should be fixed in kernel-2.6.20-1.2925.fc6.

Test kernel is available at:

http://people.redhat.com/cebbert/kernels
Comment 26 Kam Leo 2007-03-11 22:03:55 EDT
(In reply to comment #25)
> Should be fixed in kernel-2.6.20-1.2925.fc6.

Fixed problem on my system.
Comment 27 Richard Hirs 2007-03-12 11:50:08 EDT
Is this new kernel (2.6.20-1.2925.fc6) also into the update repository, as I
need also the kernel-headers and the kernel source to get my box running again.

With kind regards.....
Comment 28 J Carter 2007-03-12 13:21:01 EDT
(In reply to comment #25)
> Should be fixed in kernel-2.6.20-1.2925.fc6.

 Thanks for the update.  I tried 2.6.20-1.2925.fc6 and it didn't work for me.  I
don't see the line 

kernel: serio: i8042 AUX port at 0x60,0x64 irq 12

  in this kernel either.   (I haven't gone back to the last working to see I
also had the line back then).
Comment 29 Christian Mongeon 2007-03-12 19:50:14 EDT
(In reply to comment #25)
> Should be fixed in kernel-2.6.20-1.2925.fc6.

Fixed the problem on all of my three systems.
(See comment #15)

Thank you!
Comment 30 Paul Lemmons 2007-03-21 14:37:50 EDT
A problem with similar symptoms but probably completely different can sometimes
be experienced with USB mice. It appears that the new kernel may want to assign
the mouse a different number. Booting to run-level 3 shows the mouse working in
the console but it does not work in X. The solution was found at link:

http://www.linuxforums.org/forum/447267-post6.html

In a nutshell, xorg.conf says your mouse is at /dev/input/mouseX and it has
moved to /dev/input/mouseY, where X and Y are some number. Use the instructions
in the link above to determine where the mouse moved to and update xorg.conf
accordingly.
Comment 31 Chuck Ebbert 2007-03-21 14:40:58 EDT
(In reply to comment #30)
> 
> http://www.linuxforums.org/forum/447267-post6.html
> 
> In a nutshell, xorg.conf says your mouse is at /dev/input/mouseX and it has
> moved to /dev/input/mouseY, where X and Y are some number. Use the instructions
> in the link above to determine where the mouse moved to and update xorg.conf
> accordingly.

Actually you should just use /dev/input/mice

Comment 32 Mark Meytin 2007-03-28 10:20:29 EDT
The problem still exists for me under kernel-2.6.20-1.2933.fc6.  Earlier
kernel-2.6.18-1.2869.fc6 works fine with identical configuration.  I am running
under Virtual PC 2007, which is emulating PS/2 mouse.  When I cat
/dev/input/mouse0 or /dev/input/mice under 2.6.20-1.2933.fc6 and move a mouse I
get no response on a screen.  Under 2.6.18-1.2869.fc6 I get some output, as
expected.
Comment 33 Chuck Ebbert 2007-03-28 11:36:21 EDT
I don't think we can fix problems with Virtual PC emulated mouse.
Everyone else seems fixed; this bug is closed since that was the reported bug.
If people with "real" hardware mice still have problems, re-open the bug.
Virtual PC users can open a new bug so the issues don't get confused.
Comment 34 Kevin Cozens 2007-04-06 00:09:46 EDT
The mouse worked for me in the first kernel available via yum after
2.6.18-1.2869 but it broke my audio. The next one after that fixed my audio but
broke the mouse. The mouse has never worked since the second released kernel
after 2869. I am not using a virtual environment.

My messages file shows the same thing mentioned in comment #28. I don't see the
serio line in either the 2925 or 2933 kernels which refers to irq 12. I only
have one serio line mentioning to irq 1.

I'm curious why this has been such a hard thing to fix since the mouse has been
working until the 2869 kernel. Was it a change in the standard Linux kernel, a
bug due to an FC patch to the kernel, or a change to the default kernel build
configuration?
Comment 35 Chuck Ebbert 2007-04-09 14:51:33 EDT
(In reply to comment #34)
> The mouse worked for me in the first kernel available via yum after
> 2.6.18-1.2869 but it broke my audio. The next one after that fixed my audio but
> broke the mouse. The mouse has never worked since the second released kernel
> after 2869. I am not using a virtual environment.
> 
> My messages file shows the same thing mentioned in comment #28. I don't see the
> serio line in either the 2925 or 2933 kernels which refers to irq 12. I only
> have one serio line mentioning to irq 1.
> 
> I'm curious why this has been such a hard thing to fix since the mouse has been
> working until the 2869 kernel. Was it a change in the standard Linux kernel, a
> bug due to an FC patch to the kernel, or a change to the default kernel build
> configuration?

This breakage was from the upstream standard kernel and is fixed for
everything but virtual PC so far.

What chipset does your motherboard use?
Comment 36 Kevin Cozens 2007-04-14 11:05:41 EDT
It isn't fixed on my machine. The motherboard I have is a Magitronic GA-686LX
with a Genuine Intell Pentium II installed. The motherboard manual states the
board uses an Intel 440LX chipset. The block diagram shows "KBC 8042" being used
for the PS/2 keyboard and mouse interface.

The output from lspci is as follows:
00:00.0 Host bridge: Intel Corporation 440LX/EX - 82443LX/EX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440LX/EX - 82443LX/EX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 01)
00:0a.0 SCSI storage controller: Adaptec AHA-2940/2940W / AIC-7871
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X
(rev 5c)

Comment 37 Kevin Cozens 2007-04-16 13:57:08 EDT
I just tested kernel 2.6.20-1.2944.fc6 and still no mouse. The next few lines
are an extract from my system's start-up messages.

PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
serio: i8042 KBD port at 0x60,0x64 irq 1
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard as /class/input/input1

Can someone re-open this report or should I start open a new bug report?
Comment 38 John Oligario 2007-04-30 00:08:06 EDT
I have the same issue witn no mouse on 2.6.20, mouse inop. dropping back to 
2.6.18 and the mouse works. so there are still major problems with the mouse.
Comment 39 Chuck Ebbert 2007-04-30 18:39:17 EDT
(In reply to comment #38)
> I have the same issue witn no mouse on 2.6.20, mouse inop. dropping back to 
> 2.6.18 and the mouse works. so there are still major problems with the mouse.

What motherboard/system is this happening on?

Please post output of "lspci -vv"
Comment 40 Morris Maynard 2007-04-30 21:07:23 EDT
Here is the sysinfo for one system that exhibits this problem:
00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge 
(AGP disabled) (rev 03)
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 0

00:07.0 ISA bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 01)
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 0

00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01) (prog-
if 80 [Master])
	Control: I/O+ Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 0
	Region 4: I/O ports at ffa0 [size=16]

00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
	Control: I/O+ Mem- BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- 
Stepping- SERR- FastB2B-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Interrupt: pin A routed to IRQ 9

00:08.0 VGA compatible controller: S3 Inc. 86c764/765 [Trio32/64/64V+] (prog-if 
00 [VGA])
	Control: I/O+ Mem+ BusMaster+ SpecCycle+ MemWINV+ VGASnoop- ParErr- 
Stepping- SERR+ FastB2B-
	Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- 
<MAbort- >SERR- <PERR-
	Latency: 0
	Region 0: Memory at f8000000 (32-bit, non-prefetchable) [size=64M]

00:0a.0 Ethernet controller: Digital Equipment Corporation DECchip 21140 
[FasterNet] (rev 20)
	Subsystem: Unknown device 0a00:2114
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- 
Stepping- SERR+ FastB2B-
	Status: Cap- 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- 
<TAbort- <MAbort- >SERR- <PERR-
	Latency: 64, Cache Line Size 08
	Interrupt: pin A routed to IRQ 11
	Region 0: I/O ports at ec00 [size=128]
	Region 1: Memory at febff000 (32-bit, non-prefetchable) [size=4K]
	Expansion ROM at febe0000 [disabled] [size=64K]

Comment 41 Chuck Ebbert 2007-05-08 10:41:08 EDT
*** Bug 223603 has been marked as a duplicate of this bug. ***
Comment 42 Chuck Ebbert 2007-05-08 10:44:02 EDT
Fix for this failure on the remaining systems has been found:

http://git.kernel.org/?p=linux/kernel/git/dtor/input.git;a=commitdiff;h=d2ada5597d33a9108acb2caf912f85cbc9caab1e

Should be in the upcoming FC6 and FC7 kernels.
Comment 43 Chuck Ebbert 2007-05-16 17:36:54 EDT
patch is in next kernel.
Comment 44 Bob Rubendunst 2007-05-23 16:55:59 EDT
Folks - This is a C-O-M-P-L-I-C-A-T-E-D bug.

The bug came back with a vengence when I updated my FC6 box with the
2.6.20-1.2948.fc6 kernel and other sundry stuff from an automatic update.

I tried the 2.6.20-1.2952.fc6 kernel. Same problem (The mouse doesn't work.)

BUT, lets expand on that mouse doesn't work. I noticed with .2952.fc6, that
moving the mouse sometimes does something, but since the pointer is invisble,
it's practically worthless. And I think most folks would say "the mouse doesn't
work, rather than say, the mouse is invisible, and I can't manage to use it
while it is invisible <:-).

So, my latest version of mouse not working was because the nv driver was making
the mouse pointer invisible. Think (invisible == less useful)

I fixed it by editing the /etc/X11/xorg.conf file, and by adding the line 
Option "HWCursor" "false" tothe Device Section. I put this about 3 lines under
the line that reads Driver "nv"

So, All this time, or most of this time, I had a mouse, but since it was
invisible, I thouhght I didn't have a mouse. (In retrospect, I did notice from
the command line that the mouse was working by catting /dev/input/mice)

So, the nv driver (or something in X that interacts with it) is partly to blame
for some of these "mouse doesn't work" bugs.

The problem may or may not occur, when you use the "tainted" binary driver.

So, this problem, or constellation of problems, may depend on your hardware, or
whether you are using a nv driver, or maybe on other stuff, too.

Your mileage may vary.
Comment 45 Chuck Ebbert 2007-05-23 17:12:13 EDT
One possible workaround for no "AUX" port detection:
boot with the kernel parameter

    i8042.noloop
Comment 46 D. Hugh Redelmeier 2007-12-31 23:51:52 EST
Re comment #44:  I think that you are talking about a different bug:
https://bugzilla.redhat.com/show_bug.cgi?id=182517
https://bugs.freedesktop.org/show_bug.cgi?id=3009

Note You need to log in before you can comment on or make changes to this bug.