Bug 2246937
| Summary: | Upgrade breaks because of duplicate mount definition for mysql_boostrap container | |||
|---|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Luca Miccini <lmiccini> | |
| Component: | openstack-tripleo-heat-templates | Assignee: | Luca Miccini <lmiccini> | |
| Status: | CLOSED ERRATA | QA Contact: | Joe H. Rahme <jhakimra> | |
| Severity: | urgent | Docs Contact: | ||
| Priority: | urgent | |||
| Version: | 17.1 (Wallaby) | CC: | aromito, lsvaty, mariel, mburns | |
| Target Milestone: | async | Keywords: | Triaged | |
| Target Release: | 17.1 | |||
| Hardware: | x86_64 | |||
| OS: | Linux | |||
| Whiteboard: | ||||
| Fixed In Version: | openstack-tripleo-heat-templates-14.3.1-1.20230519151026.el9ost | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | ||
| Clone Of: | ||||
| : | 2247477 (view as bug list) | Environment: | ||
| Last Closed: | 2023-10-31 08:09:33 UTC | Type: | Bug | |
| Regression: | --- | Mount Type: | --- | |
| Documentation: | --- | CRM: | ||
| Verified Versions: | Category: | --- | ||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | ||
| Cloudforms Team: | --- | Target Upstream Version: | ||
| Embargoed: | ||||
| Bug Depends On: | ||||
| Bug Blocks: | 2247477, 2247606 | |||
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (Red Hat OpenStack Platform 17.1.1 bug fix and enhancement advisory), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2023:6203 |
Description of problem: ffu breaks with: 2023-10-29 02:10:19 | 2023-10-29 02:10:19.014997 | | WARNING | ERROR: Can't run container mysql_bootstrap 2023-10-29 02:10:19 | stderr: Error: /etc/ipa/ca.crt: duplicate mount destination 2023-10-29 02:10:19 | 2023-10-29 02:10:19.016547 | 525400d5-d0ae-4d94-a806-00000001899f | FATAL | Create containers managed by Podman for /var/lib/tripleo-config/container-startup-config/step_1 | database-2 | error={"changed": false, "msg": "Failed containers: mysql_bootstrap"} 2023-10-29 02:10:19 | 2023-10-29 02:10:19.017496 | 525400d5-d0ae-4d94-a806-00000001899f | TIMING | tripleo_container_manage : Create containers managed by Podman for /var/lib/tripleo-config/container-startup-config/step_1 | database-2 | 0:21:32.889055 | 2.46s /var/lib/tripleo-config/container-startup-config/step_1/mysql_bootstrap.json "volumes": [ "/etc/hosts:/etc/hosts:ro", "/etc/localtime:/etc/localtime:ro", "/etc/pki/ca-trust/extracted:/etc/pki/ca-trust/extracted:ro", "/etc/pki/ca-trust/source/anchors:/etc/pki/ca-trust/source/anchors:ro", "/etc/pki/tls/certs/ca-bundle.crt:/etc/pki/tls/certs/ca-bundle.crt:ro", "/etc/pki/tls/certs/ca-bundle.trust.crt:/etc/pki/tls/certs/ca-bundle.trust.crt:ro", "/etc/pki/tls/cert.pem:/etc/pki/tls/cert.pem:ro", "/dev/log:/dev/log", "/etc/ipa/ca.crt:/etc/ipa/ca.crt:ro", #<<<<< "/etc/puppet:/etc/puppet:ro", "/var/lib/kolla/config_files/mysql.json:/var/lib/kolla/config_files/config.json:rw,z", "/var/lib/config-data/puppet-generated/mysql:/var/lib/kolla/config_files/src:ro,z", "/var/lib/mysql:/var/lib/mysql:rw,z", "/etc/ipa/ca.crt:/etc/ipa/ca.crt:ro", #<<<<< "/etc/pki/tls/certs/mysql.crt:/var/lib/kolla/config_files/src-tls/etc/pki/tls/certs/mysql.crt:ro", "/etc/pki/tls/private/mysql.key:/var/lib/kolla/config_files/src-tls/etc/pki/tls/private/mysql.key:ro" ] } I suspect this issue happens only during upgrades because we use tripleo_container_manage instead of docker_config like we do during a deployment (I guess docker_config ignores the duplicate). we introduced the issue via https://review.opendev.org/c/openstack/tripleo-heat-templates/+/899236.