Bug 2247477
| Summary: | db-upgrade missing certificate and key leads to broken ffu3 | |||
|---|---|---|---|---|
| Product: | Red Hat OpenStack | Reporter: | Luca Miccini <lmiccini> | |
| Component: | openstack-tripleo-heat-templates | Assignee: | Luca Miccini <lmiccini> | |
| Status: | CLOSED ERRATA | QA Contact: | Archana Singh <arcsingh> | |
| Severity: | urgent | Docs Contact: | ||
| Priority: | urgent | |||
| Version: | 17.1 (Wallaby) | CC: | arcsingh, aromito, jhakimra, kthakre, lbezdick, lsvaty, mariel, mburns, mgarciac | |
| Target Milestone: | async | Keywords: | Triaged | |
| Target Release: | 17.1 | |||
| Hardware: | x86_64 | |||
| OS: | Linux | |||
| Whiteboard: | ||||
| Fixed In Version: | openstack-tripleo-heat-templates-14.3.1-1.20230519151027.el9ost | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | ||
| Clone Of: | 2246937 | |||
| : | 2247606 2248678 (view as bug list) | Environment: | ||
| Last Closed: | 2023-11-06 00:16:54 UTC | Type: | --- | |
| Regression: | --- | Mount Type: | --- | |
| Documentation: | --- | CRM: | ||
| Verified Versions: | Category: | --- | ||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | ||
| Cloudforms Team: | --- | Target Upstream Version: | ||
| Embargoed: | ||||
| Bug Depends On: | 2246937 | |||
| Bug Blocks: | 2247606 | |||
|
Comment 2
Luca Miccini
2023-11-01 13:56:28 UTC
[root@database-2 mysql]# cat db-upgrade.log
2023-11-01T16:46:29.242006458+00:00 stderr F + kolla_set_configs
2023-11-01T16:46:29.286966693+00:00 stderr F INFO:__main__:Loading config file at /var/lib/kolla/config_files/config.json
2023-11-01T16:46:29.286966693+00:00 stderr F INFO:__main__:Validating config file
2023-11-01T16:46:29.286966693+00:00 stderr F INFO:__main__:Kolla config strategy set to: COPY_ALWAYS
2023-11-01T16:46:29.286966693+00:00 stderr F INFO:__main__:Copying service configuration files
2023-11-01T16:46:29.286966693+00:00 stderr F INFO:__main__:Copying /dev/null to /etc/libqb/force-filesystem-sockets
2023-11-01T16:46:29.287486414+00:00 stderr F INFO:__main__:Setting permission for /etc/libqb/force-filesystem-sockets
2023-11-01T16:46:29.288044679+00:00 stderr F INFO:__main__:Deleting /etc/my.cnf.d/galera.cnf
2023-11-01T16:46:29.288199339+00:00 stderr F INFO:__main__:Copying /var/lib/kolla/config_files/src/etc/my.cnf.d/galera.cnf to /etc/my.cnf.d/galera.cnf
2023-11-01T16:46:29.288597570+00:00 stderr F INFO:__main__:Copying /var/lib/kolla/config_files/src/etc/sysconfig/clustercheck to /etc/sysconfig/clustercheck
2023-11-01T16:46:29.288906403+00:00 stderr F INFO:__main__:Copying /var/lib/kolla/config_files/src/root/.my.cnf to /root/.my.cnf
2023-11-01T16:46:29.289223938+00:00 stderr F INFO:__main__:Writing out command to execute
2023-11-01T16:46:29.289431405+00:00 stderr F INFO:__main__:Setting permission for /var/log/mysql
2023-11-01T16:46:29.289500349+00:00 stderr F INFO:__main__:Setting permission for /var/log/mysql/mysqld.log
2023-11-01T16:46:29.289574062+00:00 stderr F INFO:__main__:Setting permission for /var/log/mysql/db-upgrade.log
2023-11-01T16:46:29.295866995+00:00 stderr F + mysqladmin ping --silent
2023-11-01T16:46:29.300565399+00:00 stderr F ++ cat /var/lib/mysql/mysql_upgrade_info
2023-11-01T16:46:29.302969919+00:00 stderr F ++ true
2023-11-01T16:46:29.303216836+00:00 stderr F + upgraded_ver=
2023-11-01T16:46:29.305547390+00:00 stderr F ++ mysql --version
2023-11-01T16:46:29.305547390+00:00 stderr F ++ awk '-F[ ,]*' '{print $5}'
2023-11-01T16:46:29.308678444+00:00 stderr F + mysql_ver=10.5.22-MariaDB
2023-11-01T16:46:29.308719629+00:00 stderr F + '[' '' = 10.5.22-MariaDB ']'
2023-11-01T16:46:29.308719629+00:00 stderr F + chown -R mysql:mysql /var/lib/mysql
2023-11-01T16:46:29.316771023+00:00 stderr F + chown -R mysql:mysql /var/log/mysql
2023-11-01T16:46:29.321916850+00:00 stderr F + set -e
2023-11-01T16:46:29.321916850+00:00 stderr F + timeout 60 /bin/bash -c 'until mysqladmin -uroot ping 2>/dev/null; do sleep 1; done'
2023-11-01T16:46:29.321916850+00:00 stderr F + mysqld_safe --user=mysql --wsrep-provider=none --skip-networking --wsrep-on=off --log-error=/var/log/mysql/mysqld-upgrade.log
2023-11-01T16:46:29.525670255+00:00 stdout F 231101 16:46:29 mysqld_safe Logging to '/var/log/mysql/mysqld-upgrade.log'.
2023-11-01T16:46:29.570905293+00:00 stdout F 231101 16:46:29 mysqld_safe Starting mariadbd daemon with databases from /var/lib/mysql
3m
[root@database-2 mysql]# cat mysqld-upgrade.log
231101 16:46:29 mysqld_safe Starting mariadbd daemon with databases from /var/lib/mysql
2023-11-01 16:46:29 0 [Note] Starting MariaDB 10.5.22-MariaDB source revision 7e650253dc488debcb0898ebe6d385bf6dfa3656 as process 296
2023-11-01 16:46:29 0 [Warning] You need to use --log-bin to make --binlog-format work.
2023-11-01 16:46:29 0 [Note] InnoDB: Uses event mutexes
2023-11-01 16:46:29 0 [Note] InnoDB: Compressed tables use zlib 1.2.11
2023-11-01 16:46:29 0 [Note] InnoDB: Number of pools: 1
2023-11-01 16:46:29 0 [Note] InnoDB: Using crc32 + pclmulqdq instructions
2023-11-01 16:46:29 0 [Note] mariadbd: O_TMPFILE is not supported on /tmp (disabling future attempts)
2023-11-01 16:46:29 0 [Note] InnoDB: Using Linux native AIO
2023-11-01 16:46:29 0 [Note] InnoDB: Initializing buffer pool, total size = 134217728, chunk size = 134217728
2023-11-01 16:46:29 0 [Note] InnoDB: Completed initialization of buffer pool
2023-11-01 16:46:29 0 [Note] InnoDB: Upgrading redo log: 100663296 bytes; LSN=38052672
2023-11-01 16:46:29 0 [Note] InnoDB: Starting to delete and rewrite log file.
2023-11-01 16:46:29 0 [Note] InnoDB: Setting log file ./ib_logfile101 size to 100663296 bytes
2023-11-01 16:46:29 0 [Note] InnoDB: Renaming log file ./ib_logfile101 to ./ib_logfile0
2023-11-01 16:46:29 0 [Note] InnoDB: New log file created, LSN=38052672
2023-11-01 16:46:29 0 [Note] InnoDB: 128 rollback segments are active.
2023-11-01 16:46:29 0 [Note] InnoDB: Creating shared tablespace for temporary tables
2023-11-01 16:46:29 0 [Note] InnoDB: Setting file './ibtmp1' size to 12 MB. Physically writing the file full; Please wait ...
2023-11-01 16:46:29 0 [Note] InnoDB: File './ibtmp1' size is now 12 MB.
2023-11-01 16:46:29 0 [Note] InnoDB: 10.5.22 started; log sequence number 38052672; transaction id 36425
2023-11-01 16:46:29 0 [Note] Plugin 'FEEDBACK' is disabled.
2023-11-01 16:46:29 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_buffer_pool
2023-11-01 16:46:29 0 [Warning] 'innodb-locks-unsafe-for-binlog' was removed. It does nothing now and exists only for compatibility with old my.cnf files.
2023-11-01 16:46:29 0 [Note] InnoDB: Buffer pool(s) load completed at 231101 16:46:29
SSL error: Unable to get certificate from '/etc/pki/tls/certs/mysql.crt'
2023-11-01 16:46:29 0 [ERROR] Failed to setup SSL
2023-11-01 16:46:29 0 [ERROR] SSL error: Unable to get certificate
2023-11-01 16:46:29 0 [ERROR] Aborting
231101 16:46:29 mysqld_safe mysqld from pid file /var/lib/mysql/mariadb.pid ended
Manual test passes. Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (Red Hat OpenStack Platform 17.1.1 bug fix and enhancement advisory), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2023:6300 |