Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 2247606

Summary: db-upgrade missing certificate and key leads to broken ffu3
Product: Red Hat OpenStack Reporter: Lukas Bezdicka <lbezdick>
Component: openstack-tripleo-heat-templatesAssignee: Lukas Bezdicka <lbezdick>
Status: CLOSED ERRATA QA Contact: Joe H. Rahme <jhakimra>
Severity: high Docs Contact:
Priority: high    
Version: 17.1 (Wallaby)CC: arcsingh, aromito, dhill, fpiccion, jbadiapa, jhakimra, jmitterm, jschluet, kgilliga, lmiccini, lsvaty, mariel, mburns, mrunge, owalsh, prgutier
Target Milestone: z2Keywords: Regression, Triaged, ZStream
Target Release: 17.1   
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: openstack-tripleo-heat-templates-14.3.1-17.1.20231103010825.el9ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 2247477 Environment:
Last Closed: 2024-01-16 14:31:32 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 2246937, 2247477    
Bug Blocks:    

Comment 4 Lukas Bezdicka 2023-11-03 15:26:28 UTC
Error is:
2023-11-03 15:22:48 | 2023-11-03 15:22:48.957232 | 52540053-acdf-b374-ace9-000000002bfe |      FATAL | Start pacemaker cluster | database-1 | error={"changed": false, "msg": "Failed to set the state `online` on the cluster\n"}           
2023-11-03 15:22:48 | 2023-11-03 15:22:48.959166 | 52540053-acdf-b374-ace9-000000002bfe |     TIMING | Start pacemaker cluster | database-1 | 0:25:24.496858 | 302.12s

Comment 5 Lukas Bezdicka 2023-11-03 15:27:27 UTC
Solution for now is to simply restart pcs cluster as the root cause is pacemaker issue where it remembers shutdown state and turns off. rerun the upgrade command.

Comment 9 Matthias Runge 2023-11-28 10:07:57 UTC
adding the regression keyword since the upgrade worked from 16.2 to 17.1 before.

Comment 20 errata-xmlrpc 2024-01-16 14:31:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 17.1.2 bug fix and enhancement advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2024:0209

Comment 21 Lukas Bezdicka 2024-02-28 14:24:53 UTC
*** Bug 2258601 has been marked as a duplicate of this bug. ***

Comment 22 Luca Miccini 2024-04-18 13:02:51 UTC
*** Bug 2263624 has been marked as a duplicate of this bug. ***