Solution for now is to simply restart pcs cluster as the root cause is pacemaker issue where it remembers shutdown state and turns off. rerun the upgrade command.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory (Red Hat OpenStack Platform 17.1.2 bug fix and enhancement advisory), and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
https://access.redhat.com/errata/RHBA-2024:0209
Error is: 2023-11-03 15:22:48 | 2023-11-03 15:22:48.957232 | 52540053-acdf-b374-ace9-000000002bfe | FATAL | Start pacemaker cluster | database-1 | error={"changed": false, "msg": "Failed to set the state `online` on the cluster\n"} 2023-11-03 15:22:48 | 2023-11-03 15:22:48.959166 | 52540053-acdf-b374-ace9-000000002bfe | TIMING | Start pacemaker cluster | database-1 | 0:25:24.496858 | 302.12s