Bug 22561 - Traceback : "IndexError: list index out of range"
Summary: Traceback : "IndexError: list index out of range"
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Erik Troan
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-20 00:55 UTC by Sid Malhotra
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-21 20:04:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sid Malhotra 2000-12-20 00:55:35 UTC
Here's the full body of the saved file:
----
Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
IndexError: list index out of range

Local variables in innermost frame:
fstab: <fstab.GuiFstab instance at 84baed0>
mntPoint: /mnt/sysimage
selected: [ImageMagick, LPRng, MAKEDEV, Mesa, Mesa-devel, ORBit, ORBit-devel, SDL, SDL-devel, SDL_image, SDL_image-devel, 
SysVinit, WindowMaker, WindowMaker-libs, XFree86, XFree86-75dpi-fonts, XFree86-devel, XFree86-doc, XFree86-libs, XFree86-tools, 
XFree86-twm, XFree86-xdm, XFree86-xfs, Xaw3d, Xaw3d-devel, Xconfigurator, anacron, anonftp, apache, apache-devel, apache-manual, apmd, 
arpwatch, ash, asp2php, asp2php-gtk, aspell, at, audiofile, audiofile-devel, aumix, authconfig, autoconf, automake, autorun, awesfx, 
basesystem, bash, bash-doc, bc, bdflush, bind, bind-utils, binutils, bison, bug-buddy, byacc, bzip2, bzip2-devel, caching-nameserver, 
cdda2wav, cdecl, cdp, cdparanoia, cdrecord, chkconfig, chkfontpath, cleanfeed, compat-egcs, compat-egcs-c++, compat-glibc, 
compat-libstdc++, console-tools, control-center, control-center-devel, control-panel, cpio, cpp, cproto, cracklib, cracklib-dicts, crontabs             
-----

What am I doing wrong?  Is there a component I shouldn't install or is it just my version that's been corrupted?

Comment 1 Michael Fulbright 2000-12-21 19:23:41 UTC

*** This bug has been marked as a duplicate of 19928 ***

Comment 2 Brock Organ 2000-12-21 19:33:16 UTC
hi sid!

This problem occurs when performing a partitionless install that requires at
least one package from the 2nd cd ... we are working to find a fix for it ...
thanks for your report! :)

Comment 3 Erik Troan 2000-12-21 20:03:41 UTC

*** This bug has been marked as a duplicate of 19523 ***

Comment 4 Erik Troan 2000-12-21 20:06:24 UTC
An updates disk is available which fixes this -- for details, see bug 19523 (the
same disk fixes both this but and that one).


Note You need to log in before you can comment on or make changes to this bug.