Bug 225765 - Merge Review: japanese-bitmap-fonts (formerly fonts-japanese)
Merge Review: japanese-bitmap-fonts (formerly fonts-japanese)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Parag AN(पराग)
Fedora Package Reviews List
:
Depends On:
Blocks: 253149
  Show dependency treegraph
 
Reported: 2007-01-31 13:39 EST by Nobody's working on this, feel free to take it
Modified: 2008-07-03 23:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: fonts-japanese-0.20061016-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-03 02:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
panemade: fedora‑review+
petersen: fedora‑cvs+


Attachments (Terms of Use)
Some Changes to SPEC file (9.49 KB, patch)
2007-03-01 02:02 EST, Parag AN(पराग)
no flags Details | Diff

  None (edit)
Description Nobody's working on this, feel free to take it 2007-01-31 13:39:29 EST
Fedora Merge Review: fonts-japanese

http://cvs.fedora.redhat.com/viewcvs/devel/fonts-japanese/
Initial Owner: tagoh@redhat.com
Comment 1 Parag AN(पराग) 2007-03-01 01:55:18 EST
Mock build is fine but build.log reported
warning: File listed twice: /usr/share/fonts/japanese/misc
warning: File listed twice: /usr/share/fonts/japanese/misc/encodings.dir
warning: File listed twice: /usr/share/fonts/japanese/misc/fonts.alias
warning: File listed twice: /usr/share/fonts/japanese/misc/fonts.cache-1
warning: File listed twice: /usr/share/fonts/japanese/misc/fonts.dir

rpmlint on SRPM and RPMS reported
W: fonts-japanese no-url-tag
The URL tag is missing.

W: fonts-japanese unversioned-explicit-obsoletes ttfonts-ja
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-japanese unversioned-explicit-obsoletes jisksp14
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-japanese unversioned-explicit-obsoletes jisksp16-1990
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-japanese unversioned-explicit-obsoletes kappa20
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-japanese unversioned-explicit-obsoletes knm_new
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-japanese unversioned-explicit-obsoletes fonts-ja
The specfile contains an unversioned Obsoletes: token, which will match all
older, equal and newer versions of the obsoleted thing.  This may cause update
problems, restrict future package/provides naming, and may match something it
was originally not inteded to match -- make the Obsoletes versioned if
possible.

W: fonts-japanese rpm-buildroot-usage %build %configure --disable-bold
--disable-italic --with-fontdir=$RPM_BUILD_ROOT%{bmpfontdir}
$RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it
will break short circuiting.

W: fonts-japanese mixed-use-of-spaces-and-tabs (spaces: line 40, tab: line 1)
The specfile mixes use of spaces and tabs for indentation, which is a
cosmetic annoyance.  Use either spaces or tabs for indentation, not both.

E: fonts-japanese obsolete-not-provided ttfonts-ja
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-japanese obsolete-not-provided jisksp14
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-japanese obsolete-not-provided jisksp16-1990
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-japanese obsolete-not-provided kappa20
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-japanese obsolete-not-provided knm_new
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-japanese obsolete-not-provided fonts-ja
The obsoleted package must also be provided to allow clean upgrade paths
and not to break dependencies.

E: fonts-japanese file-in-usr-marked-as-conffile
/usr/share/fonts/japanese/TrueType/fonts.alias
A file in /usr is marked as being a configuration file.
Store your conf files in /etc/ instead.

E: fonts-japanese file-in-usr-marked-as-conffile
/usr/share/fonts/japanese/misc/fonts.alias
A file in /usr is marked as being a configuration file.
Store your conf files in /etc/ instead.

W: fonts-japanese non-conffile-in-etc /etc/ghostscript/CIDFnmap.ja
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

W: fonts-japanese non-conffile-in-etc /etc/ghostscript/cidfmap.ja
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

W: fonts-japanese non-conffile-in-etc /etc/ghostscript/FAPIcidfmap.ja
A non-executable file in your package is being installed in /etc, but is not
a configuration file. All non-executable files in /etc should be configuration
files. Mark the file as %config in the spec file.

Comment 2 Parag AN(पराग) 2007-03-01 02:02:56 EST
Created attachment 148997 [details]
Some Changes to SPEC file

Here is what you SHOULD do
1)Use attached SPEC
2)Add versions to Obsoletes
3)Add provides for each packages listed in Obsoletes
For Obsoletes warning you may like to see 
http://fedoraproject.org/wiki/Packaging/NamingGuidelines#head-3cfc1ea19d28975faad9d56f70a6ae55661d3c3d

4)Add fonts scriptlets.Check out
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets#head-4863fc4c93cec14292719d8901d83f5d90c3e477
Comment 3 Akira TAGOH 2007-03-01 08:15:12 EST
(In reply to comment #1)
> W: fonts-japanese no-url-tag
> The URL tag is missing.

It's hard to write down in URL tag because this packages includes a lot of fonts
that shipped on the different places. I mean, it's not a vendor-specific
package, but just collection.

> W: fonts-japanese unversioned-explicit-obsoletes ttfonts-ja

Fixed.

> W: fonts-japanese unversioned-explicit-obsoletes jisksp14

Fixed.

> W: fonts-japanese unversioned-explicit-obsoletes jisksp16-1990

Fixed.

> W: fonts-japanese unversioned-explicit-obsoletes kappa20

Fixed.

> W: fonts-japanese unversioned-explicit-obsoletes knm_new

Fixed.

> W: fonts-japanese unversioned-explicit-obsoletes fonts-ja

Fixed.

> W: fonts-japanese rpm-buildroot-usage %build %configure --disable-bold
> --disable-italic --with-fontdir=$RPM_BUILD_ROOT%{bmpfontdir}
> $RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it
> will break short circuiting.

Actually that line doesn't break anything. just lazy workaround to install the
font files under the proper place to be packaged, without any patches to
Makefile and extra parameters to make because DESTDIR isn't helpful since it
doesn't use automake.

> W: fonts-japanese mixed-use-of-spaces-and-tabs (spaces: line 40, tab: line 1)
> The specfile mixes use of spaces and tabs for indentation, which is a
> cosmetic annoyance.  Use either spaces or tabs for indentation, not both.

Fixed.

> E: fonts-japanese obsolete-not-provided ttfonts-ja

Fixed.

> E: fonts-japanese obsolete-not-provided jisksp14

Fixed.

> E: fonts-japanese obsolete-not-provided jisksp16-1990

Fixed.

> E: fonts-japanese obsolete-not-provided kappa20

Fixed.

> E: fonts-japanese obsolete-not-provided knm_new

Fixed.

> E: fonts-japanese obsolete-not-provided fonts-ja

Fixed.

> E: fonts-japanese file-in-usr-marked-as-conffile

Waiting for the conclusion on the list

> E: fonts-japanese file-in-usr-marked-as-conffile

Likewise.

> W: fonts-japanese non-conffile-in-etc /etc/ghostscript/CIDFnmap.ja

Fixed.

> W: fonts-japanese non-conffile-in-etc /etc/ghostscript/cidfmap.ja

Fixed.

> W: fonts-japanese non-conffile-in-etc /etc/ghostscript/FAPIcidfmap.ja

Fixed.
Comment 4 Akira TAGOH 2007-03-01 08:19:11 EST
(In reply to comment #2)
> 4)Add fonts scriptlets.Check out

Updated.

Comment 5 Parag AN(पराग) 2007-03-02 01:15:29 EST
Thanks for updating SPEC. But still i saw rpmlint reports some messages for
files installed under /etc which are not marked as %config(noreplace)
also there are still some files that are getting installed twice.
Can you check build.log?
Easy fix is to do following under %files
-%{bmpfontdir}
+%{bmpfontdir}/*.gz
Comment 6 Akira TAGOH 2007-03-02 09:31:57 EST
Well, I only saw three warning like:
W: fonts-japanese no-url-tag
W: fonts-japanese rpm-buildroot-usage %build %configure --disable-bold
--disable-italic --with-fontdir=$RPM_BUILD_ROOT%{bmpfontdir}
W: fonts-japanese mixed-use-of-spaces-and-tabs (spaces: line 149, tab: line 1)

I may be missing something but how did you see %config stuff?
spaces vs tabs issue and listing-files-twice issue was fixed in CVS with
revision 1.21 FYI.
Comment 7 Parag AN(पराग) 2007-03-14 01:43:25 EDT
In case you have %config and %config(noreplace) in your SPEC then You may like
to update the SPEC by removing that.
Check http://fedoraproject.org/wiki/Packaging/Minutes20070313
and http://fedoraproject.org/wiki/PackagingDrafts/UsrConfigs
Comment 8 Akira TAGOH 2007-03-15 07:47:35 EDT
Fixed in 0.20061016-4.fc7
Comment 9 Parag AN(पराग) 2007-03-26 07:15:20 EDT
The new build still have rpmlint problems.

W: fonts-japanese rpm-buildroot-usage %build %configure --disable-bold
--disable-italic --with-fontdir=$RPM_BUILD_ROOT%{bmpfontdir}
$RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it
will break short circuiting.

W: fonts-japanese conffile-without-noreplace-flag /etc/ghostscript/CIDFnmap.ja
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


W: fonts-japanese conffile-without-noreplace-flag /etc/ghostscript/FAPIcidfmap.ja
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


W: fonts-japanese conffile-without-noreplace-flag /etc/ghostscript/cidfmap.ja
A configuration file is stored in your package without the noreplace flag.
A way to resolve this is to put the following in your SPEC file:

%config(noreplace) /etc/your_config_file_here


Can you replace 
%config 
with
%config(noreplace) ?


Else everything looks OK to me for reviewing this package.
Comment 10 Akira TAGOH 2007-03-26 08:41:26 EDT
(In reply to comment #9)
> The new build still have rpmlint problems.
> 
> W: fonts-japanese rpm-buildroot-usage %build %configure --disable-bold
> --disable-italic --with-fontdir=$RPM_BUILD_ROOT%{bmpfontdir}
> $RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it
> will break short circuiting.

As I've mentioned at comment #3, I'm sure it won't breaks anything.

> W: fonts-japanese conffile-without-noreplace-flag /etc/ghostscript/CIDFnmap.ja
> A configuration file is stored in your package without the noreplace flag.
> A way to resolve this is to put the following in your SPEC file:
> 
> %config(noreplace) /etc/your_config_file_here

Do we really want to add noreplace flag to %config whatever happens?
I think I have explained about those files on IRC or somewhere though, those
files are written in PostScript actually. I understand it may be annoyed when
every upgrading happens but if updating is necessary for any serious reasons,
such as imcompatible or buggy code etc (not saying about it will happens, but
just may be likely), or things most likely to happen would be to change the
default font. how do we take care of that in general? just inform that on the
mailing list or so and change that manually?
We should prevent to happen that, but it may be hard to not happen that accident
at all. I'm just curious how to deal with that, because it will becomes not
working properly then.
Comment 11 Parag AN(पराग) 2007-04-10 06:24:52 EDT
Do we got any conclusions here to solve conffile-without-noreplace-flag problem?
Comment 12 Akira TAGOH 2007-04-11 06:16:22 EDT
all the files under /etc/ghostscript has been moved to
/usr/share/ghostscript/conf.d in 0.20061016-5.fc7.
Comment 13 Akira TAGOH 2007-04-17 01:49:26 EDT
updated fonts-japanese-0.20061016-6.fc7 is available btw.
Comment 14 Parag AN(पराग) 2007-04-17 03:27:45 EDT
Review:
+ package builds in mock (development i386).
- rpmlint is NOT silent for SRPM.
W: fonts-japanese rpm-buildroot-usage %build %configure --disable-bold
--disable-italic --with-fontdir=$RPM_BUILD_ROOT%{bmpfontdir}
$RPM_BUILD_ROOT should not be touched during %build or %prep stage, as it
will break short circuiting.
===> the above is OK for this package as its only installing font files.
+ rpmlint is silent for RPM.
+ source files match upstream.
e8a452c07cd5d1d31d3a6f32c2b74265  jisksp14.bdf.gz
d0d24d605ee62833234b711d6766e16c  jisksp16-1990.bdf.gz
c59fc33f4319a291c1f3f7d58d896b9c  k14-oldkanji.tar.gz
e0a103ceeffe0aa1c5670458f47452b3  kaname_k12_bdf.tar.gz
065920714d022cfd225feb6d80b03238  knm_new.tar.gz
a97a99acbee54976407dec828d03850c  mplus_bitmap_fonts-2.2.4.tar.gz
e0e1d3b139159a2af09bc9867c9a654b  warabi12-0.19a.tar.gz
19ff56e6de82e8f9a02c9cebf5af0cdc  Kappa20-0.396.tar.bz2
b312f77829011547b19fc16956dc6f12  sazanami-20061016.tar.bz2
38ce9221d128383a3f9f50eb641da424  shinonome-0.9.11-src.tar.bz2
b3900ebac6dd1044423bef5e23d653dc  imamura-jisx0213.tgz
a412bc6920d29be2689b3c3192bcdbd2  marumoji.tgz
c6b7771e4f00e310fe807b3245fd316e  vine-fonttools-0.1.tgz
fa5981d270f432d36818329c8878ba6e  xfonts_jp.tgz
77d997789026b1829bb4a33f65a0ce78  jiskan16-1990.bdf.Z
c9fd21064b4ad6f1af0bcdb40a4222ee  jiskano16-1997.bdf.Z
+ package meets naming and packaging guidelines.
+ specfile is properly named, is cleanly written
+ Spec file is written in American English.
+ Spec file is legible.
+ dist tag is present.
+ build root is correct.
+ license is open source-compatible.
+ License text is included in package.
+ %doc is small; no -doc subpackage required.
+ %doc does not affect runtime.
+ BuildRequires are proper.
+ %clean is present.
+ package installed properly.
+ Macro use appears rather consistent.
+ Package contains code, not content.
+ no headers or static libraries.
+ no .pc file present.
+ Used Fonts Scriptlet.
+ no -devel subpackage exists.
+ no .la files.
+ no translations are available.
+ Does owns the directories it creates.
+ no duplicates in %files.
+ file permissions are appropriate.
+ Provides: fonts-ja = 8.0-16 jisksp14 = 0.1-16 jisksp16-1990 = 0.1-16 kappa20 =
0.3-15 knm_new = 1.1-16 ttfonts-ja = 1.2-37

APPROVED.


Comment 15 Parag AN(पराग) 2007-05-03 02:24:38 EDT
CLOSING this bug for now as reviewed version fonts-japanese-0.20061016-6.fc7 of
this package is already in rawhide.
Comment 16 Jens Petersen 2008-07-03 22:11:13 EDT
This package is being renamed to japanese-bitmap-fonts in line with the name
of other Fedora fonts packages.
Comment 17 Jens Petersen 2008-07-03 23:12:51 EDT
Here is the 

New Package CVS Request
=======================
Package Name: japanese-bitmap-fonts
Short Description: A collection of Japanese bitmap fonts
Owners: tagoh
Branches: devel
InitialCC: fonts-sig
Cvsextras Commits: yes

Note You need to log in before you can comment on or make changes to this bug.