Bug 253149 - fonts-japanese should be renamed to japanese-bitmap-fonts
Summary: fonts-japanese should be renamed to japanese-bitmap-fonts
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: fonts-japanese   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: bzcl34nup
Keywords: Reopened
Depends On: 225765 253163 253175 266261
Blocks: GenericFontNames F10Target
TreeView+ depends on / blocked
 
Reported: 2007-08-17 06:44 UTC by Jens Petersen
Modified: 2008-10-24 19:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-24 19:43:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jens Petersen 2007-08-17 06:44:35 UTC
Description of problem:
To give better recognition to upstream fonts projects and more clearly
separate unrelated fonts coming from different upstream projects,
it would be good to move the Sazanami fonts to a new package
sazanami-fonts and also make one or more new packages for the bitmap fonts.
This will also allow the individual packages to better reflect
the upstream versioning numbers and license etc.

Additional info:
Since there are a lot of different bitmap fonts included in fonts-japanese
it is probably not feasible to split them all into individual packages.
I believe in the past we did have a number of different packages though
for some of them (eg jisksp*, kappa20).

Comment 1 Jens Petersen 2007-08-27 04:16:34 UTC
sazanami-fonts review has been completed and package built for devel.

I built fonts-japanese-0.20061016-10 without the sazanami fonts included.

Comment 2 Akira TAGOH 2007-09-21 01:52:51 UTC
Probably no more fonts are in fonts-japanese that can be separate except I have
already filed a review bug. waiting for finishing those reviews and push the
updated fonts-japanese against it. FYI.

Comment 3 Akira TAGOH 2007-09-26 12:35:13 UTC
Updated fonts-japanese has been built.

Comment 4 Jens Petersen 2007-10-24 01:32:57 UTC
IMHO it would still be good to move all the rest of the bitmap fonts to
a separate package or subpackage to make the Japanese fonts more modular.

Comment 5 Bug Zapper 2008-04-04 13:37:07 UTC
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 6 Bug Zapper 2008-05-14 03:07:51 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 7 Jens Petersen 2008-06-27 05:59:26 UTC
I am hoping to remove all our fonts-* packages in F10.

I think fonts-japanese can be renamed to japanese-bitmap-fonts or something like
that.

Comment 8 Jens Petersen 2008-07-04 03:13:58 UTC
cvs admin done

Comment 9 Jens Petersen 2008-07-04 03:14:51 UTC
Maybe the version number can be changed now?

Comment 10 Akira TAGOH 2008-07-10 05:17:16 UTC
japanese-bitmap-fonts-0.20080710-1.fc10 is available now.

Comment 11 Tony Fu 2008-09-10 03:18:19 UTC
requested by Jens Petersen (#27995)

Comment 12 Bill Nottingham 2008-10-24 19:43:44 UTC
Verified.


Note You need to log in before you can comment on or make changes to this bug.