Bug 22762 - [RFE] make resolving the dependencies more configurable
[RFE] make resolving the dependencies more configurable
Status: CLOSED DUPLICATE of bug 8495
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-22 19:22 EST by Enrico Scholz
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-27 11:42:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2000-12-22 19:22:44 EST
In the screen asking how to resolve missing dependencies, the choosen
option applies to *all*  packages. But often there are packages which are
really needed (so missing packages must be installed) and such which are
not necessarily but require a lot of other packages (e.g. in a non-KDE
environment a package linked against kde-libs requires the whole KDE base
and libs packages).

It would be usefully if the user can decide how the dependencies for a
*single* package shall be resolved. So the lower three radiobuttons
(install all packages, no packages or ignore deps) should be linked against
one entry in the missing dependency list and not affecting all.

When enabling multi-selection in the list the current behavior can be kept
by marking all entries when entering the screen.
Comment 1 Michael Fulbright 2000-12-27 11:42:20 EST
Looks very similar to bug 8595.

*** This bug has been marked as a duplicate of 8495 ***

Note You need to log in before you can comment on or make changes to this bug.