Bug 22838 - tex is broken
Summary: tex is broken
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 20802 23241 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-26 13:33 UTC by Gerald Teschl
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 19:37:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gerald Teschl 2000-12-26 13:33:02 UTC
tex is broken. All format files are missing. I tried to compile the format
for
latex, but tex will fail. The errors make absolutely no sense.

Comment 1 Jeff Johnson 2000-12-28 01:00:46 UTC
Can you p[rovide an example of what you are trying to do?

Comment 2 Gerald Teschl 2000-12-28 11:23:52 UTC
I tried to compile a simple latex file

%%%%%% test.tex %%%%%%%%
\documentclass{article}
 
\begin{document}
Hello world!
\end{document} 
%%%%%%%%%%%%%%%%%%

[gerald@soliton tmp]$ latex test.tex
This is TeX, Version 3.14159 (Web2C 7.3.1)
I can't find the format file `latex.fmt'!

Obviously there is the format missing (which should be present in a correct
installetion).
Hence I tried to compile it myself

[root@soliton /root]# tex -ini -fmt=latex -progname=latex latex.ini
This is TeX, Version 3.14159 (Web2C 7.3.1) (INITEX)
(/usr/share/texmf/tex/latex/config/latex.ini
(/usr/share/texmf/tex/latex/base/latex.ltx
(/usr/share/texmf/tex/latex/config/texsys.cfg)
! Arithmetic overflow.
l.125 \multiply\count2 60

<SNIP>

(That makes 100 errors; please try again.)
No pages of output.
Transcript written on latex.log.

I looked at the source where the first error occures in
/usr/share/texmf/tex/latex/base/latex.ltx
on line 515, where tex checks that the format is sufficiently recent. The code
is fine and
compiles with no errors on my Mac.


Comment 3 Jeff Johnson 2000-12-28 17:03:46 UTC
Yup, got it,  thanks for pointing to the problem. Compilation with -O0 fixes,
better fix
soon.

Comment 4 Jeff Johnson 2000-12-29 20:51:36 UTC
Better fix is to compile with gcc-2.96-69, done in tetex-1.0.7-11.

Comment 5 Jeff Johnson 2000-12-29 20:52:11 UTC
*** Bug 20802 has been marked as a duplicate of this bug. ***

Comment 6 Jeff Johnson 2001-01-03 19:36:52 UTC
*** Bug 23241 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.