Bug 229515 - firstbootWindow.py bug prevent reloading module correctly
Summary: firstbootWindow.py bug prevent reloading module correctly
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: firstboot   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Chris Lumens
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 229508 229510 229511 235859 241323 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-02-21 17:48 UTC by Nancy Wei
Modified: 2008-08-02 23:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 15:18:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch file (1.61 KB, patch)
2007-02-21 17:48 UTC, Nancy Wei
no flags Details | Diff

Description Nancy Wei 2007-02-21 17:48:14 UTC
Description of problem:

We enabled the language panel in firstboot. When an user selected a language 
other than default language we saw 3 problems. 
1. Left panel skipped Welcome title
2 . Right side panel mismatched with Left side title and the button underneath
3.  Right panels were still in a loop when Left side completed and the 
firstboot couldn't finish.


Version-Release number of selected component (if applicable):

RHEL 5
How reproducible:

Enable Language in Firstboot and Select a language which is not default
Steps to Reproduce:
1.
2.
3.
  
Actual results:

See above
Expected results:
Reload module correctly

Comment 1 Nancy Wei 2007-02-21 17:48:14 UTC
Created attachment 148512 [details]
patch file

Comment 2 Chris Lumens 2007-02-21 17:57:52 UTC
*** Bug 229508 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2007-02-21 17:58:05 UTC
*** Bug 229510 has been marked as a duplicate of this bug. ***

Comment 4 Chris Lumens 2007-02-21 17:58:26 UTC
*** Bug 229511 has been marked as a duplicate of this bug. ***

Comment 5 Chris Lumens 2007-02-22 14:11:29 UTC
How did you enable the language module?  Were you running under reconfig mode?

Comment 6 Nancy Wei 2007-02-22 15:02:41 UTC
(In reply to comment #5)
> How did you enable the language module?  Were you running under reconfig 
mode?

I am sorry about  duplicate tickets but web response confused me.  Every time 
after I sent out the report I got message "product name is invalid or doesn't 
exis". So I tried again and again with different name or version.

language.py is same as language_gui.py except without moduleClass 
= "reconfig". language.py is placed within /usr/share/firstboot/module

Comment 7 Chris Lumens 2007-02-27 16:38:25 UTC
Thanks for the patch.  I've verified that this corrects the problem on HEAD and
will be rebuilding for Fedora shortly.  I've also set some flags on this bug so
we can get consideration for 5.1.

Comment 8 Chris Lumens 2007-04-11 14:03:49 UTC
*** Bug 235859 has been marked as a duplicate of this bug. ***

Comment 9 RHEL Product and Program Management 2007-04-25 21:15:57 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 11 Chris Lumens 2007-05-25 15:06:43 UTC
*** Bug 241323 has been marked as a duplicate of this bug. ***

Comment 12 Chris Lumens 2007-06-21 20:21:02 UTC
This patch appears to break the RHN module.  Instead of displaying the first
portion of the RHN set of modules, it skips to the end.  Then once you press
next on that screen, the sidebar pointer is stuck and the right side gets out of
sync.  Looks like it's the insert_page call to me.

I'm not having much luck fixing this.  Any ideas?

Comment 13 Chris Lumens 2007-08-22 15:18:00 UTC
This is not going to be able to be fixed in 5.1 due to impact on the RHN module
that I was not able to solve in time.


Note You need to log in before you can comment on or make changes to this bug.