Bug 23118 - up2date core dumps...
Summary: up2date core dumps...
Status: CLOSED DUPLICATE of bug 18994
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-02 01:03 UTC by Brad Kittredge
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-08 06:31:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brad Kittredge 2001-01-02 01:03:07 UTC
Package:  up2date
Severity: critical
Version:  2.1.7-1
Synopsis: Segfault in up2date
Class:    sw-bug

Distribution: Red Hat Linux release 7.0 (Guinness)
System: Linux 2.2.16-22 i686 unknown
C library: glibc-2.2-9
C compiler: 2.96
glib: 1.2.8
GTK+: 1.2.8
ORBit: ORBit 0.5.5
gnome-libs: gnome-libs 1.2.8


Description:
up2date segfaults every time with the following message:

Removing packages with files marked to skip frup2date segfaults every
time with the following message:

Removing packages with files marked to skip from list...
Segmentation fault (core dumped)

Debugging information:
(no debugging symbols found)...
Core was generated by `python -u /usr/sbin/up2date -u'.
Program terminated with signal 11, Segmentation fault.
[New Thread 1024 (LWP 11142)]
#0  0x401bc8cc in doBuildFileList () from /usr/lib/librpm.so.0
#0  0x401bc8cc in doBuildFileList () from /usr/lib/librpm.so.0
#1  0x401bca76 in rpmBuildFileList () from /usr/lib/librpm.so.0
#2  0x401b18e1 in filenamesTag () from /usr/lib/librpm.so.0
#3  0x4001ef56 in hdrSubscript ()
   from /usr/lib/python1.5/site-packages/rpmmodule.so
#4  0x8066194 in PyObject_GetItem ()
#5  0x8052046 in PyEval_EvalCode ()
#6  0x8053568 in PyEval_EvalCode ()
#7  0x8053568 in PyEval_EvalCode ()
#8  0x8053568 in PyEval_EvalCode ()
#9  0x8053568 in PyEval_EvalCode ()
#10 0x8053568 in PyEval_EvalCode ()
#11 0x805154e in PyEval_EvalCode ()
#12 0x8061698 in PyRun_File ()
#13 0x8060d41 in PyRun_SimpleFile ()
#14 0x804fde8 in Py_Main ()
#15 0x4007ffd1 in __libc_start_main (main=0x804f87c <main>, argc=4,
    ubp_av=0xbffffa44, init=0x804ee50 <_init>, fini=0x80891cc <_fini>,
    rtld_fini=0x4000e254 <_dl_fini>, stack_end=0xbffffa3c)
    at ../sysdeps/generic/libc-start.c:118
#0  0x401bc8cc in doBuildFileList () from /usr/lib/librpm.so.0
No symbol table info available.
#1  0x401bca76 in rpmBuildFileList () from /usr/lib/librpm.so.0
No symbol table info available.
#2  0x401b18e1 in filenamesTag () from /usr/lib/librpm.so.0
No symbol table info available.
#3  0x4001ef56 in hdrSubscript ()
   from /usr/lib/python1.5/site-packages/rpmmodule.so
No symbol table info available.
#4  0x8066194 in PyObject_GetItem ()
No symbol table info available.
#5  0x8052046 in PyEval_EvalCode ()
No symbol table info available.
#6  0x8053568 in PyEval_EvalCode ()
No symbol table info available.
#7  0x8053568 in PyEval_EvalCode ()
No symbol table info available.

Comment 1 Brad Kittredge 2001-01-02 01:31:25 UTC
Sorry, but bmk@aa.net is a dead mail account ;-)

The rpm version is: rpm-4.0.2-0.7

With default version of rpm I got an identical result as bug # 22974.  Hope this
helps.

Comment 2 Adrian Likins 2001-02-08 06:02:15 UTC
This appears to be a bug with rpm version 4.0.2-0.7.

This should be fixed in the next release of rpm.
In the meantime, this shouldnt happen with the original
rpm 4.0-4 from 7.0. 

I'm not sure why you would be having the error reported
in #22974. I havent been able to reproduce that behaviour
here. Can you verify with rpm, and rpm-python were reinstalled
with the original versions?

Comment 3 Brad Kittredge 2001-02-08 06:31:32 UTC
I reverted to the version of rpm that ships with RH 7.0 and executed the
following: rpm --rebuilddb

Below is the output from up2date after I did this:

Retrieving list of all available packages...

Removing installed packages from list of updates...
0.077% <snip>
Removing packages marked to skip from list...
0.202% <snip>
Getting headers for available packages...
0.202% <snip>
Removing packages with files marked to skip from list...
0.202% <snip> 3.651% There was a fatal RPM error.  The message was:
error reading from database



Comment 4 Preston Brown 2001-02-09 03:48:51 UTC

*** This bug has been marked as a duplicate of 18994 ***


Note You need to log in before you can comment on or make changes to this bug.