Bug 23264 - Mouse detected incorrectly; can hang install!
Mouse detected incorrectly; can hang install!
Status: CLOSED DUPLICATE of bug 25771
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
Florence Gold
:
: 26313 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-03 20:14 EST by Brian Ginter
Modified: 2007-04-18 12:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 17:17:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Ginter 2001-01-03 20:14:40 EST
I am currently using a Logitech Cordless MouseMan Wheel. When it is 
plugged into a USB port anaconda incorrectly identifies a generic 3 button 
PS/2 mouse and the mouse will not work.
When plugged into the PS/2 port everything works fine.(except the wheel :-)
Comment 1 Michael Fulbright 2001-01-09 17:55:52 EST
Passing to QA to reproduce if we have required hw.
Comment 2 Brent Nordquist 2001-01-11 15:20:35 EST
I had something similar happen in Florence beta-2:  I had a Microsoft two-button
serial mouse (DB9) plugged into COM1 (this older machine doesn't have any mouse
hardware), and it identified the mouse as three-button PS/2:

Running anaconda - please wait...
Probing for mouse type...
Found a Generic - 3 Button Mouse (PS/2)

I changed it to two-button serial (emulate three) on COM1 later during the
actual install.
Comment 3 Glen Foster 2001-01-11 16:03:38 EST
This defect is considered MUST-FIX for Florence Gold release
Comment 4 Edward Kuns 2001-01-14 19:08:09 EST
Just to add a little more information, I have a Logitech USB+PS/2
LED mouse.  In Flo' beta-2, anaconda detects this as PS/2 whether I
plug it in as PS/2 or as USB.

Worse, shortly after X is started during the install, everything hangs.
(At the language selection screen.)  The keyboard stops responding.
Even the three-finger salute does nothing.  If I CTRL-ALT-F2 away from
this screen after X startup but *before* the language selection screen
appears, all is fine until I switch back to X.  The other windows are
alive.  But as soon as I ALT-F7 back to X, everything hangs with no
response to CTRL-ALT-DEL or CTRL-ALT-Backspace or CTRL-ALT-F<anything>.

If I plug the exact same mouse in with its PS/2 adaptor, all is fine.

Hardware = ABIT KT7-RAID with Athlon 1.1 Gig and 256 Meg memory.

Same behavior in Flo' beta-1 and Flo' beta-2.
Comment 5 Bill Nottingham 2001-02-06 13:31:57 EST
*** Bug 26313 has been marked as a duplicate of this bug. ***
Comment 6 R P Herrold 2001-02-11 20:55:58 EST
Hardware:
 
HP Netserver 5/100 LH -- Pent, 192M, PCI 3c905B nic, onboard
Adaptec AIC-7850 controller pair at rev 1.19S6; all SCSI
drives; Texel DM-xx24 K scsi CD-ROM drive (tray type), P/S 2
kbd and mouse (true MS 2 button serial compatible - PS/2
connector)      

Started with the 'lowres' option, becuase it had graphics
issues with the 1 M onboard Cirrus video
 
During the anaconda load, it misdetected the true MS 2-button
serial compatible mouse as a 3-button PS/2 compatible mouse
Comment 7 R P Herrold 2001-02-11 22:16:45 EST
More info:

On Sun, 11 Feb 2001, Bill Nottingham wrote:
 
> R P Herrold (herrold@owlriver.com) said:
> > During the anaconda load, it misdetected the true MS 2-button
> > serial compatible mouse as a 3-button PS/2 compatible mouse
>
> Technically, it misdetected the presence of a PS/2 mouse, and
> then never bothered to look for the serial mouse. Same effect,
> though.
 
... Indeed, sort of, but no ... it _is_ in the PS/2 port, but
through a serial-to-PS/2 adapter pigtail -- I had forgotten
that, It is a "Serial - Mouse Port Compatible Mouse", MS Part
no 37967 ...
Comment 8 Bill Nottingham 2001-02-12 17:16:44 EST
If it's in the PS/2 port, it's a PS/2 mouse.
Comment 9 Bill Nottingham 2001-02-12 17:17:09 EST

*** This bug has been marked as a duplicate of 25771 ***

Note You need to log in before you can comment on or make changes to this bug.