Bug 25771 - [PS/2] System did not find serial mouse
[PS/2] System did not find serial mouse
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ben LaHaise
Brock Organ
Florence Gold
:
: 23264 30231 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-02 18:00 EST by Mark H Johnson
Modified: 2007-04-18 12:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 03:37:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark H Johnson 2001-02-02 18:00:30 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i586)


During installation, the display indicated that a "PS/2 mouse" was found.
The system being used has a serial mouse. Was unable to use the graphical
interface for installation.

Reproducible: Always
Steps to Reproduce:
1.Boot with a system having a serial mouse.
2.default gives you no chance.
2b.expert mode allows you to select a serial mouse, but it still didn't
work.
	

Actual Results:  Pointer is stuck in the center of the screen - unable to
move it.
Was able to install the system using the text screens & able to use the two
button serial mouse to get X configured, etc.

Expected Results:  Pointer should move (like it does NOW...).

Its an older system, 166mhz Pentium, serial mouse interface (actually a
trackball -but the mice I tried failed too) on ttyS0, CD, floppy, etc.
Comment 1 Michael Fulbright 2001-02-02 23:04:00 EST
Assigning to a defeveloper - is this a known 2.4 problem Bill?
Comment 2 Glen Foster 2001-02-05 17:34:33 EST
We (Red Hat) should really try to fix this before next release.
Comment 3 Bill Nottingham 2001-02-05 17:41:47 EST
It didn't find the serial mouse, because it never looked for it, since
it 'found' a PS/2 mouse.

This is the PS/2 misdetection problem; assigning to kernel.
Comment 4 Michael K. Johnson 2001-02-08 18:16:47 EST
Since Ben is looking into this...
Comment 5 Bill Nottingham 2001-02-12 17:17:05 EST
*** Bug 23264 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2001-03-01 19:01:52 EST
*** Bug 30231 has been marked as a duplicate of this bug. ***
Comment 7 Ed McKenzie 2001-03-07 03:37:18 EST
kernel 2.4.2-0.1.19 still causes kudzu to detect a nonexistant PS/2 mouse.
Comment 8 Bill Nottingham 2001-03-16 18:06:51 EST
kudzu is fixed as of 0.98.0-1 or so.

Note You need to log in before you can comment on or make changes to this bug.