Bug 232679 - applet erraneously shows package as available for update on 64 bit
Summary: applet erraneously shows package as available for update on 64 bit
Status: CLOSED DUPLICATE of bug 232654
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhn-applet (Show other bugs)
(Show other bugs)
Version: 4.4
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Shannon Hughes
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
: 232097 (view as bug list)
Depends On: 232654
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-03-16 16:24 UTC by Pradeep Kilambi
Modified: 2007-11-17 01:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-22 14:24:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot illustrating the problem (113.70 KB, image/png)
2007-05-15 19:30 UTC, Matěj Cepl
no flags Details

Description Pradeep Kilambi 2007-03-16 16:24:50 UTC
+++ This bug was initially created as a clone of Bug #232654 +++

Description of problem:
The applet shows that firefox is available for update with a red
ball with an exclamation point in it and when you click it, it tells me that
there is a new version of firefox which is available.

In this case an i386 version of firefox is installed on x86_64 box. If we look
at the subscribed channels an update for x86_64 version of firefox is available
and not i386. But applet shows that firefox is available for update though
nothing new is available for i386.

The possible issue could be that applet lists updates based on just the name
rather than considering arch as well

Version-Release number of selected component (if applicable):
rhn-applet-2.1.25-22

To Reproduce:

- register a 64 bit(with a firefox.i386 installed) to prod
- prod has a firefox.x86_64 available for update.
- now applet shows firefox in the available packages for update even though only
x86_64 version is available.
  
Actual results:
shows unavailable package as available for update

Expected results:
should not list unavailable packages

Comment 1 Shannon Hughes 2007-03-20 16:24:39 UTC
*** Bug 232097 has been marked as a duplicate of this bug. ***

Comment 4 Matěj Cepl 2007-05-15 19:28:20 UTC
I can reproduce this even with i386 xen RHEL4 full-virt guest on x86_64 FC6 host.
See attached screenshot.

Comment 5 Matěj Cepl 2007-05-15 19:30:37 UTC
Created attachment 154765 [details]
screenshot illustrating the problem

And BTW we are talking about Nahant Update 5 here (package
rhn-applet-2.1.25-22)

Comment 6 Todd Sanders 2007-05-22 14:24:33 UTC

*** This bug has been marked as a duplicate of 232654 ***

Comment 7 Brandon Perkins 2007-05-24 17:20:52 UTC
DUPLICATE of bug 232654


Note You need to log in before you can comment on or make changes to this bug.