Bug 236974 - (F7XINPUTSH) Fedora 7: SCIM Launch Problem
Fedora 7: SCIM Launch Problem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
: i18n
: 240436 241626 (view as bug list)
Depends On: 237054
Blocks: FC7Blocker
  Show dependency treegraph
 
Reported: 2007-04-18 14:19 EDT by Warren Togami
Modified: 2007-11-30 17:12 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-18 11:49:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-04-18 14:19:12 EDT
April 16th there was a problematic comps change to F7 that necessitated
associated other changes.

FC6 and RHEL5 Behavior
======================
- scim packages were installed only if you chose languages that need it
during install, or used groupinstall on a language.
- If scim is installed, it automatically runs in the desktop of any
language.
- Enabled-by-default is potentially annoying to non-SCIM users.
However, since it is not installed by default, those users did not 
complain so much.  Users who didn't want it were told to uninstall it 
(which matches Windows and Mac behavior.)
- im-chooser provided a way for the user to override the system's
setting, to disable SCIM, or choose a different IM software for that
user's desktop.

Yesterday's Change
==================
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=229742
We attempted to solve this rare groupremove problem by making SCIM
install with the base-x group.  This means that *ALL* Fedora desktop
installations will have SCIM both installed and running.

Due to the enabled-by-default behavior, SCIM annoys non-SCIM users who
accidentally hit SCIM hotkeys, popping up the language bar or inputting
unwanted characters.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=235435
In an attempt to mitigate this enabled-by-default behavior, this change
was hastily made without being thoroughly thought through.  It disables
the SCIM activation hotkey (CTRL-Space) if you login to a new user
profile for the first time with a language that doesn't normally need SCIM.

Disabling the hotkey by default is problematic:
===============================================
- This creates inconsistent behavior between SCIM user profiles created
at different times, depending on what locale and version of Fedora was
running at the time.  (Source of support and debugging confusion.)
- This forces certain users to use a confusingly disjoint configuration
within SCIM Setup, which is separate from im-chooser.  (User confusion)
- This still has an unnecessary memory footprint for users who
absolutely never need SCIM.

Solution
========
Jeremy Katz, the RH Desktop team and I have agreed upon the following.

1) Undo the hack made in Bug #235435.
2) Change SCIM's automatic launching to be locale specific.  For
example, Asian languages are in a SCIM automatic list, so launch
automatically in those languages.  Do not launch SCIM automatically in
other languages.
3) Modify im-chooser to allow the user to override the automatic SCIM
launch behavior.  im-chooser should offer something like:
   * Always Use [SCIM]
   * Follow the system-wide configuration [SCIM]
   * Never use input methods

"Follow the system-wide configuration [SCIM]" would be the default for
all users.  The user can then choose to explicitly override, to enable
or disable input methods independently of their locale.

Can we please implement this before Fedora 7?  The SCIM running by
default in all desktop languages is unacceptable, and the hack in Bug
#235435 confuses the issue, hiding the real problem.

We are willing to be flexible during the freeze to fix this.
Comment 1 Jeremy Katz 2007-04-18 20:08:41 EDT
It would be really good to get at least 1 and 2 resolved for test4.  Even better
would be to have them fixed for the weekly live CD spin tomorrow afternoon.
Comment 2 Warren Togami 2007-04-18 22:49:10 EDT
https://www.redhat.com/archives/fedora-maintainers/2007-April/msg00393.html
Recommendations for the design of part #3.
Comment 3 Scott Tsai 2007-04-21 14:37:10 EDT
I've actually had more than one  Taiwanese user that use the en_US locale
complain to me they don't know how to activate the input method system and get
English error messages from gcc at the same time.

Is there a way to make im-chooser more discoverable?
"System" -> "Preference" -> "Personal" -> "Input Method" is really quite deep.
If only we could search the desktop menus ..
Comment 4 Warren Togami 2007-04-22 13:55:34 EDT
Sorry Scott.  While I can sympathize with your situation because I sometimes use
Japanese on en_US, you have to admit that this is a less common case.  It is
*NOT* overly difficult to enable IM on our desktops on non-Asian languages when
compared to other operating systems.
Comment 5 Jens Petersen 2007-04-23 04:33:02 EDT
(In reply to comment #4)
> Sorry Scott.  While I can sympathize with your situation because I sometimes use
> Japanese on en_US, you have to admit that this is a less common case.  It is
> *NOT* overly difficult to enable IM on our desktops on non-Asian languages when
> compared to other operating systems.

Actually I sympathize strongly with this comment.  Being able to just run
"yum groupinstall chinese-support" and knowing it run by default is much nicer
for users than having to find and fiddle with im-chooser and it works great
in FC6 and RHEL5 where scim is not installed by default.

So either we should not install scim by default or otherwise yes it seems
we need to disable it by default for non-Asian desktops.
Comment 6 Jeremy Katz 2007-04-23 08:56:54 EDT
(In reply to comment #5)
> (In reply to comment #4)
> > Sorry Scott.  While I can sympathize with your situation because I sometimes use
> > Japanese on en_US, you have to admit that this is a less common case.  It is
> > *NOT* overly difficult to enable IM on our desktops on non-Asian languages when
> > compared to other operating systems.
> 
> Actually I sympathize strongly with this comment.  Being able to just run
> "yum groupinstall chinese-support" and knowing it run by default is much nicer
> for users than having to find and fiddle with im-chooser and it works great
> in FC6 and RHEL5 where scim is not installed by default.

Just because scim is installed, though, doesn't mean that all users on the
system are going to use it.  In fact, maybe just I do and the rest of my family
doesn't.

> So either we should not install scim by default or otherwise yes it seems
> we need to disable it by default for non-Asian desktops.

Not installing it by default really doesn't do anything to fix the problem; it
just continues to pretend that it's not there.  And it's not really even an
option any more with the move towards having the live CD available as one of the
things we are doing with the live CD is showing off some of the breadth of our
locale support.
Comment 7 Jens Petersen 2007-04-24 01:48:00 EDT
> 3) Modify im-chooser to allow the user to override the automatic SCIM
> launch behavior.  im-chooser should offer something like:
>    * Always Use [SCIM]
>    * Follow the system-wide configuration [SCIM]
>    * Never use input methods
> Can we please implement this before Fedora 7?

Can you please file another bug for this against im-chooser?

(In reply to comment #6)
> Not installing it by default really doesn't do anything to fix the problem

Agreed.  But installing the core scim packages alone doesn't really make sense
either if they are not being used.  It would be better only to install them
when scim IMEngines are installed: so I would prefer a solution which removes
the scim cores package from comps completely.
Comment 8 James Ralston 2007-04-30 19:05:07 EDT
I agree with Scott Tsai in comment 3: im-chooser needs to be more obvious.

I'm an en_US user who occasionally writes Japanese, so it vexed me greatly when
scim "stopped working" after I re-sync'ed against Rawhide last week.  Even more
confusingly, launching scim manually (via "scim -d") didn't work, either; the
resulting scim didn't pay attention to my hotkeys.

The only way I was able to figure out that I needed to run im-chooser was to dig
through Bugzilla, which is not something the average user (or even a previous
Fedora user who is used to the "scim is always running" behavior) is going to do.
Comment 9 Jens Petersen 2007-04-30 19:52:05 EDT
(In reply to comment #3)
> I've actually had more than one  Taiwanese user that use the en_US locale
> complain to me they don't know how to activate the input method system and get
> English error messages from gcc at the same time.

You could do this by setting LC_CTYPE=zh_TW.UTF-8 in "~/.i18n" say.
(Though scim itself follows LANG not LC_CTYPE for it locale dependent defaults.)

(In reply to comment #8)
> I'm an en_US user who occasionally writes Japanese, so it vexed me greatly when
> scim "stopped working" after I re-sync'ed against Rawhide last week.  Even more
> confusingly, launching scim manually (via "scim -d") didn't work, either; the
> resulting scim didn't pay attention to my hotkeys.

The old hotkeys should be back now.

> The only way I was able to figure out that I needed to run im-chooser was to dig
> through Bugzilla, which is not something the average user (or even a previous
> Fedora user who is used to the "scim is always running" behavior) is going to do.

I know. :(  I added a note yesterday to the i18n relnotes FWIW.
Comment 10 Jens Petersen 2007-05-17 21:16:52 EDT
*** Bug 240436 has been marked as a duplicate of this bug. ***
Comment 11 Warren Togami 2007-05-18 11:49:10 EDT
The minimum requirements for F7 were done here, we can close this.
Comment 12 Jens Petersen 2007-05-29 00:33:35 EDT
*** Bug 241626 has been marked as a duplicate of this bug. ***
Comment 13 Matěj Cepl 2007-06-20 09:04:11 EDT
Just IMHO this is not a problem just for Asian languages -- Compose key doesn't
work without some IM running and by default we have no IM method for languages
which don't have to have IM.
Comment 14 Jens Petersen 2007-06-20 21:27:16 EDT
(In reply to comment #13)
> Compose key doesn't work without some IM running

Not quite sure what you mean here.  Compose should be handled by xkb
which does not require IM.
Comment 15 Matěj Cepl 2007-06-21 05:36:51 EDT
OK, I am really not sure how it should work, but unless I installed scim,
Compose key (remapped CapsLock) didn't work for me, Compose--- created just
three simple dashes. Then I installed scim and I get my m-dash again.

Note You need to log in before you can comment on or make changes to this bug.