Bug 237831 - Wrong init script
Wrong init script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: isdn4k-utils (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
BaseOS QE
:
: 242481 (view as bug list)
Depends On:
Blocks: 237789 237832 237833 242493 242495
  Show dependency treegraph
 
Reported: 2007-04-25 11:37 EDT by Michal Marciniszyn
Modified: 2014-02-10 18:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 10:47:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Marciniszyn 2007-04-25 11:37:49 EDT
Description of problem:
Through the script, following constructions are used:
[ -f /sbin/capiinit ] || exit 0
[ -f /etc/capi.conf ] || exit 0
Effectively, they return 0 even when the service is not started or running
(start/status command). Also wrong return codes are present through the script.

Version-Release number of selected component (if applicable):
all

How reproducible:
always

Steps to Reproduce:
1. remove capi.conf file
2. service capi start/status
3. echo $?
  
Actual results:
0

Expected results:
non-zero error code/correct service status

Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.
Comment 1 Phil Knirsch 2008-04-29 11:32:25 EDT
Proposing for RHEL-5.3, waiting with final ACK on developer review.

Read ya, Phil 
Comment 2 Ngo Than 2008-05-28 11:04:35 EDT
+devel ack
Comment 6 Ngo Than 2008-07-28 05:55:47 EDT
*** Bug 242481 has been marked as a duplicate of this bug. ***
Comment 15 errata-xmlrpc 2009-06-17 10:47:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1112.html

Note You need to log in before you can comment on or make changes to this bug.