Bug 239180 - Hal sets wrong flags on USB hard drive after suspend
Summary: Hal sets wrong flags on USB hard drive after suspend
Status: CLOSED DUPLICATE of bug 238385
Alias: None
Product: Fedora
Classification: Fedora
Component: hal   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-05-05 17:26 UTC by George Billios
Modified: 2013-03-06 03:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-06 14:25:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg after connecting the drive and mount attempt (2.69 KB, text/plain)
2007-05-06 06:29 UTC, George Billios
no flags Details
lshal output (167.12 KB, text/plain)
2007-05-06 06:30 UTC, George Billios
no flags Details

Description George Billios 2007-05-05 17:26:42 UTC
Description of problem:

After resuming from suspend and connecting a usb hard drive, it is not
automatically mounted and when trying to do so with gnome-mount in text mode the
error is that the partition has the 'ignore' flag set and so it can't be mounted

Version-Release number of selected component (if applicable):

hal-0.5.9-6.fc7

How reproducible:

Always after suspend

Steps to Reproduce:
1. Suspend the pc
2. Resume
3. Connect a usb hard drive
  
Actual results:

Nothing happens


Expected results:

The device should be automatically mounted

Additional info:

Restarting hal daemon by hand resolves this, so maybe had should be restarted
after a suspend

Comment 1 David Zeuthen 2007-05-05 20:30:15 UTC
Sounds weird. Can you reproduce this? Two requests

 1. When this is happening, please run lshal and attach the output to this bug 

 2. Do you have the file /usr/share/hal/fdi/policy/gparted-disable-automount.fdi
or any other partitioning program running when connecting the drive?

Thanks.


Comment 2 George Billios 2007-05-06 06:28:53 UTC
Hi there,

First I need to change the description because the problem is not just after
suspend but also happens after a fresh start. 

Please find attached below the output from dmesg regarding the drive recognition
and the attempts to mount it by hand and also the lshal output.

Regarding your second question, no the fdi you wrote doesn't exist and I have no
partitioning program running. 

Comment 3 George Billios 2007-05-06 06:29:32 UTC
Created attachment 154221 [details]
Dmesg after connecting the drive and mount attempt

Comment 4 George Billios 2007-05-06 06:30:13 UTC
Created attachment 154222 [details]
lshal output

Comment 5 David Zeuthen 2007-05-06 07:14:25 UTC
Looks like a dupe of bug 238385 - can you try updating udev? Thanks.

Comment 6 George Billios 2007-05-06 07:59:13 UTC
There is no update after the one I have udev-106-3.fc7 so I'll wait until the
next release and report back,

thanks for your info. 

Comment 7 David Zeuthen 2007-05-06 14:25:04 UTC
Well, I'm pretty sure that's why... so closing this bug as a dupe.

Btw, bug 238385 comment 2 shows a work around until packages for udev-106-4.fc7
or newer are moved over.


*** This bug has been marked as a duplicate of 238385 ***


Note You need to log in before you can comment on or make changes to this bug.