Bug 239842 - /lib/lsb/init-functions shall use aliases but not functions
Summary: /lib/lsb/init-functions shall use aliases but not functions
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Lawrence Lim
QA Contact:
URL:
Whiteboard:
Keywords:
: 247290 432548 (view as bug list)
Depends On:
Blocks: 239684
TreeView+ depends on / blocked
 
Reported: 2007-05-11 17:35 UTC by Enrico Scholz
Modified: 2014-03-26 00:55 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 07:09:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2007-05-11 17:35:48 UTC
Description of problem:

/lib/lsb/init-functions in FC7 uses functions to implement the 'pidofproc'
functions. This breaks common use cases like

| pids=$(pidofproc foo)

Such constructs work fine in FC6.


Version-Release number of selected component (if applicable):

redhat-lsb-3.1-13


How reproducible:

100%


Steps to Reproduce:
1. . /lib/lsb/init-functions
2. echo $(pidofproc bash)

  
Actual results:

FC7 fails with 'bash: pidofproc: command not found'


Expected results:

FC6 gives out list of bash-processes

Comment 1 Eric Harney 2007-05-21 14:54:08 UTC
I think the real problem here is that somebody typo'd the pidofproc function and
renamed it "pidofprof" in /lib/lsb/init-functions.

Comment 2 Enrico Scholz 2007-07-07 08:37:11 UTC
*** Bug 247290 has been marked as a duplicate of this bug. ***

Comment 3 Max Spevack 2007-07-09 19:39:24 UTC
It should be a trivial fix then, right?

Comment 4 Lawrence Lim 2007-07-18 07:09:37 UTC
Waiting for ACL to be updated so that the patch can be committed.

Comment 5 Lawrence Lim 2007-07-20 02:10:22 UTC
should be fix in redhat-lsb-3_1-15_f8. 

Comment 6 A S Alam 2007-12-17 07:09:34 UTC
it Fixed in following version:
--
redhat-lsb-3_1-19.fc8

Comment 7 Enrico Scholz 2008-02-12 20:07:41 UTC
*** Bug 432548 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.