Bug 241964 - yum-3.2.0-1.fc7 traceback
yum-3.2.0-1.fc7 traceback
Status: CLOSED DUPLICATE of bug 241604
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-31 19:07 EDT by Milan Kerslager
Modified: 2014-01-21 17:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-03 03:06:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milan Kerslager 2007-05-31 19:07:40 EDT
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 172, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 302, in doTransaction
    problems = self.downloadPkgs(downloadpkgs)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 798, in downloadPkgs
    remote_pkgs.sort(mediasort)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 747, in mediasort
    a = a.getDiscNum()
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 485, in getDiscNum
    return int(fragid)
ValueError: invalid literal for int() with base 10: ''
Comment 1 STEPHAN Gael 2007-06-01 10:27:21 EDT
Same behaviour here. I could reproduce it:

[root@ruatha ~]# yum clean all 
Loading "installonlyn" plugin
Cleaning up Everything
[root@ruatha ~]# yum install amarok
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
fedora                    100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 948 kB    00:00     
livna                     100% |=========================| 1.1 kB    00:00     
primary.xml.gz            100% |=========================|  68 kB    00:00     
livna     : ################################################## 212/212
updates                   100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================| 8.5 kB    00:00     
updates   : ################################################## 25/25
livna-testing             100% |=========================|  951 B    00:00     
primary.xml.gz            100% |=========================|  157 B    00:00     
Resolving Dependencies
--> Running transaction check
---> Package amarok.i386 0:1.4.5-4.fc7 set to be updated
--> Processing Dependency: libkonqsidebarplugin.so.1 for package: amarok
--> Processing Dependency: libkutils.so.1 for package: amarok
--> Processing Dependency: libknewstuff.so.1 for package: amarok
--> Processing Dependency: ruby for package: amarok
--> Processing Dependency: libnjb.so.5 for package: amarok
--> Processing Dependency: libifp.so.4 for package: amarok
--> Processing Dependency: libruby.so.1.8 for package: amarok
--> Processing Dependency: libkdeprint.so.4 for package: amarok
--> Processing Dependency: libDCOP.so.4 for package: amarok
--> Processing Dependency: libkhtml.so.4 for package: amarok
--> Processing Dependency: libkparts.so.2 for package: amarok
--> Processing Dependency: libtunepimp.so.5 for package: amarok
--> Processing Dependency: libmtp.so.5 for package: amarok
--> Processing Dependency: libkdefx.so.4 for package: amarok
--> Processing Dependency: libkio.so.4 for package: amarok
--> Processing Dependency: libkdeui.so.4 for package: amarok
--> Processing Dependency: libpq.so.5 for package: amarok
--> Processing Dependency: libkdesu.so.4 for package: amarok
--> Processing Dependency: libkdnssd.so.1 for package: amarok
--> Processing Dependency: libxine.so.1 for package: amarok
--> Processing Dependency: libkdecore.so.4 for package: amarok
--> Processing Dependency: libkwalletclient.so.1 for package: amarok
--> Processing Dependency: libkjs.so.1 for package: amarok
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package xine-lib.i386 0:1.1.6-2.fc7 set to be updated
---> Package libmtp.i386 0:0.1.5-1.fc7 set to be updated
---> Package kdebase.i386 6:3.5.6-12.fc7 set to be updated
---> Package libnjb.i386 0:2.2.5-3.fc6 set to be updated
---> Package ruby-libs.i386 0:1.8.6-2.fc7 set to be updated
---> Package kdnssd-avahi.i386 0:0.1.3-0.1.20060713svn.fc6 set to be updated
---> Package kdelibs.i386 6:3.5.6-9.fc7 set to be updated
---> Package ruby.i386 0:1.8.6-2.fc7 set to be updated
---> Package libifp.i386 0:1.0.0.2-4.fc6 set to be updated
---> Package postgresql-libs.i386 0:8.2.3-2.fc7 set to be updated
---> Package libtunepimp.i386 0:0.5.3-3.fc7 set to be updated
--> Processing Dependency: redhat-artwork-kde >= 7.0.0-8 for package: kdebase
--> Processing Dependency: libsensors.so.3 for package: kdebase
--> Processing Dependency: libHalf.so.4 for package: kdelibs
--> Processing Dependency: kde-settings-kdm for package: kdebase
--> Processing Dependency: libjasper.so.1 for package: kdelibs
--> Processing Dependency: libmodplug.so.0 for package: xine-lib
--> Processing Dependency: libIlmImf.so.4 for package: kdebase
--> Processing Dependency: libofa.so.0 for package: libtunepimp
--> Processing Dependency: libsoundserver_idl.so.1 for package: kdelibs
--> Processing Dependency: kde-settings >= 3.5 for package: kdelibs
--> Processing Dependency: libmcop.so.1 for package: kdebase
--> Processing Dependency: htdig for package: kdebase
--> Processing Dependency: libqtmcop.so.1 for package: kdelibs
--> Processing Dependency: libmpcdec.so.3 for package: libtunepimp
--> Processing Dependency: libkmedia2_idl.so.1 for package: kdelibs
--> Processing Dependency: libartsflow.so.1 for package: kdelibs
--> Processing Dependency: libmpcdec.so.3 for package: xine-lib
--> Processing Dependency: libIlmImf.so.4 for package: kdelibs
--> Processing Dependency: kde-settings for package: kdebase
--> Processing Dependency: libmcop.so.1 for package: kdelibs
--> Processing Dependency: libavahi-qt3.so.1 for package: kdnssd-avahi
--> Processing Dependency: arts >= 8:1.5.6 for package: kdelibs
--> Processing Dependency: libsoundserver_idl.so.1 for package: kdebase
--> Processing Dependency: libartsflow_idl.so.1 for package: kdelibs
--> Processing Dependency: libwavpack.so.1 for package: xine-lib
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package htdig.i386 3:3.2.0b6-11.fc7 set to be updated
---> Package wavpack.i386 0:4.41-1.fc7 set to be updated
---> Package kde-settings-kdm.noarch 0:3.5-28.fc7.1 set to be updated
---> Package lm_sensors.i386 0:2.10.3-2.fc7 set to be updated
---> Package redhat-artwork-kde.i386 0:7.0.0-9.fc7 set to be updated
---> Package libmodplug.i386 1:0.8.4-1.fc7 set to be updated
---> Package jasper.i386 0:1.900.1-2.fc7 set to be updated
---> Package libmpcdec.i386 0:1.2.2-4.fc6 set to be updated
---> Package libofa.i386 0:0.9.3-8.fc6 set to be updated
---> Package arts.i386 8:1.5.6-4.fc7 set to be updated
---> Package OpenEXR.i386 0:1.4.0a-3.fc6 set to be updated
---> Package avahi-qt3.i386 0:0.6.17-1.fc7 set to be updated
---> Package kde-settings.noarch 0:3.5-28.fc7.1 set to be updated
--> Processing Dependency: libfftw3.so.3 for package: libofa
--> Processing Dependency: libfltk_gl.so.1.1 for package: OpenEXR
--> Processing Dependency: libglut.so.3 for package: jasper
--> Processing Dependency: libfltk.so.1.1 for package: OpenEXR
--> Processing Dependency: libaudio.so.2 for package: arts
--> Processing Dependency: libjack.so.0 for package: arts
--> Processing Dependency: xorg-x11-xdm for package: kde-settings-kdm
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package fltk.i386 0:1.1.8-0.3.r5750.fc7 set to be updated
---> Package nas.i386 0:1.9-1.fc7 set to be updated
---> Package freeglut.i386 0:2.4.0-11.fc7 set to be updated
---> Package xorg-x11-xdm.i386 1:1.1.3-1.fc7 set to be updated
---> Package fftw.i386 0:3.1.2-3.fc6 set to be updated
---> Package jack-audio-connection-kit.i386 0:0.102.20-4.fc7 set to be updated
--> Processing Dependency: libfreebob.so.0 for package: jack-audio-connection-kit
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package libfreebob.i386 0:1.0.3-1.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 amarok                  i386       1.4.5-4.fc7      fedora             18 M
Installing for dependencies:
 OpenEXR                 i386       1.4.0a-3.fc6     fedora            416 k
 arts                    i386       8:1.5.6-4.fc7    fedora            1.1 M
 avahi-qt3               i386       0.6.17-1.fc7     fedora             17 k
 fftw                    i386       3.1.2-3.fc6      fedora            899 k
 fltk                    i386       1.1.8-0.3.r5750.fc7  fedora            424 k
 freeglut                i386       2.4.0-11.fc7     fedora            142 k
 htdig                   i386       3:3.2.0b6-11.fc7  fedora            1.0 M
 jack-audio-connection-kit  i386       0.102.20-4.fc7   fedora            137 k
 jasper                  i386       1.900.1-2.fc7    updates           174 k
 kde-settings            noarch     3.5-28.fc7.1     fedora             13 k
 kde-settings-kdm        noarch     3.5-28.fc7.1     fedora             16 k
 kdebase                 i386       6:3.5.6-12.fc7   fedora             28 M
 kdelibs                 i386       6:3.5.6-9.fc7    fedora             18 M
 kdnssd-avahi            i386       0.1.3-0.1.20060713svn.fc6  fedora          
  43 k
 libfreebob              i386       1.0.3-1.fc7      fedora            154 k
 libifp                  i386       1.0.0.2-4.fc6    fedora             50 k
 libmodplug              i386       1:0.8.4-1.fc7    fedora            170 k
 libmpcdec               i386       1.2.2-4.fc6      fedora             30 k
 libmtp                  i386       0.1.5-1.fc7      fedora             65 k
 libnjb                  i386       2.2.5-3.fc6      fedora             71 k
 libofa                  i386       0.9.3-8.fc6      fedora             63 k
 libtunepimp             i386       0.5.3-3.fc7      fedora            368 k
 lm_sensors              i386       2.10.3-2.fc7     fedora            512 k
 nas                     i386       1.9-1.fc7        fedora            647 k
 postgresql-libs         i386       8.2.3-2.fc7      fedora            195 k
 redhat-artwork-kde      i386       7.0.0-9.fc7      fedora            559 k
 ruby                    i386       1.8.6-2.fc7      fedora            518 k
 ruby-libs               i386       1.8.6-2.fc7      fedora            1.7 M
 wavpack                 i386       4.41-1.fc7       fedora            120 k
 xine-lib                i386       1.1.6-2.fc7      fedora            2.5 M
 xorg-x11-xdm            i386       1:1.1.3-1.fc7    fedora            131 k

Transaction Summary
=============================================================================
Install     32 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 76 M
Is this ok [y/N]: y
Downloading Packages:
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 172, in main
    base.doTransaction()
  File "/usr/share/yum-cli/cli.py", line 302, in doTransaction
    problems = self.downloadPkgs(downloadpkgs) 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 798, in downloadPkgs
    remote_pkgs.sort(mediasort)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 747, in mediasort
    a = a.getDiscNum()
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 485, in getDiscNum
    return int(fragid)
ValueError: invalid literal for int() with base 10: ''
Comment 2 Bert DeKnuydt 2007-06-01 10:35:35 EDT
Same here, but it went away when I removed a line 

   baseurl=file:/esat/linux/Fedora/$releasever/$basearch/

in the fedora repo.
Comment 3 STEPHAN Gael 2007-06-01 10:35:57 EDT
Interesting, i have this behaviour when i use my local mirror made with the dvd
only. It doesn't happen with "real" internet mirrors.
Comment 4 Wart 2007-06-01 12:07:19 EDT
(In reply to comment #3)
> Interesting, i have this behaviour when i use my local mirror made with the dvd
> only. It doesn't happen with "real" internet mirrors.

Same here.  When I point fedora.repo to my local mirror (which is a
loopback-mounted DVD image), this problem appears.  But it goes away once I
switch back to the internet mirrors.
Comment 5 Milan Kerslager 2007-06-01 13:15:36 EDT
I was using loopback mounted ISO too when hitting this bug. I was able to
workaround this by installing just one package at a time.

But as I learned yesterday, the DVD does not contain full package set (I missed
expect and compat-* packages). I have to mirror
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Everything/i386/os/
to have full-package-set local access.
Comment 6 Wart 2007-06-02 21:04:13 EDT
FWIW, the workaround described in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=212180#c6 works for me.  
That is, if you re-generate the repodata manually and point your yum config at
the regenerated repodata, then the error goes away.
Comment 7 Ignacio Vazquez-Abrams 2007-06-03 03:06:23 EDT

*** This bug has been marked as a duplicate of 241604 ***

Note You need to log in before you can comment on or make changes to this bug.