Bug 241975 - Get localized release notes into the tree, anaconda to display them
Get localized release notes into the tree, anaconda to display them
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pungi (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 242093 245557 (view as bug list)
Depends On:
Blocks: F9Target
  Show dependency treegraph
 
Reported: 2007-05-31 21:34 EDT by Dimitris Glezos
Modified: 2013-01-09 20:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-12 17:19:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dimitris Glezos 2007-05-31 21:34:19 EDT
## Description of problem:

Users using anaconda in a language other than english are getting a (localized!)
message "The release notes are missing".

## How reproducible:

Run anaconda. Choose "Greek" as a language. Click on "Relase notes".

## Expected results:

Display greek release notes.

## Additional info:

At some point, we should include on the CD all release notes in a separate
directory, `docs/relnotes/`.
Comment 1 Chris Lumens 2007-06-01 10:46:37 EDT
Fixed anaconda so it falls back to English release notes if nothing else is
found.  Reassigning to pungi for getting the translated release notes into the
tree.  Jesse - please give us a shout if you rearrange the release notes
location so we can correct our assumptions.
Comment 2 Dimitris Glezos 2007-06-01 11:24:30 EDT
(Adding Paul Frields as CC.)

Chris, thanks for the fix. I should have seen this in test4. :/

If we create a docs/ dir, we can move in there the stylesheets and relnotes, and
have the README and README-BURNING-ISOs too. If so, we might need subdirs for
each language to avoid cluttering.
Comment 3 Chris Lumens 2007-06-01 13:11:39 EDT
*** Bug 242093 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2007-06-06 13:47:45 EDT
This bug is now addressed by an updates image.  It is available for download at:

    http://people.redhat.com/clumens/f7-updates.img

Instructions for using updates disks are located at:

    http://fedoraproject.org/wiki/Anaconda/Updates

If possible, please test this image out and report if it fixes your issue or
not.  Once we are confident that your issue is solved by this image, we are
going to announce it more publicly.  This fix may also be included in an updated
anaconda package later for people who are making custom Fedora distributions. 
Thanks for your time.
Comment 5 Jesse Keating 2007-06-08 13:35:54 EDT
RFE for pungi changes has been filed
https://hosted.fedoraproject.org/projects/pungi/ticket/42
Comment 6 Jesse Keating 2007-06-25 10:21:25 EDT
*** Bug 245557 has been marked as a duplicate of this bug. ***
Comment 7 Jesse Keating 2007-12-02 23:01:52 EST
This is going to add 14megs~ to the iso size.  Also, I seem to recall some
thought about removing the installer's ability to read the release notes during
install.  Chris, am I crazy regarding that?
Comment 8 Jesse Keating 2007-12-12 17:19:10 EST
we're no longer displaying the release notes in the installer.  That makes this
bug moot.
Comment 9 Dimitris Glezos 2007-12-13 00:05:53 EST
If we're having the English ones in the ISO (even if anaconda doesn't display
them), we should probably have the localized ones too. 14 megs sound something
we could handle.
Comment 10 Alexander Todorov 2007-12-13 05:05:48 EST
Dimitris,
I think that release notes will go avay from the CD as well. Anaconda guys can
confirm if that's 100% sure.
Comment 11 Jesse Keating 2007-12-13 07:04:21 EST
Yes, all the release notes are going away on the iso (well except those that are
in the package included on the iso, but those have the translations too)

Note You need to log in before you can comment on or make changes to this bug.