Bug 242059 - Gnome Desktop is slow to load or does not load at all
Gnome Desktop is slow to load or does not load at all
Status: CLOSED DUPLICATE of bug 238680
Product: Fedora
Classification: Fedora
Component: esound (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Bastien Nocera
:
: 242055 242600 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 10:20 EDT by Jackie
Modified: 2007-11-30 17:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-06 12:41:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jackie 2007-06-01 10:20:07 EDT
Description of problem:
When I start a Gnome session, it is very slow to load the desktop. I have let 
it sit for 10 minutes at least and the toolbars still do not come up. I have 
just upgraded from FC6. I can start a KDE session with no problem. I am on a 
Dell Inspiron B130.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Log in using a Gnome session
2.
3.
  
Actual results:
Slow to bring up desktop enviroment

Expected results:


Additional info:
Comment 1 Jackie 2007-06-01 10:29:32 EDT
*** Bug 242055 has been marked as a duplicate of this bug. ***
Comment 2 Sean Bedford 2007-06-01 16:26:29 EDT
I can confirm that I have this problem as well - on my Asus G1 laptop with a
fresh install of Fedora 7. No extras from the default install have been added,
so it looks like it may be a problme somewhere else in the code.

This is reproducible almost all the time - on a rare occasion, I do actually
manage to get to the desktop, although gnome responds much too slowly once I get
there.
Comment 3 Jay Goodman 2007-06-01 19:53:47 EDT
Try switching to a console (CTL-ALT-F1), log in and 'killall esd'.  Switch back
(CTRL-ALT-F7) and see if gnome and its panels are loading at a normal rate.  

If so, goto System->Prefs->hardware->Sound and turn off esd for the time being.
 Post back if that was the problem and the folks will have a better
understanding of the issue (there might even be and upstream fix already in the
queue)
Comment 4 Sean Bedford 2007-06-01 20:09:32 EDT
I can confirm that killing and then stopping the esound server from running
appears to fix the problem.
Comment 5 David 2007-06-02 00:01:24 EDT
I also confirm this bug, it should be elevated to medium or high priority as you
cant easily start Fedora and log in.

However one temporary foolproof fix, go into your user sound settings and turn
off play system sounds.

This fixes the freeze / no menu issue.
Comment 6 Jay Goodman 2007-06-02 00:04:18 EDT
I have a simple work around that works on my laptop (NVIDIA MPC51)

There seem to be upstream in the the esound package that will eventually work
its way into a fedora update.  I'll post back if i can re-find the upstream bug
report



edit /etc/esd.conf
change
default_options=
to
default_options=-nobeeps -unix -as 2


Comment 7 Jay Goodman 2007-06-02 00:20:04 EDT
Upstream esound bug report

http://bugzilla.gnome.org/show_bug.cgi?id=431711
Comment 8 Sean Bedford 2007-06-02 06:30:58 EDT
I can also confirm that editing /etc/esd.conf as described above allows system
sounds to be turned back on without gnome-panel crashing
Comment 9 David 2007-06-02 06:59:47 EDT
Your a legend, indeed:

edit /etc/esd.conf
change
default_options=
to
default_options=-nobeeps -unix -as 2

WORKS I have now re-enabled system sounds!
Comment 10 Jackie 2007-06-02 11:40:26 EDT
All workarounds work for me as well.
Comment 11 Craig Bell 2007-06-02 16:44:47 EDT
I can also confirm that this solution also works for me
Comment 12 Richard S. Hendershot 2007-06-02 18:11:05 EDT
I can confirm the esd.conf change works for me as well.

Logout was broken also.  I had to use the ctrl-alt-bkspc to kill the X session
as logout would never complete (all accounts).  The above desktop issue only
arose for one user (my normal login, wouldn't you figure ;)

nice and spiffy now!
Comment 13 Scott Berry 2007-06-02 20:32:37 EDT
I have also found this to work correctly on a Dell Dimension 4800 running Fc7.
Comment 14 Richard S. Hendershot 2007-06-03 08:20:14 EDT
also x86_64

I noticed this bug is filed against i386.  Mine is x86_64 nvidia-based system
(ASUS M2N32-SLI Deluxe)
Comment 15 Richard Steck 2007-06-06 09:33:48 EDT
Same bug appeared here.  Scary at first until I found reference in 
fedoraforum.org. Temporarily fixed by patch suggested by Jay Goodman.
I hope this gets fixed in the next release.
Thank you.
Comment 16 Bastien Nocera 2007-06-06 10:05:43 EDT
(In reply to comment #6)
> I have a simple work around that works on my laptop (NVIDIA MPC51)
> 
> There seem to be upstream in the the esound package that will eventually work
> its way into a fedora update.  I'll post back if i can re-find the upstream bug
> report

We use the default esd.conf file from upstream, and that's already in the F7
package.

> edit /etc/esd.conf
> change
> default_options=
> to
> default_options=-nobeeps -unix -as 2

If that fixes it, then this bug is fixed...
Comment 17 Sean Bedford 2007-06-06 10:40:58 EDT
If that is what the file has been changed to upstream for inclusion in a future
fix, then that does indeed fix the problem - but those options definitely aren't
there in a default F7 install, so this fix should be a high priority due to the
nature in which it breaks Fedora's default desktop environment.
Comment 18 Bastien Nocera 2007-06-06 11:58:18 EDT
(In reply to comment #17)
> If that is what the file has been changed to upstream for inclusion in a future
> fix, then that does indeed fix the problem - but those options definitely aren't
> there in a default F7 install, so this fix should be a high priority due to the
> nature in which it breaks Fedora's default desktop environment.

esd.conf was always the one from upstream, and upstream doesn't use those
non-default options.

I'll make an update with the modified default_options.
Comment 19 Bastien Nocera 2007-06-06 12:13:14 EDT
*** Bug 242600 has been marked as a duplicate of this bug. ***
Comment 20 Bastien Nocera 2007-06-06 12:41:44 EDT
Actually, the options are passed from gnome-session as well, so there's already
"-nobeeps". "-unix" is the default in esd, so no need to add that one.

As for "-as 2", as we don't auto-spawn, this would mean that esd closes pretty
much as soon as started, and won't respawn again, which is obviously wrong.

*** This bug has been marked as a duplicate of 238680 ***

Note You need to log in before you can comment on or make changes to this bug.