Bug 242189 - Exception encountered - /dev/sda wanted to be initialized, though working fine for FC6
Exception encountered - /dev/sda wanted to be initialized, though working fin...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-01 22:32 EDT by Jim Cornette
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-04 14:15:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This is what anaconda wanted to reboot because of. (53.41 KB, text/plain)
2007-06-01 22:32 EDT, Jim Cornette
no flags Details
modprobe.conf - added suggested line to file (251 bytes, text/plain)
2007-06-02 02:36 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2007-06-01 22:32:16 EDT
Description of problem:
This is a problem similar to the problem that I encountered and earlier reported
a bug regarding. FC7 wants to initialize a disk which has XP and FC6
successfully installed on it. The problem was earlier re-assigned to parted as
the culpret.
The bug was pushed around awhile and some ideas were tried and I tested some
versions of parted on my working FC6 installation and still get this dump.
It is still here for me and probably will see more episodes since FC7 is now
released.

Version-Release number of selected component (if applicable):
Anaconda on the i386 DVD for FC7

How reproducible:
Start installer and do not allow anaconda to initialize the working disk. Get
error when continuing on with the installation.

Steps to Reproduce:
1. Start installer
2. Say no to initializing /dev/sda
3. Continue installation
4. Get exception
5. Save exception to floppy
6. Get prompt to reboot system.
  
Actual results:

FC7 thinks the geometry on /dev/sda is wrong. The detection of the disk is
correct for FC6 and XP and shows no errors.

Expected results:

FC7 to realize that the disk is alright and to continue without the exception.

Additional info:
Comment 1 Jim Cornette 2007-06-01 22:32:17 EDT
Created attachment 155960 [details]
This is what anaconda wanted to reboot because of.
Comment 2 Jim Cornette 2007-06-01 22:39:28 EDT
To clarify what each lvm is in dump file.

This is the / partition for FC6
22:10:00 INFO    : lv is hda5vol/LogVol00, size of 13056

This is the swap partition for FC6
22:10:00 INFO    : lv is hda5vol/LogVol01, size of 544

There should be no problem mounting the LVM for / (FC6)
22:10:00 DEBUG   : isys.py:mount()- going to mount /dev/hda5vol/LogVol00 on
/mnt/sysimage
Comment 3 David Timms 2007-06-02 01:03:37 EDT
Is this the same as: bug 241249 ?
referenced at:
http://fedoraproject.org/wiki/Bugs/F7Common#head-65f561a07fdf2889f310f3aac0ab0f984faf3e9c
Comment 5 Jim Cornette 2007-06-02 02:22:36 EDT
Thanks David for pointing out the reason for this error. I resorted to a yum
localupdate method to upgrade this system so I will post the excerpt into this
bug report for future reference. I saw this error spit out from a rawhide
installation for a long time now.

boot: linux libata.ignore_hpa=1 

Those upgrading from FC6 or earlier via yum on impacted systems can add a line
to modprobe.conf along these same lines to allow an F7 kernel to boot their
system. Ex:

 options libata ignore_hpa=1 
Comment 6 Jim Cornette 2007-06-02 02:36:18 EDT
Created attachment 155964 [details]
modprobe.conf - added suggested line to file

Since I am using yum because of the installer problem, I added the line so I
hopefully can boot the system after the upgrade.
Is this correct?
Comment 7 Jeremy Katz 2007-06-04 14:15:51 EDT
Yep, that's correct.  Unfortunately, given the kernel interface, there's no way
for us to really probe and do this automatically :(
Comment 8 Jim Cornette 2007-06-04 17:31:03 EDT
I ended up getting a kernel panic with the entry in modprobe.conf and ended up
removing the last partition while booted into development using fdisk. I then
recreated an extended partition and added two partitions, one for / and the
other for swap. I could then run the installer with success without getting an
exception. Now the disk does not show errors in either development or F7.
I could not confirm whether adding to modprobe.conf works or not. The disk no
longer needs the entry to work.

Note You need to log in before you can comment on or make changes to this bug.