Bug 242276 - Mock in Fedora 7 points to rawhide by default
Summary: Mock in Fedora 7 points to rawhide by default
Status: CLOSED ERRATA
Alias: None
Product: Fedora Hosted Projects
Classification: Retired
Component: mock (Show other bugs)
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Clark Williams
QA Contact:
URL:
Whiteboard:
Keywords:
: 239919 242880 242883 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-02 22:25 UTC by Julian Sikorski
Modified: 2013-01-10 04:19 UTC (History)
5 users (show)

Fixed In Version: 0.7.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-21 20:04:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
f7/i386 config (734 bytes, text/plain)
2007-06-02 22:56 UTC, Julian Sikorski
no flags Details
f7/ppc config (730 bytes, text/plain)
2007-06-02 22:57 UTC, Julian Sikorski
no flags Details
f7/x86_64 config (864 bytes, text/plain)
2007-06-02 22:57 UTC, Julian Sikorski
no flags Details

Description Julian Sikorski 2007-06-02 22:25:07 UTC
Description of problem:
Mock configs point to rawhide by default. What is more, they do not seem to be
updated for koji (local and groups (?) repo).

Version-Release number of selected component (if applicable):
0.6.12-1.fc7

How reproducible:
always

Steps to Reproduce:
1. install mock under f7
2. check the configs
  
Actual results:
config is not updated for the merge, no f7 config

Expected results:
files are pointing to correct places, fedora 7 config is present

Comment 1 Julian Sikorski 2007-06-02 22:56:43 UTC
Created attachment 156004 [details]
f7/i386 config

Comment 2 Julian Sikorski 2007-06-02 22:57:06 UTC
Created attachment 156005 [details]
f7/ppc config

Comment 3 Julian Sikorski 2007-06-02 22:57:35 UTC
Created attachment 156006 [details]
f7/x86_64 config

Comment 4 Julian Sikorski 2007-06-02 22:58:40 UTC
I have attached the files I wrapepd up here. They seem to work. They need to
have [local] repo url adjusted (to koji, I think). Cheers.

Comment 5 Julian Sikorski 2007-06-02 23:05:04 UTC
Ah, devel also needs to be fixed to reflect the merge, I presume.

Comment 6 Julian Sikorski 2007-06-03 00:44:47 UTC
*** Bug 239919 has been marked as a duplicate of this bug. ***

Comment 7 Mark McLoughlin 2007-06-05 10:55:55 UTC
Nicolas Mailhot suggests this:

  https://www.redhat.com/archives/fedora-devel-list/2007-June/msg00152.html

i.e. using "groupinstall build" rather than "install buildsys-build" and pulling
RPMs from koji


Comment 8 Jesse Keating 2007-06-12 20:06:52 UTC
*** Bug 242880 has been marked as a duplicate of this bug. ***

Comment 9 Jesse Keating 2007-06-12 20:07:44 UTC
*** Bug 242883 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2007-06-14 21:11:58 UTC
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Jesse Keating 2007-06-16 11:53:23 UTC
I can confirm that on Fedora 7 the default.cfg gets linked to the correct
fedora-7-<arch>.cfg file.

Comment 12 Fedora Update System 2007-06-21 20:03:45 UTC
mock-0.7.1-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Frank Büttner 2007-06-23 20:53:07 UTC
And it don't know nothing about EL4/EL5.

Comment 14 Jesse Keating 2007-06-24 14:19:47 UTC
There are fedora-4-epel configs in there.  I hate the naming but this is what
the EPEL folks wanted.


Note You need to log in before you can comment on or make changes to this bug.