Bug 243562 - KPowersave crashes on attempting to open the configuration dialog
KPowersave crashes on attempting to open the configuration dialog
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kpowersave (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
: 244035 250026 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 15:09 EDT by David Winslow
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version: 0.7.3-0.2svn20070828.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 12:47:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "$ strace kpowersave --nofork 2> strace-kpowersave-nofork-configure.txt" (675.13 KB, text/plain)
2007-06-11 11:37 EDT, MartinG
no flags Details
Output of "$ valgrind --leak-check=full --show-reachable=yes kpowersave --nofork 2> valgrind-kpowersave-nofork-configure.txt" (76.91 KB, application/x-gzip)
2007-06-11 11:49 EDT, MartinG
no flags Details

  None (edit)
Description David Winslow 2007-06-09 15:09:40 EDT
Description of problem:
When I attempt to open the configuration dialog for KPowersave, it promptly
crashes, bringing up the KDE crash handler.

Version-Release number of selected component (if applicable):
kpowersave-0.7.2-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Run kpowersave
2. Right click on the tray icon and choose "Configure KPowersave..."
  
Actual results:
KPowersave crashes.

Expected results:
A configuration dialog should be displayed.
Comment 1 MartinG 2007-06-11 08:03:05 EDT
Exact same problem here. I have a fresh install of Fedora 7 on a Dell Latitude 
X1, fully updated with yum (using only standard repos). I have only installed 
KDE and not Gnome.

kernel 2.6.21-1.3194.fc7

# rpm -qa kpowersave hal\* acpi\*
kpowersave-0.7.2-1.fc7
hal-cups-utils-0.6.9-1.fc7
hal-info-20070516-2.fc7
hal-libs-0.5.9-8.fc7
hal-0.5.9-8.fc7

I have no ACPI packages installed, but as I've understood, this stuff is now 
handled by HAL. As I cannot configure KPowerSave, I am not able to make my 
laptop go to sleep when I close the lid - I have to manually choose "suspend to 
RAM" (and that works just fine, even when using Beryl).

Also, if I try to change the cpu frequency to e.g. "powersave" I get the 
following error message: "CPU Freq policy powersave could not be set."

Could it be that some dependency is missing? Or some file permissions?
I disabled SELinux during install.
Comment 2 MartinG 2007-06-11 11:37:51 EDT
Created attachment 156726 [details]
Output of "$ strace kpowersave --nofork 2> strace-kpowersave-nofork-configure.txt"

I attached a strace of kpowersave crashing when choosing configure on the menu.
By the way, I am running i616:
Linux x1 2.6.21-1.3194.fc7 #1 SMP Wed May 23 22:35:01 EDT 2007 i686 i686 i386
GNU/Linux
Comment 3 MartinG 2007-06-11 11:49:48 EDT
Created attachment 156728 [details]
Output of "$ valgrind --leak-check=full --show-reachable=yes kpowersave --nofork 2> valgrind-kpowersave-nofork-configure.txt"
Comment 4 Antonio Bulgheroni 2007-06-11 18:01:24 EDT
I have a very similar problem on the same configuration. I cannot even start
kpowersave. All the functionalities of kpowersave are perfectly handled by klaptop.
Comment 5 Dennis Gilmore 2007-06-13 22:58:23 EDT
*** Bug 244035 has been marked as a duplicate of this bug. ***
Comment 6 Stian Moltubakk 2007-07-06 00:50:38 EDT
I have the same problem as Antonio that kpowersave crash once KDE starts, but 
only as user, If I'm root the kpowersave will run just fine and I can right 
click on it and everything without anny problem.
Comment 7 Stian Moltubakk 2007-07-06 05:11:12 EDT
I just noticed that kpowersave don't crash if I boot using initng, but it don't 
display information about annything.
Comment 8 Viet Yen Nguyen 2007-07-14 10:02:55 EDT
I have the exact same problems as Stian Moltubakk.
Comment 9 Viet Yen Nguyen 2007-07-14 10:09:05 EDT
I have the exact same problems as Stian Moltubakk.
Comment 10 Emmanuel Promayon 2007-07-25 10:33:26 EDT
Kpowersave's author and current maintainer David Kurawka fixed this issue in 
the SVN version (available on sourceforge)

For those who don't want to compile it and can't wait for the next version, he 
even gave a quick fix (only for Dell platforms if I am not mistaken):
- load the dcdbas kernel module 
- restart haldaemon and kpowersave
... and it works!

Thanks again David!
Comment 11 Dennis Gilmore 2007-07-29 15:48:45 EDT
*** Bug 250026 has been marked as a duplicate of this bug. ***
Comment 12 Steven 2007-08-14 02:17:49 EDT
The fix is CVS, not SVN.
Comment 13 Steven 2007-08-14 02:35:05 EDT
Sorry, SVN was down when I tried, it is on there. Also on CVS, although it
didn't work. Trying the SVN one now.
Comment 14 Fedora Update System 2007-08-29 13:26:57 EDT
kpowersave-0.7.3-0.2svn20070828.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2007-09-12 12:47:27 EDT
kpowersave-0.7.3-0.2svn20070828.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.