Bug 244330 - pm-utils-0.99.3-6.fc7.1 does not package vbetool and radeontool
Summary: pm-utils-0.99.3-6.fc7.1 does not package vbetool and radeontool
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pm-utils   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Till Maas
QA Contact:
URL:
Whiteboard:
Keywords:
: 246211 303831 (view as bug list)
Depends On: radeontool vbetool
Blocks: 237634
TreeView+ depends on / blocked
 
Reported: 2007-06-15 03:21 UTC by TC
Modified: 2007-11-30 22:12 UTC (History)
6 users (show)

Fixed In Version: 0.7-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 08:32:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description TC 2007-06-15 03:21:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.12) Gecko/20070530 Fedora/1.5.0.12-1.fc5 Firefox/1.5.0.12

Description of problem:
The pm-utils binary packages in updates-testing dated 06-Jun-2007 15:41 do not package vbetool and radeontool despite comments given in changelog. I had to rebuild from the src.rpm to create a correctly generated pm-utils package. 

Version-Release number of selected component (if applicable):
0.99.3-6.fc7.1

How reproducible:
Always


Steps to Reproduce:
1. rpm -qil pm-utils*rpm
2.
3.

Actual Results:
vbetool and radeontool not given in RPM manifest list

Expected Results:
vbetool and radeontool should be included in binary package.

Additional info:
This appears to be a packaging problem. Rebuilding the RPM from the src.rpm package includes the missing vbetool and radeontool binaries.

Comment 1 Jim Radford 2007-07-06 22:19:29 UTC
Why is this marked "low priority" when the fix is *trivial* and without vbetool
*many* laptops will not suspend (at *least* 166 different models by my count)?

Comment 2 Guillaume Chazarain 2007-07-31 12:14:45 UTC
Also, why do we provide RPMS for i486, i586, i686, athlon?
i386 should be enough and is the only one providing vbetool and radeontool.

Comment 3 Paul Osmialowski 2007-08-03 08:51:46 UTC
I've upgraded FC3 to F7 on my old Toshiba Portege laptop that acts as a network
gateway (no X so there's no xset command available). The only way to switch
backlight off is to use vbetool (I've tried to send commands through /proc tree
using echo to toshiba_acpi module, but there was no results). Fortunately,
ATrpms provides pm-utils for F7 with vbetool. Also I'm curious, how it was done
in FC3 that when no one touched keyboard/mouse for some time, backlight switched
off automatically (even if X nor xdm/gdm/kdm wasn't started)?


Comment 4 Till Maas 2007-08-31 09:09:18 UTC
*** Bug 246211 has been marked as a duplicate of this bug. ***

Comment 5 Till Maas 2007-08-31 15:43:44 UTC
vbetool and radeontool are going to be packaged on their own. I hope that they
will be reviewed shortly. In case it needs a lot of time there may be a rebuild
of pm-utils, so I expect to fix this bug soon.

Comment 6 Fedora Update System 2007-09-18 03:13:34 UTC
radeontool-1.5-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2007-09-18 03:13:38 UTC
vbetool-0.7-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2007-09-18 03:13:45 UTC
pm-utils-0.99.4-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2007-09-24 17:58:59 UTC
pm-utils-0.99.4-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Till Maas 2007-09-24 19:10:05 UTC
*** Bug 303831 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2007-09-25 08:32:38 UTC
vbetool-0.7-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2007-09-25 22:46:50 UTC
pm-utils-0.99.4-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.