Bug 245096 - system-config-authentication fails to update /etc/sysconfig/network for NIS domain
system-config-authentication fails to update /etc/sysconfig/network for NIS d...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: authconfig (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
: 245097 (view as bug list)
Depends On: 380551
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-20 22:15 EDT by Wesly Chen
Modified: 2008-06-18 02:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0375
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:29:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fixed authinfo.py (85.43 KB, text/plain)
2007-06-21 09:47 EDT, Tomas Mraz
no flags Details

  None (edit)
Description Wesly Chen 2007-06-20 22:15:27 EDT
Description of problem:
Config the NIS domain and server via "system-config-authentication", it updates 
the /etc/yp.conf file. But it does NOT put "NISDOMAIN=xxx" 
in /etc/sysconfig/network. So when I run "service ypbind start" or reboot the 
machine, ypbind doesn't run unless I type "domainname xxx".

Version-Release number of selected component (if applicable):
authconfig-gtk-5.3.12-2.el5.x86_64

How reproducible:


Steps to Reproduce:
1. run /usr/sbin/system-config-authentication
2. check "Enable NIS Support" and click on "Configure NIS..."
3. Fill in "NIS Domain" and "NIS Server"
4. Click "OK" and "OK"

Actual results:
ypbind start successfully. But /etc/sysconfig/network is not updated 
with "NISDOMAIN=xxx"

Expected results:
/etc/sysconfig/network need to be updated with "NISDOMAIN=xxx". Otherwise, the 
ypbind won't start after reboot due to NIS domain is not set.


Additional info:
Comment 1 Tomas Mraz 2007-06-21 08:53:55 EDT
*** Bug 245097 has been marked as a duplicate of this bug. ***
Comment 2 Tomas Mraz 2007-06-21 09:47:27 EDT
Created attachment 157534 [details]
Fixed authinfo.py

Can you please try to replace /usr/share/authinfo.py with this one and try to
set the nis domain again?
Comment 3 Wesly Chen 2007-06-21 23:26:40 EDT
Should it be 
/usr/share/authconfig/authinfo.py
?

It did update /etc/sysconfig/network.
Comment 4 Tomas Mraz 2007-06-22 05:23:31 EDT
(In reply to comment #3)
> Should it be 
> /usr/share/authconfig/authinfo.py
> ?
Yes, of course.

> It did update /etc/sysconfig/network.
Great.
Comment 5 RHEL Product and Program Management 2007-10-31 14:25:05 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 Petr Šplíchal 2008-01-31 05:30:40 EST
The problem only occurs when supplied domain name is the same as previous one
saved in yp.conf (which seems like there is no need to update, but
/etc/sysconfig/network has to be updated nevertheless).

How to test:
authconfig --enablenis --nisdomain redhat.com --nisserver 172.16.76.10 --update
remove NISDOMAIN line from /etc/sysconfig/network
authconfig --enablenis --nisdomain redhat.com --nisserver 172.16.76.10 --update
NISDOMAIN=redhat.com should be present in /etc/sysconfig/network
Comment 12 errata-xmlrpc 2008-05-21 10:29:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0375.html
Comment 13 Chris Ward 2008-06-17 11:48:41 EDT
Reminder: This bug includes the 'RHTS' QA Whiteboard Keyword. Don't forget to add
'RHTSdone' to the QA Whiteboard along with a comment describing where the RHTS
test can be found once the RHTS test has been written. Otherwise, if an RHTS
will not be created, please remove RHTS from the qa whiteboard.

Note You need to log in before you can comment on or make changes to this bug.