Bug 245289 - Frequent hang (or freeze) while reading mail and marking spam
Frequent hang (or freeze) while reading mail and marking spam
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 245786 245937 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-06-22 02:07 EDT by David Nielsen
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.10.2-3.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 12:26:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace of random hang (4.71 KB, text/plain)
2007-06-22 02:07 EDT, David Nielsen
no flags Details
backtrace of junkfiltering scenerio (4.90 KB, text/plain)
2007-06-22 02:07 EDT, David Nielsen
no flags Details
terminal output (17.72 KB, text/plain)
2007-06-27 02:15 EDT, David Nielsen
no flags Details
backtrace (4.83 KB, text/plain)
2007-06-27 02:16 EDT, David Nielsen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 362638 None None None Never

  None (edit)
Description David Nielsen 2007-06-22 02:07:01 EDT
Description of problem:
I'm seeing quite frequent hangs in Evolution, bug-buddy does not get triggered
but running in gdb I was able to catch a glimpse of the action. Normally this
will happen at random just reading mail but I found a way to provoke it by
marking a specific mail as spam. I'm attaching both backtraces.

I don't know what specifically triggers this when reading mail but marking this
one spam mail seems to do the trick every time.

Version-Release number of selected component (if applicable):
evolution-2.11.4-1.fc8
evolution-data-server-1.11.4-1.fc8
bogofilter-1.1.5-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. Start reading mail, eventually it will hang
  
Actual results:
Evolution hangs but bug-buddy is not launched

Expected results:
I know it's Evolution and thus one shouldn't get ones hopes up, but if it would
at least let me read my mail it would be nice.

Additional info:
Comment 1 David Nielsen 2007-06-22 02:07:01 EDT
Created attachment 157598 [details]
Backtrace of random hang
Comment 2 David Nielsen 2007-06-22 02:07:54 EDT
Created attachment 157599 [details]
backtrace of junkfiltering scenerio
Comment 3 David Nielsen 2007-06-22 02:09:22 EDT
CC'ing wwoods@redhat.com, Will you mentioned at the last QA meeting that
Evolution was hanging for you as well.
Comment 4 Matthew Barnes 2007-06-27 00:08:11 EDT
The backtrace shows an invalid free() in Thread 1.  I vaguely recall this or
something like it being fixed in the latest release.

Can you please try upgrading to evolution-2.11.4-1.fc8 and see if you still
experience the hang?  If you still see the hangs can you try running Evolution
from a terminal and post any messages that get printed?

(Thanks for installing the debuginfo packages, by the way.)
Comment 5 David Nielsen 2007-06-27 02:14:34 EDT
Evolution-2.11.4-1.fc8 is also displaying an uncanny ability to hang every few
minutes.

I'm attaching the direct output from running 2.11.4-1.fc8 in gdb and the
backtrace I managed to capture. The problem is now so bad you just have to start
Evolution then sit back and wait for it to take a nose dive, normally does not
take more than 30-45 secs.

And might I add debuginfo-install from the yum-utils package.. most handy
package when using Evolution ever.
Comment 6 David Nielsen 2007-06-27 02:15:44 EDT
Created attachment 157981 [details]
terminal output

obsoleting old backtraces
Comment 7 David Nielsen 2007-06-27 02:16:17 EDT
Created attachment 157982 [details]
backtrace
Comment 8 Matthew Barnes 2007-06-27 10:49:57 EDT
*** Bug 245937 has been marked as a duplicate of this bug. ***
Comment 9 Matěj Cepl 2007-06-27 10:53:34 EDT
change of summary to make it more discoverable
Comment 10 Matthew Barnes 2007-06-27 12:44:23 EDT
I think I have a fix for the problem.  Memory was being allocated and
deallocated by two different memory management schemes (GLib's slab allocator
versus glibc).

This issue seems to be affecting Fedora 7 users as well.  Could someone please
confirm that the problem is fixed in Rawhide before I push it to Fedora 7?

Please try evolution-2.11.4-2.fc8.
Comment 11 David Nielsen 2007-06-27 14:10:54 EDT
I never thought I would say this about Evolution... but it seems stable. It's
been sitting there letting me read my mail for at least 20 mins with repeated
hits to my mail server.. ample abuse and no crash. I definitely owe you beer
Matthew.
Comment 12 Matthew Barnes 2007-06-27 15:09:01 EDT
Thanks for the confirmation.  Given the severity of the problem I'll go ahead
and push the fix to Fedora 7 and just neglect to mention that it was caused by
one of my own patches.  *smiles sheepishly*

Also fixed in evolution-2.10.2-3.fc7.
Comment 13 Fedora Update System 2007-06-27 21:47:43 EDT
evolution-2.10.2-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2007-07-03 12:26:17 EDT
evolution-2.10.2-3.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Ben Konrath 2007-07-03 12:37:36 EDT
*** Bug 245786 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.