Bug 24738 - logout button not really default
Summary: logout button not really default
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core   
(Show other bugs)
Version: 7.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 15400 21315 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-23 20:49 UTC by Robert M. Riches Jr.
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 20:33:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert M. Riches Jr. 2001-01-23 20:49:23 UTC
When a user logs out from gnome, a dialog box is presented with three
buttons at the bottom: yes, no, help (or similar).  The yes button appears
to be the default.  However, hitting <RETURN> on the keyboard brings
up the help browser instead of completing the logout process.

Comment 1 Owen Taylor 2001-01-24 00:20:11 UTC
There are actually two bugs here

 1) The default is displayed in the wrong place (should be on the
    Help button)

 2) The help button has focus

There is a patch for 1) in GTK+ CVS and that fix will be in GTK+-1.2.9,
There is a patch for 2) in gnome-core CVS (though for HEAD, not the 
gnome-core-1-2 stable branch). 

So, all we need to do is get the two patches into our packages one way
or the other.

Comment 2 Elliot Lee 2001-02-02 01:14:31 UTC
*** Bug 21315 has been marked as a duplicate of this bug. ***

Comment 3 Elliot Lee 2001-02-09 19:35:50 UTC
*** Bug 15400 has been marked as a duplicate of this bug. ***

Comment 4 Phil Copeland 2001-06-04 18:22:28 UTC
Owen, any resolution on this?

Phil
=--=

Comment 5 Kjartan Maraas 2004-03-29 20:33:12 UTC
Closing as this is way old by now.


Note You need to log in before you can comment on or make changes to this bug.