Bug 247716 - SAMBA start script doesn't start nmbd daemon
Summary: SAMBA start script doesn't start nmbd daemon
Status: CLOSED DUPLICATE of bug 244984
Alias: None
Product: Fedora
Classification: Fedora
Component: samba   
(Show other bugs)
Version: 7
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Simo Sorce
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 247714 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-10 22:36 UTC by Joshua Rosen
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-10 23:38:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Rosen 2007-07-10 22:36:07 UTC
Description of problem:

The F7 /etc/init.d/smb script doesn't start the nmbd daemon. As a result the
SAMBA shares aren't visible to Windows. The fix is to replace the F7 smb script
with the FC6 version.

Version-Release number of selected component (if applicable):


How reproducible: 100%

Here is the start() script in F7

start() {
        KIND="SMB"
	echo -n $"Starting $KIND services: "
	daemon smbd $SMBDOPTIONS
	RETVAL=$?
	echo
	[ $RETVAL -eq 0 ] && touch /var/lock/subsys/smb || \
	   RETVAL=1
	return $RETVAL
}

Here is the script from FC6

start() {
        KIND="SMB"
	echo -n $"Starting $KIND services: "
	daemon smbd $SMBDOPTIONS
	RETVAL=$?
	echo
        KIND="NMB"
	echo -n $"Starting $KIND services: "
	daemon nmbd $NMBDOPTIONS
	RETVAL2=$?
	echo
	[ $RETVAL -eq 0 -a $RETVAL2 -eq 0 ] && touch /var/lock/subsys/smb || \
	   RETVAL=1
	return $RETVAL
}




Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Joshua Rosen 2007-07-10 23:12:20 UTC
*** Bug 247714 has been marked as a duplicate of this bug. ***

Comment 2 Simo Sorce 2007-07-10 23:38:24 UTC

*** This bug has been marked as a duplicate of 244984 ***


Note You need to log in before you can comment on or make changes to this bug.