Bug 24887 - RFE: Add support for i810 + 2nd video card (surely a dupe)
RFE: Add support for i810 + 2nd video card (surely a dupe)
Status: CLOSED DUPLICATE of bug 16123
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 17:22 EST by Jeremy Katz
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 12:35:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2001-01-24 17:22:42 EST
This is with 20010124 rawhide and a Dell Optiplex GX110 with onboard i810
with an add-in nvidia pci card.  Boot with bootnet and don't get
framebuffer console.  Select NFS install.  Following happens as anaconda
crashes out (typed by hand, so ignore my typos :)

Provdes X server is XFree86
Card:RIVA TNT2
We can use framebuffer
fb_check returned with value Card: RIVA TNT2
We can use framebuffer
0
Using Xserver /usr/X11R6/bin/XF86_FBDev
Can't open /dev/fb0
Waiting for X server to start... X server started successfully.
Gdk-ERROR **: Fatal IO error (Connection reset by peer) on X server :1.
install exited abnormally

and unmounts fs and allows me to reboot from there.  Should at least fall
back gracefully to text mode if XF86_FBDev fails to start
Comment 1 Glen Foster 2001-01-24 19:40:04 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 2 Brent Fox 2001-01-26 17:01:16 EST
This is strange because it is supposed to fall back to text mode.  Actually,
anaconda detects if you are in framebuffer mode and if not, then it starts a
native X server such as SVGA.  If that fails, only then does it fall back to
text mode. I have a Dell OptiPlex GX110 test machine here that works correctly,
but I am using the onboard (i810) video card.  Can you try removing the extra
video card and see what happens then?  We've had problems in the past detecting
the secondary video card on i810 systems in the past.
Comment 3 Jeremy Katz 2001-01-26 17:11:30 EST
Removal of the add-in card does have the frame buffer server start properly, so
it is related to the second video card.  Unfortunately saying to remove teh
second video card is probably not the best thing to tell to "normal users" :)

Comment 4 Brent Fox 2001-01-26 17:24:44 EST
I agree totally.  What surprises me is that your i810 card can start framebuffer
at all.  Mine can't.  Are you sure it didn't fall back to the native X server
instead?  Go to VC2 and type 'cat /dev/fb0'  If a bunch of text scrolls across
the screen you're in framebuffer mode.  If nothing happens, it must have started
the native X server.  

On my test machine, I've added a second video card, but I can't get a signal
from it.  Did you set anything in your bios to send the video signal to the
second card?
Comment 5 Jeremy Katz 2001-01-26 17:42:02 EST
Sorry, openafs + 2.4 is screwing with my head and I just can't read today... it
just starts the SVGA server.  As to enabling a secondary video card, check in
the BIOS -> Integrated Devices -> Primary Video Controller -> Auto.  I think
that should be all you need, though this is how it was shipped by Dell so I
never changed it.
Comment 6 Brent Fox 2001-01-26 18:07:23 EST
Strange.  I've tried two different video cards and I've set the bios just like
you described and no luck.  I can't get any signal at all through the secondary
card.  The only options are Auto and Onboard, so I assumed Auto is what it
needed to be, but that doesn't work.  It's hard for me to fix the problem if I
don't have a working test case.
What pci slot are you putting the video card in?  I know this probably shouldn't
make a difference, but I'm out of other ideas.
Comment 7 Jeremy Katz 2001-01-26 18:27:16 EST
Slot on the far left as you look at the back of the box.  If you can't get the
add-on card to work, I'll take a deeper look into the problem this weekend /
beginning of net week since I do have an easily reproducible test case
Comment 8 Brent Fox 2001-01-26 18:43:13 EST
Well, I looked around on the Dell site and found about 1000 people on their
message boards with the same problem that I'm having.  Turns out there is a bios
update to fix this problem.  You must have a newer bios than me.  Anyway, the
bios downloads are all in .exe format, even if you pick Red Hat Linux as your
operating system.  I don't have any windows machines around, so I can't fix this
problem until I can get to my machine at home with vmWare.  Arrg.  I'll do that
over the weekend.
Comment 9 Brent Fox 2001-01-31 17:06:06 EST
Ok, I tried updating the bios of my machine and it doesn't fix the problem.  I'm
inclined to think that problems are related to the bios.  Please try with beta 3
(Fisher).
Comment 10 Jeremy Katz 2001-02-02 15:29:38 EST
Still happens with beta3 but I've got a much better handle on what's actually
going on now (and why it didn't happen in 7.0)

Stage 2 loads and checks the framebuffer.  Obviously, no framebuffer so this
fails.  Note that fb_check() shows that the card in the machine is the TNT2
because fb_check() always takes the last card returned from the kudzu probe.
Then, when the Xconfiguration is created, it instead uses the first card and so
sets up the test XF86Config for the i810.  X tries to start and fails due to the
error in the XF86Config, and it fails after the gui tries to start, so then
starting the gui fails and we die.  The quick fix to at least stop anaconda from
falling over and to get it to fallback to text mode is to add a short sleep
after starting the X server (around line 308 of anaconda/anaconda).

As to why it didn't happen in 7.0, in 7.0, XF86_SVGA was used as the X server
instead of XFree86 and so it didn't care what the card was since it was the same
driver either way.

The real solution is fixing up the handling of multiple video cards, but that's
probably not going to happen for this release :)   Also, for some
cross-referencing, this is related to bug 24468 (and the ones it's related to)
Comment 11 Brent Fox 2001-02-08 22:35:09 EST
I think there are some inherent problems with having two or more video cards in
your machine.  We don't currently support this.  Xconfigurator and kudzu need
more intelligent probing routines in order to handle this.  Deferring to a
future release.
Comment 12 Jeremy Katz 2001-02-08 22:39:01 EST
Heh, luckily it seems that the changes for disabled pci devices appears to have
fixed the problems from the little bit of testing I did earlier today but just
hadn't gotten around to dropping in bugzilla yet.  The issue of multiple video
cards does need looking at for a future release though since it's getting to be
an extremely common setup.
Comment 13 Michael Fulbright 2001-09-18 12:35:44 EDT

*** This bug has been marked as a duplicate of 16123 ***

Note You need to log in before you can comment on or make changes to this bug.