Bug 24468 - video probe inconsistencies between GUI and TUI install
video probe inconsistencies between GUI and TUI install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-20 17:55 EST by Jeremy Katz
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 17:15:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Katz 2001-01-20 17:55:09 EST
There seems to be inconsistencies in which video card is selected between
the GUI and TUI installs of anaconda on machines with an on-board video and
an add-on PCI card.  Some machines, the GUI install method finds the
"right" card and others, the TUI install method (hence Xconfigurator) finds
the "right" card.

eg: with a Dell Optiplex GX110 with built-in i810 video on the motherboard
and a PCI TNT2, anaconda's probe finds the i810 and hence can't start the
GUI installer; the early probe finds the i810.  Later, when you actually
configure X in text-mode, the TNT2 is detected instead and X is set up
properly.  This means that kickstarts will find the proper video card on
this box, but it won't run a GUI install.  lspci for this box (hardware
profile 29) is:

00:00.0 Host bridge: Intel Corporation 82810E GMCH [Graphics Memory
Controller Hub] (rev 03)
00:01.0 VGA compatible controller: Intel Corporation 82810E CGC [Chipset
Graphics Controller] (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corporation 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corporation 82801AA USB (rev 02)
00:1f.3 SMBus: Intel Corporation 82801AA SMBus (rev 02)
01:07.0 VGA compatible controller: nVidia Corporation Vanta [NV6] (rev 15)
01:08.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)
01:0c.0 Ethernet controller: 3Com Corporation 3c905C-TX [Fast Etherlink]
(rev 78)


Counterpoint is an older Dell GXa with an onboard ATI Rage Pro and Matrox
G200 PCI.  With this machine, anaconda probes the Matrox and starts
XF86_SVGA.  GUI installer properly detects the right video card
consistently.  TUI installer on the other hand (hence, Xconfigurator +
kickstart) always detect the Rage Pro and try to use it.  lspci for this
box (should be machine profile 30) is:
00:00.0 Host bridge: Intel Corporation 440LX/EX - 82443LX/EX Host bridge
(rev 03)
00:01.0 PCI bridge: Intel Corporation 440LX/EX - 82443LX/EX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 01)
00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 01)
00:0e.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W
[Millennium II]
00:11.0 Ethernet controller: 3Com Corporation 3c905 100BaseTX [Boomerang]
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X
(rev 5c)


Looks like the PCI bus is scanned in a different order for the two of them.
 To be honest, I think that the Xconfigurator way is "better" if only
because I've got about 200 of the GX110s which get installed via kickstart
and the GXa only serves as a test box :)  But whichever way, I think that
the two should at least go the same way.  And although I'd love to have my
mind read and the correct one always picked, I do understand the difficulty
in that proposition.
Comment 1 Michael Fulbright 2001-01-26 11:34:10 EST
Assigned to a developer.
Comment 2 Michael Fulbright 2001-01-26 11:35:01 EST
Related to bug 16123 and bug 15320.
Comment 3 Jeremy Katz 2001-02-02 15:30:34 EST
Also related to bug 24887
Comment 4 Brent Fox 2001-02-08 22:33:33 EST
This would be nice to fix, but we don't support having more than one video card
in one machine at this time.  Deferring to a future release.  Xconfigurator and
kudzu need more intelligence in order to do this.
Comment 5 Jeremy Katz 2001-09-10 17:15:22 EDT
The inconsistencies are fixed now since they use the same code... the multiple
video cards is scattered throughout other deferred bugs.  Closing as currentrelease

Note You need to log in before you can comment on or make changes to this bug.