Bug 249120 - fds104 jre15sun empty subtree pw policy window
fds104 jre15sun empty subtree pw policy window
Product: 389
Classification: Community
Component: UI - Configuration (Show other bugs)
All Linux
high Severity high
: ---
: ---
Assigned To: Rich Megginson
Chandrasekar Kannan
: 249320 415011 492092 (view as bug list)
Depends On:
Blocks: 249650 FDS1.2.0
  Show dependency treegraph
Reported: 2007-07-20 20:14 EDT by Marc Sauton
Modified: 2015-01-04 18:27 EST (History)
6 users (show)

See Also:
Fixed In Version: 8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-29 19:00:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
empty pw policy sub tree window (9.64 KB, image/jpeg)
2007-07-20 20:14 EDT, Marc Sauton
no flags Details
diffs (1.11 KB, patch)
2008-12-11 17:23 EST, Rich Megginson
no flags Details | Diff
pwp dialog startup (50.69 KB, image/jpeg)
2008-12-11 17:28 EST, Rich Megginson
no flags Details
pwp dialog too small (30.57 KB, image/jpeg)
2008-12-11 17:28 EST, Rich Megginson
no flags Details
cvs commit log (233 bytes, text/plain)
2008-12-11 17:59 EST, Rich Megginson
no flags Details

  None (edit)
Description Marc Sauton 2007-07-20 20:14:54 EDT
Description of problem:
fds104 jre15sun empty subtree pw policy window

Version-Release number of selected component (if applicable):

Fedora Core release 6 (Zod)
        Fedora-Directory/1.0.4 B2006.312.1539

java version "1.5.0_12"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_12-b04)
Java HotSpot(TM) Client VM (build 1.5.0_12-b04, mixed mode, sharing)

How reproducible:

always in my environment.

Steps to Reproduce:
1. install fc6, jre150-12 from sun, fds104
2. create fds instance, start, start admin, start console
3. console | Directory | dc=... | right click | Password policy

Actual results:
The popup window for the password policy is empty, with little tiny scroll bars

Expected results:
A usable window, like in rhds71sp3

Additional info:
see attached screen copy
Comment 1 Marc Sauton 2007-07-20 20:14:55 EDT
Created attachment 159713 [details]
empty pw policy sub tree window
Comment 5 Rich Megginson 2008-07-14 20:20:46 EDT
Is this a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=249320 ?
Comment 6 Marc Sauton 2008-07-14 20:43:35 EDT
looks likes it is...
Comment 7 Rich Megginson 2008-07-15 10:22:13 EDT
*** Bug 249320 has been marked as a duplicate of this bug. ***
Comment 8 jsullivan 2008-11-10 13:48:27 EST
I'm having the same problem.  It happens every time on both Fedora 9 and Centos 5.  I am using Console Framework 1.1.1.  Both installations use OpenJDK Client VM (build 1.6.0-b09, mixed mode).

Both installations are vserver guests.  The vserver host is Centos 5.  It is i386 architecture.  I am running the console on my amd64 laptop running Ubuntu 8.0.4 via X forwarding on ssh.

If it would help the developers, I could probably arrange for remote access to my laptop for diagnostics and troubleshooting.
Comment 9 jsullivan 2008-11-10 13:50:41 EST
I should also mention I have tried grabbing the edges of the widget in the middle of the blank frame in case it could be resized.  That did not help.  I tried resizing and maximizing the dialog box and that did not help.  I always have a nicely centered inverted "L" in the frame with a close button on the bottom right of the frame.
Comment 10 jsullivan 2008-11-10 19:57:56 EST
Hmmm . . . I was looking for a way to modify container and user password policies through Advanced Properties.  I had a user for whom I wanted to not have the password expire.  I looked at the advanced properties to see the expiration date.  I then set the global permissions so passwords never expires and checked the Advanced Properties of the user again to see what the value was (assuming it would be 0).  It was not there.  So, I re-enabled password expiration in the global settings.  I check the user's Advanced Properties again and there was still not attribute for password expiration.  I closed the dialog, right clicked and select Manage Password Policy for user and, lo and behold, I have a usable password policy dialog!

I've just tried setting Password Policies for subtrees and it is all working just fine.  I do not know what changed.  Other than my toggling the expired flag and I also had just removed the anonymous browse right.

Argh! I'm trying to close the console so I can restart it and see if the changes persist.  It is telling me I have unsaved changes.  I cannot find them; there are not red dots on any of the tabs.  I will exit anyway and see what happens.

Bizarre! Now I'm back to the original problem - no usable password policy dialog for users or subtrees!

Argh! I'm back in the wilderness.  I've tried reproducing the steps above but I cannot return to having a usable dialog box.  I do not know what was so unique about what just happened.  Hope this helps - John
Comment 11 Rich Megginson 2008-12-02 12:32:41 EST
*** Bug 415011 has been marked as a duplicate of this bug. ***
Comment 12 Rich Megginson 2008-12-11 17:23:53 EST
Created attachment 326683 [details]
Comment 13 Rich Megginson 2008-12-11 17:28:35 EST
Created attachment 326684 [details]
pwp dialog startup
Comment 14 Rich Megginson 2008-12-11 17:28:57 EST
Created attachment 326685 [details]
pwp dialog too small
Comment 15 Rich Megginson 2008-12-11 17:59:34 EST
Created attachment 326687 [details]
cvs commit log

Reviewed by: nkinder (Thanks!)
Fix Description: The culprit was flexible but evil GridBagLayout.  Changing the layout in the dialog window to BorderLayout solved the problem.  Now, the window comes up with the panels flush with the edges of the dialog window.  Resizing the box too small results in h and v scroll bars.
pwp dialog at startup - https://bugzilla.redhat.com/attachment.cgi?id=326684
pwp dialog made too small - https://bugzilla.redhat.com/attachment.cgi?id=326685
Platforms tested: RHEL5
Flag Day: no
Doc impact: no
Comment 16 Jenny Galipeau 2009-03-20 12:58:40 EDT
fix verified DS 8.1 RHEL 5 and RHEL 4
password policy at all levels user and subtree - no empty window.
Comment 17 Rich Megginson 2009-03-25 12:08:22 EDT
*** Bug 492092 has been marked as a duplicate of this bug. ***
Comment 18 Chandrasekar Kannan 2009-04-29 19:00:47 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.